aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2000-10-29 21:51:22 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2000-10-29 21:51:22 +0000
commit26f09d36bf4ec79d44eb58de66b098eab158a130 (patch)
treeb982fc3f9dcf4c4eee1e5f49c14f860cf14bac68 /x11-toolkits
parentbf43cbab0cdf18aeb7f6db35fcea5544390583ce (diff)
downloadports-26f09d36bf4ec79d44eb58de66b098eab158a130.tar.gz
ports-26f09d36bf4ec79d44eb58de66b098eab158a130.zip
It's a perl module to access gtkglarea library.
Notes
Notes: svn path=/head/; revision=34419
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/p5-GtkGLArea/Makefile30
-rw-r--r--x11-toolkits/p5-GtkGLArea/distinfo1
-rw-r--r--x11-toolkits/p5-GtkGLArea/files/patch-Makefile.PL37
-rw-r--r--x11-toolkits/p5-GtkGLArea/pkg-comment1
-rw-r--r--x11-toolkits/p5-GtkGLArea/pkg-descr3
-rw-r--r--x11-toolkits/p5-GtkGLArea/pkg-plist18
7 files changed, 91 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index dca6c79e15ba..aa687feea629 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -53,6 +53,7 @@
SUBDIR += p5-Glade
SUBDIR += p5-Gnome
SUBDIR += p5-Gtk
+ SUBDIR += p5-GtkGLArea
SUBDIR += p5-Tcl-Tk
SUBDIR += p5-Tk
SUBDIR += pango
diff --git a/x11-toolkits/p5-GtkGLArea/Makefile b/x11-toolkits/p5-GtkGLArea/Makefile
new file mode 100644
index 000000000000..84ee2e1204ad
--- /dev/null
+++ b/x11-toolkits/p5-GtkGLArea/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-GtkGLArea
+# Date created: 30 Oct 2000
+# Whom: vanilla
+#
+# $FreeBSD$
+#
+
+PORTNAME= GtkGLArea
+PORTVERSION= 0.7004
+CATEGORIES= x11-toolkits lang perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Gtk
+PKGNAMEPREFIX= p5-
+DISTNAME= Gtk-Perl-${PORTVERSION}
+
+MAINTAINER= vanilla@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/mach/Gtk.pm:${PORTSDIR}/x11-toolkits/p5-Gtk
+LIB_DEPENDS= gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea
+
+USE_PERL5= yes
+USE_MESA= yes
+USE_GTK= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS} -L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/p5-GtkGLArea/distinfo b/x11-toolkits/p5-GtkGLArea/distinfo
new file mode 100644
index 000000000000..ebd8f2180544
--- /dev/null
+++ b/x11-toolkits/p5-GtkGLArea/distinfo
@@ -0,0 +1 @@
+MD5 (Gtk-Perl-0.7004.tar.gz) = f8f5d889e7a005667a93946ab1bf3e69
diff --git a/x11-toolkits/p5-GtkGLArea/files/patch-Makefile.PL b/x11-toolkits/p5-GtkGLArea/files/patch-Makefile.PL
new file mode 100644
index 000000000000..07d712016f72
--- /dev/null
+++ b/x11-toolkits/p5-GtkGLArea/files/patch-Makefile.PL
@@ -0,0 +1,37 @@
+--- Makefile.PL.orig Tue Jun 20 18:37:29 2000
++++ Makefile.PL Mon Oct 30 04:15:42 2000
+@@ -1,6 +1,5 @@
+ use ExtUtils::MakeMaker;
+ use File::Basename;
+-use blib '..';
+ use Gtk::Install::Files;
+ use Cwd;
+ require '../Depends.pm';
+@@ -12,9 +11,9 @@
+
+ $pm = {};
+
+-$inc = `gtk-config --cflags`;
++$inc = `$ENV{GTK_CONFIG} --cflags`;
+ chomp($inc);
+-$libs = "-lgtkgl -lMesaGL -lMesaGLU " . `gtk-config --libs`;
++$libs = "-lgtkgl -lMesaGL -lMesaGLU " . `$ENV{GTK_CONFIG} --libs`;
+ chomp($libs);
+ $nomesa = $libs;
+ $nomesa =~ s/Mesa//g;
+@@ -29,12 +28,12 @@
+ $typemaps, [keys %defs], [@defines], [@headers], $pm);
+
+ foreach (@typemaps) {
+- print "Add typemap: $Gtk::Install::Files::CORE/$_\n";
+- push(@$typemaps, cwd() .'/'.$Gtk::Install::Files::CORE . '/'. $_);
++ print "Add typemap: $Gtk::Install::Files::CORE$_\n";
++ push(@$typemaps, '/'.$Gtk::Install::Files::CORE . $_);
+ }
+
+ push(@defines, @Gtk::Install::Files::defines);
+-push(@defines, '-I../build', '-Ibuild', '-I.', '-I../Gtk');
++push(@defines, '-I../build', '-Ibuild', '-I.', '-I'.$Gtk::Install::Files::CORE);
+
+ $pm->{'GtkGLArea.pm'} = '$(INST_ARCHLIBDIR)/GLArea.pm';
+ $pm->{'build/GtkGLAreaTypes.pm'} = '$(INST_ARCHLIBDIR)/GLArea/Types.pm';
diff --git a/x11-toolkits/p5-GtkGLArea/pkg-comment b/x11-toolkits/p5-GtkGLArea/pkg-comment
new file mode 100644
index 000000000000..d9cffc7e17cc
--- /dev/null
+++ b/x11-toolkits/p5-GtkGLArea/pkg-comment
@@ -0,0 +1 @@
+The OpenGL widget module of Gtk-Perl
diff --git a/x11-toolkits/p5-GtkGLArea/pkg-descr b/x11-toolkits/p5-GtkGLArea/pkg-descr
new file mode 100644
index 000000000000..435b22f29be1
--- /dev/null
+++ b/x11-toolkits/p5-GtkGLArea/pkg-descr
@@ -0,0 +1,3 @@
+The OpenGL widget module of Gtk-Perl (Gtk::GLArea namespace).
+
+WWW: http://projects.prosa.it/gtkperl/
diff --git a/x11-toolkits/p5-GtkGLArea/pkg-plist b/x11-toolkits/p5-GtkGLArea/pkg-plist
new file mode 100644
index 000000000000..182121060ccd
--- /dev/null
+++ b/x11-toolkits/p5-GtkGLArea/pkg-plist
@@ -0,0 +1,18 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gtk/GLArea.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gtk/GLArea/Constants.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gtk/GLArea/Glut.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gtk/GLArea/Types.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gtk/GLArea/Install/Files.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gtk/GLArea/Install/GtkGLAreaTypemap
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gtk/GLArea/Install/GtkGLAreaDefs.h
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gtk/GLArea/Install/PerlGtkGLAreaInt.h
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gtk/GLArea/Install/pkg.typemap
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gtk/GLArea/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gtk/GLArea/GLArea.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gtk/GLArea/GLArea.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gtk/GLArea/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gtk/GLArea/Constants/autosplit.ix
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gtk/GLArea/Install
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gtk/GLArea
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gtk/GLArea/Constants
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gtk/GLArea