aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-04-23 05:07:11 +0000
committerWill Andrews <will@FreeBSD.org>2000-04-23 05:07:11 +0000
commitd0efc5b86b39bafb00f9b4b1ba580fa730aaca3f (patch)
treefce82abe1e3cb80b4f9faff03f538b2f0f817b34 /x11-toolkits
parentf19242cba485e49f8560a40cc285f966d84b2824 (diff)
downloadports-d0efc5b86b39bafb00f9b4b1ba580fa730aaca3f.tar.gz
ports-d0efc5b86b39bafb00f9b4b1ba580fa730aaca3f.zip
Add py-qt, a package of python bindings for Qt. This has been moved from
the original x11-toolkits/pyqt. PR: 17933 Submitted by: Arun Sharma <adsharm@sharmas.dhs.org> Move suggested by: nectar
Notes
Notes: svn path=/head/; revision=27914
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/py-qt/Makefile25
-rw-r--r--x11-toolkits/py-qt/distinfo1
-rw-r--r--x11-toolkits/py-qt/pkg-comment1
-rw-r--r--x11-toolkits/py-qt/pkg-descr2
-rw-r--r--x11-toolkits/py-qt/pkg-plist5
6 files changed, 35 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 8d81a49ba20e..efa3c88adc86 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -30,6 +30,7 @@
SUBDIR += pmw
SUBDIR += py-gnome
SUBDIR += py-gtk
+ SUBDIR += py-qt
SUBDIR += py-tkinter
SUBDIR += py-wxPython
SUBDIR += pykde
diff --git a/x11-toolkits/py-qt/Makefile b/x11-toolkits/py-qt/Makefile
new file mode 100644
index 000000000000..e1e1a4c90c74
--- /dev/null
+++ b/x11-toolkits/py-qt/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: PyQt
+# Version required: 0.9
+# Date created: Sun Oct 17 00:24:28 PDT 1999
+# Whom: adsharma@sharmas.dhs.org
+#
+# $FreeBSD$
+
+PORTNAME= py-qt
+PORTVERSION= 0.11.1
+CATEGORIES= x11-toolkits python
+MASTER_SITES= http://www.river-bank.demon.co.uk/software/
+DISTNAME= PyQt-${PORTVERSION}
+
+MAINTAINER= adsharma@sharmas.dhs.org
+
+LIB_DEPENDS= sip.2:${PORTSDIR}/devel/sip
+
+USE_QT= yes
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ENV= LDFLAGS=-lgcc
+CONFIGURE_ARGS= --with-qt-includes=${X11BASE}/include/X11/qt
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/py-qt/distinfo b/x11-toolkits/py-qt/distinfo
new file mode 100644
index 000000000000..1ecb4419df47
--- /dev/null
+++ b/x11-toolkits/py-qt/distinfo
@@ -0,0 +1 @@
+MD5 (PyQt-0.11.1.tar.gz) = c6b6ac3541c5d3b99e1e078b93047cce
diff --git a/x11-toolkits/py-qt/pkg-comment b/x11-toolkits/py-qt/pkg-comment
new file mode 100644
index 000000000000..cbb3bf8a7335
--- /dev/null
+++ b/x11-toolkits/py-qt/pkg-comment
@@ -0,0 +1 @@
+Python Bindings for Qt
diff --git a/x11-toolkits/py-qt/pkg-descr b/x11-toolkits/py-qt/pkg-descr
new file mode 100644
index 000000000000..45f88dfc904c
--- /dev/null
+++ b/x11-toolkits/py-qt/pkg-descr
@@ -0,0 +1,2 @@
+Python Bindings for Qt
+http://www.river-bank.demon.co.uk/software/
diff --git a/x11-toolkits/py-qt/pkg-plist b/x11-toolkits/py-qt/pkg-plist
new file mode 100644
index 000000000000..66389e0ebdde
--- /dev/null
+++ b/x11-toolkits/py-qt/pkg-plist
@@ -0,0 +1,5 @@
+lib/python1.5/lib-dynload/libqtcmodule-0.11.1.so
+lib/python1.5/lib-dynload/libqtcmodule.so
+lib/python1.5/qt.py
+@exec /sbin/ldconfig -m %D/lib
+@unexec /sbin/ldconfig -R