aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-08 18:36:39 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-08 18:36:39 +0000
commit2615706a311b9d06937c7c803d9372ecd5d87e8b (patch)
treeee9be2980750e01c35150422a0f37abd45f56922 /x11-toolkits
parentf7676015da7917195d45d2eaad5e9fd1ad7b9f26 (diff)
downloadports-2615706a311b9d06937c7c803d9372ecd5d87e8b.tar.gz
ports-2615706a311b9d06937c7c803d9372ecd5d87e8b.zip
* Teach vte about posix_openpt()
* Attempt to speed up terminal rendering a bit [1] * Don't leave children shells linger after logging out of GNOME [2] Submitted by: Jean-Yves Lefort <jylefort@brutele.be> [2] Obtained from: http://bugzilla.gnome.org/show_bug.cgi?id=122656 [1]
Notes
Notes: svn path=/head/; revision=106511
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/vte/Makefile4
-rw-r--r--x11-toolkits/vte/files/patch-configure21
-rw-r--r--x11-toolkits/vte/files/patch-src_pty.c13
-rw-r--r--x11-toolkits/vte/files/patch-src_vte.c28
4 files changed, 52 insertions, 14 deletions
diff --git a/x11-toolkits/vte/Makefile b/x11-toolkits/vte/Makefile
index 1560868f767b..b700a28b6ef0 100644
--- a/x11-toolkits/vte/Makefile
+++ b/x11-toolkits/vte/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vte
PORTVERSION= 0.11.10
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11-toolkits gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.11
@@ -23,7 +23,7 @@ USE_REINPLACE= yes
USE_BISON= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL_VER=13
-USE_GNOME= gnomeprefix gnomehack gtk20
+USE_GNOME= gnomeprefix gnomehack lthack gtk20
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
BSD_PTHREAD_LIBS="${PTHREAD_LIBS}"
diff --git a/x11-toolkits/vte/files/patch-configure b/x11-toolkits/vte/files/patch-configure
index bedd42f13994..f4a8f8c73607 100644
--- a/x11-toolkits/vte/files/patch-configure
+++ b/x11-toolkits/vte/files/patch-configure
@@ -1,13 +1,5 @@
---- configure.orig Mon Jun 16 17:50:24 2003
-+++ configure Tue Sep 30 01:22:24 2003
-@@ -19316,6 +19316,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+--- configure.orig Fri Mar 19 03:38:08 2004
++++ configure Wed Apr 7 02:56:46 2004
@@ -23732,10 +23733,6 @@
rm -f conftest*
@@ -19,6 +11,15 @@
cat >>confdefs.h <<\_ACEOF
#define _XOPEN_SOURCE 1
+@@ -23942,7 +23939,7 @@
+
+
+
+-for ac_func in cfmakeraw getpgid getpt grantpt unlockpt ptsname ptsname_r recvmsg
++for ac_func in cfmakeraw getpgid getpt posix_openpt grantpt unlockpt ptsname ptsname_r recvmsg
+ do
+ as_ac_var=`echo "ac_cv_func_$ac_func" | $as_tr_sh`
+ echo "$as_me:$LINENO: checking for $ac_func" >&5
@@ -25977,7 +25974,7 @@
diff --git a/x11-toolkits/vte/files/patch-src_pty.c b/x11-toolkits/vte/files/patch-src_pty.c
index 3601fb3d69f0..a31b1192bc2a 100644
--- a/x11-toolkits/vte/files/patch-src_pty.c
+++ b/x11-toolkits/vte/files/patch-src_pty.c
@@ -1,5 +1,5 @@
---- src/pty.c.orig Sat Apr 12 00:47:10 2003
-+++ src/pty.c Sat Apr 12 00:47:34 2003
+--- src/pty.c.orig Tue Jun 3 15:54:15 2003
++++ src/pty.c Wed Apr 7 02:55:57 2004
@@ -45,6 +45,7 @@
#include "pty.h"
@@ -8,3 +8,12 @@
#include "../gnome-pty-helper/gnome-pty.h"
#endif
+@@ -709,6 +710,8 @@
+ #ifdef HAVE_GETPT
+ /* Call the system's function for allocating a pty. */
+ fd = getpt();
++#elif defined(HAVE_POSIX_OPENPT)
++ fd = posix_openpt(O_RDWR | O_NOCTTY);
+ #else
+ /* Try to allocate a pty by accessing the pty master multiplex. */
+ fd = open("/dev/ptmx", O_RDWR | O_NOCTTY);
diff --git a/x11-toolkits/vte/files/patch-src_vte.c b/x11-toolkits/vte/files/patch-src_vte.c
new file mode 100644
index 000000000000..f3733b9f29d2
--- /dev/null
+++ b/x11-toolkits/vte/files/patch-src_vte.c
@@ -0,0 +1,28 @@
+--- src/vte.c.orig Mon Jun 16 17:15:09 2003
++++ src/vte.c Thu Apr 8 14:24:13 2004
+@@ -101,7 +101,7 @@
+ #define VTE_ADJUSTMENT_PRIORITY G_PRIORITY_DEFAULT_IDLE
+ #define VTE_INPUT_RETRY_PRIORITY G_PRIORITY_HIGH
+ #define VTE_INPUT_PRIORITY G_PRIORITY_DEFAULT_IDLE
+-#define VTE_CHILD_INPUT_PRIORITY G_PRIORITY_DEFAULT_IDLE
++#define VTE_CHILD_INPUT_PRIORITY G_PRIORITY_LOW
+ #define VTE_CHILD_OUTPUT_PRIORITY G_PRIORITY_HIGH
+ #define VTE_FX_PRIORITY G_PRIORITY_DEFAULT_IDLE
+ #define VTE_REGCOMP_FLAGS REG_EXTENDED
+@@ -109,7 +109,7 @@
+ #define VTE_INPUT_CHUNK_SIZE 0x1000
+ #define VTE_INVALID_SOURCE -1
+ #define VTE_INVALID_BYTE '?'
+-#define VTE_COALESCE_TIMEOUT 2
++#define VTE_COALESCE_TIMEOUT 50
+
+ /* The structure we use to hold characters we're supposed to display -- this
+ * includes any supported visible attributes. */
+@@ -11318,7 +11318,6 @@
+ terminal);
+ g_object_unref(G_OBJECT(terminal->pvt->pty_reaper));
+ }
+- terminal->pvt->pty_pid = -1;
+ terminal->pvt->pty_reaper = NULL;
+
+ /* Stop processing input. */