aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-04-27 12:39:47 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-04-27 12:39:47 +0000
commit7128279fe21a70b1cb96182100a80fbcf790de7b (patch)
tree7d6b6f340d8ef950903399a52f0f8d2b76f85af5 /x11-toolkits
parent1417b8324028cbe3818dc3dc1321897b1c2e58ec (diff)
downloadports-7128279fe21a70b1cb96182100a80fbcf790de7b.tar.gz
ports-7128279fe21a70b1cb96182100a80fbcf790de7b.zip
a Ruby interface to Tcl/Tk libraries
PR: 10907 Submitted by: Yasuhiro Fukuma <yasuf@big.or.jp>
Notes
Notes: svn path=/head/; revision=18157
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/ruby-tk/Makefile76
-rw-r--r--x11-toolkits/ruby-tk/pkg-comment1
-rw-r--r--x11-toolkits/ruby-tk/pkg-descr5
-rw-r--r--x11-toolkits/ruby-tk/pkg-plist17
-rw-r--r--x11-toolkits/ruby14-tk/Makefile76
-rw-r--r--x11-toolkits/ruby14-tk/distinfo1
-rw-r--r--x11-toolkits/ruby14-tk/pkg-comment1
-rw-r--r--x11-toolkits/ruby14-tk/pkg-descr5
-rw-r--r--x11-toolkits/ruby14-tk/pkg-plist17
9 files changed, 199 insertions, 0 deletions
diff --git a/x11-toolkits/ruby-tk/Makefile b/x11-toolkits/ruby-tk/Makefile
new file mode 100644
index 000000000000..5301e5b430c4
--- /dev/null
+++ b/x11-toolkits/ruby-tk/Makefile
@@ -0,0 +1,76 @@
+# New ports collection makefile for: rubytk
+# Version required: 1.2.5
+# Date created: 15 March 1999
+# Whom: Yasuhiro Fukuma <yasuf@big.or.jp>
+#
+# $Id$
+#
+
+DISTNAME= ruby-${VERSION}
+PKGNAME?= rubytk-${VERSION}
+CATEGORIES?= x11-toolkits
+MASTER_SITES= ftp://ftp.netlab.co.jp/pub/lang/ruby/${BRANCH_NAME}/ \
+ ftp://ftp.TokyoNet.AD.JP/pub/misc/ruby/${BRANCH_NAME}/ \
+ ftp://ftp.iij.ad.jp/pub/lang/ruby/${BRANCH_NAME}/ \
+ ftp://blade.nagaokaut.ac.jp/pub/lang/ruby/${BRANCH_NAME}/ \
+ ftp://ftp.krnet.ne.jp/pub/ruby/${BRANCH_NAME}/ \
+ ftp://mirror.nucba.ac.jp/mirror/ruby/${BRANCH_NAME}/
+
+MAINTAINER?= yasuf@big.or.jp
+
+BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+LIB_DEPENDS= ${TCL_LIB}.1:${PORTSDIR}/${TCL_CATEGORY}/tcl${TCL_VERSION} \
+ ${TK_LIB}.1:${PORTSDIR}/${TK_CATEGORY}/tk${TK_VERSION}
+
+USE_XLIB= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/ext
+CONFIGURE_ENV+= TCL_LIB="${TCL_LIB}" TK_LIB="${TK_LIB}" \
+ PREFIX="${PREFIX}" X11BASE="${X11BASE}"
+PLIST_SUB+= RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+
+VERSION= 1.2.5
+BRANCH_NAME= 1.2
+
+# Set these vars as the version numbers (without decimal points) of Tcl/Tk
+# you want to use with Ruby/Tk.
+# e.g.: make TCL_VERSION=42 TK_VERSION=76 WITH_TCL_JP=yes build
+TCL_VERSION?= 80
+TK_VERSION?= 80
+.if defined(WITH_TCL_JP)
+TCL_CATEGORY= japanese
+TK_CATEGORY= japanese
+TCL_JP= jp
+.else
+TCL_CATEGORY= lang
+TK_CATEGORY= x11-toolkits
+TCL_JP= # empty
+.endif
+
+TCL_LIB= tcl${TCL_VERSION}${TCL_JP}
+TK_LIB= tk${TK_VERSION}${TCL_JP}
+
+RUBY= ${PREFIX}/bin/ruby
+EXTS= tcltklib tk
+
+do-configure:
+.for dir in ${EXTS}
+ @${ECHO_MSG} "Configuring in ${dir}..."
+ @cd ${WRKSRC}/${dir}; ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb
+.endfor
+
+do-build:
+.for dir in ${EXTS}
+ @${ECHO_MSG} "Building in ${dir}..."
+ @cd ${WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${MAKE} ${ALL_TARGET}
+.endfor
+
+do-install:
+.for dir in ${EXTS}
+ @${ECHO_MSG} "Installing in ${dir}..."
+ @cd ${WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${MAKE} ${INSTALL_TARGET}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/ruby-tk/pkg-comment b/x11-toolkits/ruby-tk/pkg-comment
new file mode 100644
index 000000000000..143288549132
--- /dev/null
+++ b/x11-toolkits/ruby-tk/pkg-comment
@@ -0,0 +1 @@
+a Ruby interface to Tcl/Tk libraries.
diff --git a/x11-toolkits/ruby-tk/pkg-descr b/x11-toolkits/ruby-tk/pkg-descr
new file mode 100644
index 000000000000..1692318ccdd9
--- /dev/null
+++ b/x11-toolkits/ruby-tk/pkg-descr
@@ -0,0 +1,5 @@
+This is Ruby/Tk, a Ruby interface to Tcl/Tk libraries.
+It's a part of the official Ruby distribution.
+
+- Yasuhiro Fukuma
+yasuf@big.or.jp
diff --git a/x11-toolkits/ruby-tk/pkg-plist b/x11-toolkits/ruby-tk/pkg-plist
new file mode 100644
index 000000000000..e7556ea023a0
--- /dev/null
+++ b/x11-toolkits/ruby-tk/pkg-plist
@@ -0,0 +1,17 @@
+lib/ruby/%%RUBY_ARCH%%/tcltklib.so
+lib/ruby/%%RUBY_ARCH%%/tkutil.so
+lib/ruby/tcltk.rb
+lib/ruby/tk.rb
+lib/ruby/tkafter.rb
+lib/ruby/tkbgerror.rb
+lib/ruby/tkcanvas.rb
+lib/ruby/tkclass.rb
+lib/ruby/tkdialog.rb
+lib/ruby/tkentry.rb
+lib/ruby/tkfont.rb
+lib/ruby/tkmenubar.rb
+lib/ruby/tkmngfocus.rb
+lib/ruby/tkpalette.rb
+lib/ruby/tkscrollbox.rb
+lib/ruby/tktext.rb
+lib/ruby/tkvirtevent.rb
diff --git a/x11-toolkits/ruby14-tk/Makefile b/x11-toolkits/ruby14-tk/Makefile
new file mode 100644
index 000000000000..5301e5b430c4
--- /dev/null
+++ b/x11-toolkits/ruby14-tk/Makefile
@@ -0,0 +1,76 @@
+# New ports collection makefile for: rubytk
+# Version required: 1.2.5
+# Date created: 15 March 1999
+# Whom: Yasuhiro Fukuma <yasuf@big.or.jp>
+#
+# $Id$
+#
+
+DISTNAME= ruby-${VERSION}
+PKGNAME?= rubytk-${VERSION}
+CATEGORIES?= x11-toolkits
+MASTER_SITES= ftp://ftp.netlab.co.jp/pub/lang/ruby/${BRANCH_NAME}/ \
+ ftp://ftp.TokyoNet.AD.JP/pub/misc/ruby/${BRANCH_NAME}/ \
+ ftp://ftp.iij.ad.jp/pub/lang/ruby/${BRANCH_NAME}/ \
+ ftp://blade.nagaokaut.ac.jp/pub/lang/ruby/${BRANCH_NAME}/ \
+ ftp://ftp.krnet.ne.jp/pub/ruby/${BRANCH_NAME}/ \
+ ftp://mirror.nucba.ac.jp/mirror/ruby/${BRANCH_NAME}/
+
+MAINTAINER?= yasuf@big.or.jp
+
+BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+LIB_DEPENDS= ${TCL_LIB}.1:${PORTSDIR}/${TCL_CATEGORY}/tcl${TCL_VERSION} \
+ ${TK_LIB}.1:${PORTSDIR}/${TK_CATEGORY}/tk${TK_VERSION}
+
+USE_XLIB= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/ext
+CONFIGURE_ENV+= TCL_LIB="${TCL_LIB}" TK_LIB="${TK_LIB}" \
+ PREFIX="${PREFIX}" X11BASE="${X11BASE}"
+PLIST_SUB+= RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+
+VERSION= 1.2.5
+BRANCH_NAME= 1.2
+
+# Set these vars as the version numbers (without decimal points) of Tcl/Tk
+# you want to use with Ruby/Tk.
+# e.g.: make TCL_VERSION=42 TK_VERSION=76 WITH_TCL_JP=yes build
+TCL_VERSION?= 80
+TK_VERSION?= 80
+.if defined(WITH_TCL_JP)
+TCL_CATEGORY= japanese
+TK_CATEGORY= japanese
+TCL_JP= jp
+.else
+TCL_CATEGORY= lang
+TK_CATEGORY= x11-toolkits
+TCL_JP= # empty
+.endif
+
+TCL_LIB= tcl${TCL_VERSION}${TCL_JP}
+TK_LIB= tk${TK_VERSION}${TCL_JP}
+
+RUBY= ${PREFIX}/bin/ruby
+EXTS= tcltklib tk
+
+do-configure:
+.for dir in ${EXTS}
+ @${ECHO_MSG} "Configuring in ${dir}..."
+ @cd ${WRKSRC}/${dir}; ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb
+.endfor
+
+do-build:
+.for dir in ${EXTS}
+ @${ECHO_MSG} "Building in ${dir}..."
+ @cd ${WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${MAKE} ${ALL_TARGET}
+.endfor
+
+do-install:
+.for dir in ${EXTS}
+ @${ECHO_MSG} "Installing in ${dir}..."
+ @cd ${WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${MAKE} ${INSTALL_TARGET}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/ruby14-tk/distinfo b/x11-toolkits/ruby14-tk/distinfo
new file mode 100644
index 000000000000..b08ccbf9c196
--- /dev/null
+++ b/x11-toolkits/ruby14-tk/distinfo
@@ -0,0 +1 @@
+MD5 (ruby-1.2.5.tar.gz) = 3ec298b7697843733ea0230f23b626b6
diff --git a/x11-toolkits/ruby14-tk/pkg-comment b/x11-toolkits/ruby14-tk/pkg-comment
new file mode 100644
index 000000000000..143288549132
--- /dev/null
+++ b/x11-toolkits/ruby14-tk/pkg-comment
@@ -0,0 +1 @@
+a Ruby interface to Tcl/Tk libraries.
diff --git a/x11-toolkits/ruby14-tk/pkg-descr b/x11-toolkits/ruby14-tk/pkg-descr
new file mode 100644
index 000000000000..1692318ccdd9
--- /dev/null
+++ b/x11-toolkits/ruby14-tk/pkg-descr
@@ -0,0 +1,5 @@
+This is Ruby/Tk, a Ruby interface to Tcl/Tk libraries.
+It's a part of the official Ruby distribution.
+
+- Yasuhiro Fukuma
+yasuf@big.or.jp
diff --git a/x11-toolkits/ruby14-tk/pkg-plist b/x11-toolkits/ruby14-tk/pkg-plist
new file mode 100644
index 000000000000..e7556ea023a0
--- /dev/null
+++ b/x11-toolkits/ruby14-tk/pkg-plist
@@ -0,0 +1,17 @@
+lib/ruby/%%RUBY_ARCH%%/tcltklib.so
+lib/ruby/%%RUBY_ARCH%%/tkutil.so
+lib/ruby/tcltk.rb
+lib/ruby/tk.rb
+lib/ruby/tkafter.rb
+lib/ruby/tkbgerror.rb
+lib/ruby/tkcanvas.rb
+lib/ruby/tkclass.rb
+lib/ruby/tkdialog.rb
+lib/ruby/tkentry.rb
+lib/ruby/tkfont.rb
+lib/ruby/tkmenubar.rb
+lib/ruby/tkmngfocus.rb
+lib/ruby/tkpalette.rb
+lib/ruby/tkscrollbox.rb
+lib/ruby/tktext.rb
+lib/ruby/tkvirtevent.rb