aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorBill Fumerola <billf@FreeBSD.org>1999-03-07 23:52:56 +0000
committerBill Fumerola <billf@FreeBSD.org>1999-03-07 23:52:56 +0000
commite8d9657e5584dd3105850e3d820325951e7d11a6 (patch)
tree75607ccb96a86edc2b87c5ac028ad8c6c4aa55e7 /x11-toolkits
parent07e43910e4b1c42f19577eb3420da53edf1cb9a8 (diff)
downloadports-e8d9657e5584dd3105850e3d820325951e7d11a6.tar.gz
ports-e8d9657e5584dd3105850e3d820325951e7d11a6.zip
The Fast Light ToolKit ("FLTK", pronounces "fulltick") is a LGPL'd C++
graphical user interface for X. http://fltk.easysw.com PR: ports/10036 and ports/10053 Submitted by: Dima Sivachenko <dima@Chg.RU>
Notes
Notes: svn path=/head/; revision=17044
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/fltk/Makefile33
-rw-r--r--x11-toolkits/fltk/distinfo1
-rw-r--r--x11-toolkits/fltk/pkg-comment1
-rw-r--r--x11-toolkits/fltk/pkg-descr7
-rw-r--r--x11-toolkits/fltk/pkg-plist230
5 files changed, 272 insertions, 0 deletions
diff --git a/x11-toolkits/fltk/Makefile b/x11-toolkits/fltk/Makefile
new file mode 100644
index 000000000000..9ba961bd93dc
--- /dev/null
+++ b/x11-toolkits/fltk/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: fltk
+# Version required: 19990127
+# Date created: 11 February 1999
+# Whom: Dima Sivachenko <dima@Chg.RU>
+#
+# $Id: $
+#
+
+DISTNAME= fltk-19990127
+PKGNAME= fltk-1999.01.27
+CATEGORIES= x11-toolkit
+MASTER_SITES= ftp://ftp.easysw.com/pub/fltk/ \
+ ftp://ftp.northamerica.net/pub/ESP/fltk/ \
+ ftp://ftp.funet.fi/mirrors/ftp.easysw.com/pub/fltk/ \
+ ftp://ftp.kddlabs.co.jp/pub/lang/fltk/ \
+ ftp://ftp.c-com.net/pub/LinuxBerg/files/x11/dev/
+
+MAINTAINER= dima@chg.ru
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --enable-shared
+USE_X_PREFIX= yes
+
+post-install:
+
+ @ ${INSTALL_DATA} ${WRKSRC}/lib/libfltk.so.1 ${PREFIX}/lib
+ @ ${LDCONFIG} -m
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/fltk
+ @ ${INSTALL_DATA} ${WRKSRC}/documentation/* ${PREFIX}/share/doc/fltk
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/fltk/distinfo b/x11-toolkits/fltk/distinfo
new file mode 100644
index 000000000000..acec679bd827
--- /dev/null
+++ b/x11-toolkits/fltk/distinfo
@@ -0,0 +1 @@
+MD5 (fltk-19990127.tar.gz) = bba5eb56d853d94b9bd4ad4be1ccecde
diff --git a/x11-toolkits/fltk/pkg-comment b/x11-toolkits/fltk/pkg-comment
new file mode 100644
index 000000000000..62d59e215f37
--- /dev/null
+++ b/x11-toolkits/fltk/pkg-comment
@@ -0,0 +1 @@
+C++ graphical user interface for X
diff --git a/x11-toolkits/fltk/pkg-descr b/x11-toolkits/fltk/pkg-descr
new file mode 100644
index 000000000000..82f28d4cb5ac
--- /dev/null
+++ b/x11-toolkits/fltk/pkg-descr
@@ -0,0 +1,7 @@
+The Fast Light ToolKit ("FLTK", pronounces "fulltick") is a LGPL'd C++
+graphical user interface for X.
+
+http://fltk.easysw.com
+
+--Dima
+dima@chg.ru
diff --git a/x11-toolkits/fltk/pkg-plist b/x11-toolkits/fltk/pkg-plist
new file mode 100644
index 000000000000..f6e7a7e5b26b
--- /dev/null
+++ b/x11-toolkits/fltk/pkg-plist
@@ -0,0 +1,230 @@
+lib/libfltk.so.1
+@exec /sbin/ldconfig -m %D/lib
+@unexec /sbin/ldconfig -R
+bin/fluid
+include/FL/Fl_Image.H
+include/FL/Enumerations.H
+include/FL/Fl.H
+include/FL/Fl_Adjuster.H
+include/FL/Fl_Bitmap.H
+include/FL/Fl_Box.H
+include/FL/Fl_Browser.H
+include/FL/Fl_Browser_.H
+include/FL/Fl_Button.H
+include/FL/Fl_Chart.H
+include/FL/Fl_Check_Button.H
+include/FL/Fl_Choice.H
+include/FL/Fl_Clock.H
+include/FL/Fl_Color_Chooser.H
+include/FL/Fl_Counter.H
+include/FL/Fl_Dial.H
+include/FL/Fl_Double_Window.H
+include/FL/Fl_Fill_Dial.H
+include/FL/Fl_Fill_Slider.H
+include/FL/Fl_Float_Input.H
+include/FL/Fl_FormsBitmap.H
+include/FL/Fl_FormsPixmap.H
+include/FL/Fl_Free.H
+include/FL/Fl_Gl_Window.H
+include/FL/Fl_Group.H
+include/FL/Fl_Positioner.H
+include/FL/Fl_Hold_Browser.H
+include/FL/Fl_Hor_Fill_Slider.H
+include/FL/Fl_Hor_Nice_Slider.H
+include/FL/Fl_Hor_Slider.H
+include/FL/Fl_Hor_Value_Slider.H
+include/FL/Fl_Input.H
+include/FL/Fl_Input_.H
+include/FL/Fl_Int_Input.H
+include/FL/Fl_Light_Button.H
+include/FL/Fl_Line_Dial.H
+include/FL/Fl_Menu.H
+include/FL/Fl_Menu_.H
+include/FL/Fl_Menu_Bar.H
+include/FL/Fl_Menu_Button.H
+include/FL/Fl_Menu_Item.H
+include/FL/forms.H
+include/FL/Fl_Menu_Window.H
+include/FL/Fl_Multi_Browser.H
+include/FL/Fl_Multi_Label.H
+include/FL/Fl_Multiline_Input.H
+include/FL/Fl_Multiline_Output.H
+include/FL/Fl_Nice_Slider.H
+include/FL/Fl_Object.H
+include/FL/Fl_Output.H
+include/FL/Fl_Pack.H
+include/FL/Fl_Overlay_Window.H
+include/FL/Fl_Pixmap.H
+include/FL/Fl_Window.H
+include/FL/Fl_Radio_Button.H
+include/FL/Fl_Radio_Light_Button.H
+include/FL/Fl_Radio_Round_Button.H
+include/FL/Fl_Repeat_Button.H
+include/FL/Fl_Return_Button.H
+include/FL/Fl_Roller.H
+include/FL/Fl_Round_Button.H
+include/FL/x.H
+include/FL/Fl_Round_Clock.H
+include/FL/Fl_Scroll.H
+include/FL/Fl_Scrollbar.H
+include/FL/Fl_Secret_Input.H
+include/FL/Fl_Select_Browser.H
+include/FL/Fl_Simple_Counter.H
+include/FL/Fl_Single_Window.H
+include/FL/Fl_Slider.H
+include/FL/Fl_Tabs.H
+include/FL/Fl_Tile.H
+include/FL/Fl_Timer.H
+include/FL/Fl_Widget.H
+include/FL/Fl_Toggle_Button.H
+include/FL/Fl_Toggle_Light_Button.H
+include/FL/Fl_Toggle_Round_Button.H
+include/FL/Fl_Valuator.H
+include/FL/Fl_Value_Input.H
+include/FL/Fl_Value_Output.H
+include/FL/Fl_Value_Slider.H
+include/FL/dirent.h
+include/FL/filename.H
+include/FL/fl_ask.H
+include/FL/fl_draw.H
+include/FL/fl_file_chooser.H
+include/FL/fl_message.H
+include/FL/fl_show_colormap.H
+include/FL/fl_show_input.H
+include/FL/gl.h
+include/FL/gl2opengl.h
+include/FL/gl_draw.H
+include/FL/glut.H
+include/FL/math.h
+include/FL/menubar.h
+include/FL/win32.H
+@dirrm include/FL
+include/Fl
+share/doc/fltk/FL.gif
+share/doc/fltk/Fl_Adjuster.html
+share/doc/fltk/Fl_Box.html
+share/doc/fltk/Fl_Browser.html
+share/doc/fltk/Fl_Browser_.html
+share/doc/fltk/Fl_Button.html
+share/doc/fltk/Fl_Chart.html
+share/doc/fltk/Fl_Check_Button.gif
+share/doc/fltk/Fl_Check_Button.html
+share/doc/fltk/Fl_Choice.html
+share/doc/fltk/Fl_Clock.html
+share/doc/fltk/Fl_Color_Chooser.html
+share/doc/fltk/Fl_Counter.html
+share/doc/fltk/Fl_Dial.html
+share/doc/fltk/Fl_Double_Window.html
+share/doc/fltk/Fl_End.html
+share/doc/fltk/Fl_Float_Input.html
+share/doc/fltk/Fl_Free.html
+share/doc/fltk/Fl_Gl_Window.html
+share/doc/fltk/Fl_Group.html
+share/doc/fltk/Fl_Hold_Browser.html
+share/doc/fltk/Fl_Input.html
+share/doc/fltk/Fl_Input_.html
+share/doc/fltk/Fl_Int_Input.html
+share/doc/fltk/Fl_Light_Button.gif
+share/doc/fltk/Fl_Light_Button.html
+share/doc/fltk/Fl_Menu_.html
+share/doc/fltk/Fl_Menu_Bar.html
+share/doc/fltk/Fl_Menu_Button.html
+share/doc/fltk/Fl_Menu_Item.html
+share/doc/fltk/Fl_Menu_Window.html
+share/doc/fltk/Fl_Multi_Browser.html
+share/doc/fltk/Fl_Multiline_Input.html
+share/doc/fltk/Fl_Multiline_Output.html
+share/doc/fltk/Fl_Output.html
+share/doc/fltk/Fl_Overlay_Window.html
+share/doc/fltk/Fl_Pack.html
+share/doc/fltk/Fl_Positioner.html
+share/doc/fltk/Fl_Repeat_Button.html
+share/doc/fltk/Fl_Return_Button.gif
+share/doc/fltk/Fl_Return_Button.html
+share/doc/fltk/Fl_Roller.gif
+share/doc/fltk/Fl_Roller.html
+share/doc/fltk/Fl_Round_Button.gif
+share/doc/fltk/Fl_Round_Button.html
+share/doc/fltk/Fl_Scroll.gif
+share/doc/fltk/Fl_Scroll.html
+share/doc/fltk/Fl_Scrollbar.html
+share/doc/fltk/Fl_Secret_Input.html
+share/doc/fltk/Fl_Select_Browser.html
+share/doc/fltk/Fl_Single_Window.html
+share/doc/fltk/Fl_Slider.html
+share/doc/fltk/Fl_Tabs.html
+share/doc/fltk/Fl_Tile.gif
+share/doc/fltk/Fl_Tile.html
+share/doc/fltk/Fl_Timer.html
+share/doc/fltk/Fl_Valuator.html
+share/doc/fltk/Fl_Value_Input.gif
+share/doc/fltk/Fl_Value_Input.html
+share/doc/fltk/Fl_Value_Output.gif
+share/doc/fltk/Fl_Value_Output.html
+share/doc/fltk/Fl_Value_Slider.html
+share/doc/fltk/Fl_Widget.html
+share/doc/fltk/Fl_Window.html
+share/doc/fltk/adjuster1.gif
+share/doc/fltk/ask.C.gif
+share/doc/fltk/basics.html
+share/doc/fltk/bglogo.gif
+share/doc/fltk/boxtypes.gif
+share/doc/fltk/button.C.gif
+share/doc/fltk/buttons.gif
+share/doc/fltk/charts.gif
+share/doc/fltk/choice.gif
+share/doc/fltk/clock.gif
+share/doc/fltk/common.html
+share/doc/fltk/counter.gif
+share/doc/fltk/dial.gif
+share/doc/fltk/drawing.html
+share/doc/fltk/editor-replace.gif
+share/doc/fltk/editor.gif
+share/doc/fltk/editor.html
+share/doc/fltk/enumerations.html
+share/doc/fltk/events.html
+share/doc/fltk/filechooser.gif
+share/doc/fltk/fl_alert.gif
+share/doc/fltk/fl_ask.gif
+share/doc/fltk/fl_choice.gif
+share/doc/fltk/fl_color_chooser.jpg
+share/doc/fltk/fl_input.gif
+share/doc/fltk/fl_message.gif
+share/doc/fltk/fl_password.gif
+share/doc/fltk/fl_show_colormap.gif
+share/doc/fltk/fluid-org.gif
+share/doc/fltk/fluid.gif
+share/doc/fltk/fluid.html
+share/doc/fltk/fluid_main.gif
+share/doc/fltk/fluid_prefs.gif
+share/doc/fltk/fluid_widget.gif
+share/doc/fltk/forms.html
+share/doc/fltk/functions.html
+share/doc/fltk/glut.html
+share/doc/fltk/hello.C.gif
+share/doc/fltk/index.html
+share/doc/fltk/intro.html
+share/doc/fltk/license.html
+share/doc/fltk/menu.gif
+share/doc/fltk/menu_button.gif
+share/doc/fltk/menubar.gif
+share/doc/fltk/opengl.html
+share/doc/fltk/osissues.html
+share/doc/fltk/positioner.gif
+share/doc/fltk/preface.html
+share/doc/fltk/resizebox1.gif
+share/doc/fltk/resizebox2.gif
+share/doc/fltk/round_clock.gif
+share/doc/fltk/scrollbar.gif
+share/doc/fltk/shape.C.gif
+share/doc/fltk/slider.gif
+share/doc/fltk/subclassing.html
+share/doc/fltk/symbols.gif
+share/doc/fltk/tabs.gif
+share/doc/fltk/text.gif
+share/doc/fltk/valuators.gif
+share/doc/fltk/value_slider.gif
+share/doc/fltk/widgets.html
+share/doc/fltk/README
+share/doc/fltk/Makefile
+@dirrm share/doc/fltk