aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-01-29 12:14:18 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-01-29 12:14:18 +0000
commita80f0bd0dd7d4db692d81c1f2fe73f117828db0d (patch)
treee1ba2085cc7146328f30ef47d6e9941c2e1d05c3 /x11-toolkits
parent4adc5a8a717b83cd9a139cd4c92ea01102d602e2 (diff)
downloadports-a80f0bd0dd7d4db692d81c1f2fe73f117828db0d.tar.gz
ports-a80f0bd0dd7d4db692d81c1f2fe73f117828db0d.zip
Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;
the ECHO macro is set to "echo" by default, but it is set to "true" if make(1) is invoked with the -s option while ECHO_CMD is always set to the echo command.
Notes
Notes: svn path=/head/; revision=53961
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Xaw3d/Makefile2
-rw-r--r--x11-toolkits/libj2dplot/Makefile2
-rw-r--r--x11-toolkits/libjparser/Makefile2
-rw-r--r--x11-toolkits/libjsearch/Makefile2
-rw-r--r--x11-toolkits/libjtoolbar/Makefile2
-rw-r--r--x11-toolkits/libjtree/Makefile2
-rw-r--r--x11-toolkits/qt23/Makefile2
-rw-r--r--x11-toolkits/qt30/Makefile2
-rw-r--r--x11-toolkits/qt31/Makefile2
-rw-r--r--x11-toolkits/qt32/Makefile2
-rw-r--r--x11-toolkits/qt33/Makefile2
-rw-r--r--x11-toolkits/xenostep/Makefile2
12 files changed, 12 insertions, 12 deletions
diff --git a/x11-toolkits/Xaw3d/Makefile b/x11-toolkits/Xaw3d/Makefile
index f6151a4faef1..42b7cf9dd30a 100644
--- a/x11-toolkits/Xaw3d/Makefile
+++ b/x11-toolkits/Xaw3d/Makefile
@@ -27,7 +27,7 @@ post-extract:
.if exists(${X11BASE}/bin/XFree86)
post-build:
${CP} ${PKGDIR}/pkg-plist ${PLIST}
- ${ECHO} "lib/libXaw3d.so.7" >> ${PLIST}
+ ${ECHO_CMD} "lib/libXaw3d.so.7" >> ${PLIST}
.endif
# Workaround a bug in egcs on FreeBSD/Alpha.
diff --git a/x11-toolkits/libj2dplot/Makefile b/x11-toolkits/libj2dplot/Makefile
index 27f12f2b2c21..e8ee04c66027 100644
--- a/x11-toolkits/libj2dplot/Makefile
+++ b/x11-toolkits/libj2dplot/Makefile
@@ -82,7 +82,7 @@ post-extract:
.endfor
post-patch:
- @${ECHO} "SEARCHDIRS += ${PORTINCLUDES}" >> \
+ @${ECHO_CMD} "SEARCHDIRS += ${PORTINCLUDES}" >> \
${WRKSRC}/${EXTRALIBFILES_MAKE_WRKSRC}/jx_constants
post-build:
diff --git a/x11-toolkits/libjparser/Makefile b/x11-toolkits/libjparser/Makefile
index e28f6aa30928..b98ae97fde57 100644
--- a/x11-toolkits/libjparser/Makefile
+++ b/x11-toolkits/libjparser/Makefile
@@ -81,7 +81,7 @@ post-extract:
.endfor
post-patch:
- @${ECHO} "SEARCHDIRS += ${PORTINCLUDES}" >> \
+ @${ECHO_CMD} "SEARCHDIRS += ${PORTINCLUDES}" >> \
${WRKSRC}/${EXTRALIBFILES_MAKE_WRKSRC}/jx_constants
post-build:
diff --git a/x11-toolkits/libjsearch/Makefile b/x11-toolkits/libjsearch/Makefile
index 49906b651a46..38358d083bdb 100644
--- a/x11-toolkits/libjsearch/Makefile
+++ b/x11-toolkits/libjsearch/Makefile
@@ -86,7 +86,7 @@ post-extract:
.endfor
post-patch:
- @${ECHO} "SEARCHDIRS += ${PORTINCLUDES}" >> \
+ @${ECHO_CMD} "SEARCHDIRS += ${PORTINCLUDES}" >> \
${WRKSRC}/${EXTRALIBFILES_MAKE_WRKSRC}/jx_constants
post-build:
diff --git a/x11-toolkits/libjtoolbar/Makefile b/x11-toolkits/libjtoolbar/Makefile
index 6595316718a3..006a7d34acc8 100644
--- a/x11-toolkits/libjtoolbar/Makefile
+++ b/x11-toolkits/libjtoolbar/Makefile
@@ -88,7 +88,7 @@ post-extract:
.endfor
post-patch:
- @${ECHO} "SEARCHDIRS += ${PORTINCLUDES}" >> \
+ @${ECHO_CMD} "SEARCHDIRS += ${PORTINCLUDES}" >> \
${WRKSRC}/${EXTRALIBFILES_MAKE_WRKSRC}/jx_constants
pre-build:
diff --git a/x11-toolkits/libjtree/Makefile b/x11-toolkits/libjtree/Makefile
index 24737bdd46db..15d25ec58bd7 100644
--- a/x11-toolkits/libjtree/Makefile
+++ b/x11-toolkits/libjtree/Makefile
@@ -82,7 +82,7 @@ post-extract:
.endfor
post-patch:
- @${ECHO} "SEARCHDIRS += ${PORTINCLUDES}" >> \
+ @${ECHO_CMD} "SEARCHDIRS += ${PORTINCLUDES}" >> \
${WRKSRC}/${EXTRALIBFILES_MAKE_WRKSRC}/jx_constants
post-build:
diff --git a/x11-toolkits/qt23/Makefile b/x11-toolkits/qt23/Makefile
index b43fe6c79f49..6784057df9be 100644
--- a/x11-toolkits/qt23/Makefile
+++ b/x11-toolkits/qt23/Makefile
@@ -39,7 +39,7 @@ CONFIGURE_ARGS= -system-zlib -system-libpng -system-jpeg -sm -gif \
CONFIGURE_ARGS+= -debug
.endif
-CONFIGURE_ENV= ${ECHO} yes | QTDIR=${WRKSRC}
+CONFIGURE_ENV= ${ECHO_CMD} yes | QTDIR=${WRKSRC}
.if defined(MAKE_JOBS)
MAKE_ARGS+= MAKE="${GMAKE} -j${MAKE_JOBS}"
.endif
diff --git a/x11-toolkits/qt30/Makefile b/x11-toolkits/qt30/Makefile
index b43fe6c79f49..6784057df9be 100644
--- a/x11-toolkits/qt30/Makefile
+++ b/x11-toolkits/qt30/Makefile
@@ -39,7 +39,7 @@ CONFIGURE_ARGS= -system-zlib -system-libpng -system-jpeg -sm -gif \
CONFIGURE_ARGS+= -debug
.endif
-CONFIGURE_ENV= ${ECHO} yes | QTDIR=${WRKSRC}
+CONFIGURE_ENV= ${ECHO_CMD} yes | QTDIR=${WRKSRC}
.if defined(MAKE_JOBS)
MAKE_ARGS+= MAKE="${GMAKE} -j${MAKE_JOBS}"
.endif
diff --git a/x11-toolkits/qt31/Makefile b/x11-toolkits/qt31/Makefile
index b43fe6c79f49..6784057df9be 100644
--- a/x11-toolkits/qt31/Makefile
+++ b/x11-toolkits/qt31/Makefile
@@ -39,7 +39,7 @@ CONFIGURE_ARGS= -system-zlib -system-libpng -system-jpeg -sm -gif \
CONFIGURE_ARGS+= -debug
.endif
-CONFIGURE_ENV= ${ECHO} yes | QTDIR=${WRKSRC}
+CONFIGURE_ENV= ${ECHO_CMD} yes | QTDIR=${WRKSRC}
.if defined(MAKE_JOBS)
MAKE_ARGS+= MAKE="${GMAKE} -j${MAKE_JOBS}"
.endif
diff --git a/x11-toolkits/qt32/Makefile b/x11-toolkits/qt32/Makefile
index b43fe6c79f49..6784057df9be 100644
--- a/x11-toolkits/qt32/Makefile
+++ b/x11-toolkits/qt32/Makefile
@@ -39,7 +39,7 @@ CONFIGURE_ARGS= -system-zlib -system-libpng -system-jpeg -sm -gif \
CONFIGURE_ARGS+= -debug
.endif
-CONFIGURE_ENV= ${ECHO} yes | QTDIR=${WRKSRC}
+CONFIGURE_ENV= ${ECHO_CMD} yes | QTDIR=${WRKSRC}
.if defined(MAKE_JOBS)
MAKE_ARGS+= MAKE="${GMAKE} -j${MAKE_JOBS}"
.endif
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
index b43fe6c79f49..6784057df9be 100644
--- a/x11-toolkits/qt33/Makefile
+++ b/x11-toolkits/qt33/Makefile
@@ -39,7 +39,7 @@ CONFIGURE_ARGS= -system-zlib -system-libpng -system-jpeg -sm -gif \
CONFIGURE_ARGS+= -debug
.endif
-CONFIGURE_ENV= ${ECHO} yes | QTDIR=${WRKSRC}
+CONFIGURE_ENV= ${ECHO_CMD} yes | QTDIR=${WRKSRC}
.if defined(MAKE_JOBS)
MAKE_ARGS+= MAKE="${GMAKE} -j${MAKE_JOBS}"
.endif
diff --git a/x11-toolkits/xenostep/Makefile b/x11-toolkits/xenostep/Makefile
index 062aa4c0acaf..b4703109d7c6 100644
--- a/x11-toolkits/xenostep/Makefile
+++ b/x11-toolkits/xenostep/Makefile
@@ -26,7 +26,7 @@ DIRS= "XenoStep Classic" "XenoStep Classic Small" "XenoStep HeliX" \
post-extract:
for dir in ${DIRS}; do \
- destdir=`${ECHO} $${dir} | ${SED} 's| |_|g'`; \
+ destdir=`${ECHO_CMD} $${dir} | ${SED} 's| |_|g'`; \
${CP} -R "${WRKSRC}/$${dir}" "${WRKSRC}/$${destdir}"; \
done