aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-01-21 17:47:19 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-01-21 17:47:19 +0000
commitb3967937cc752f29982fd0fa212c7b2955b8ea2f (patch)
tree9099bd36e7afa2d4108f64e1d98dd558b93a976e /x11-toolkits
parent085ebfad27c84f39b1bf9b5eabfba7a9ba42d421 (diff)
downloadports-b3967937cc752f29982fd0fa212c7b2955b8ea2f.tar.gz
ports-b3967937cc752f29982fd0fa212c7b2955b8ea2f.zip
Otk is a portable widget library for making graphical user interfaces for
application programs. It emphasizes simplicity without eliminating capability. It is based on OpenGL, and C. WWW: http://otk.sourceforge.net/ PR: ports/92103 Submitted by: Igor Pokrovsky <ip@doom.homeunix.org>
Notes
Notes: svn path=/head/; revision=154067
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/otk/Makefile33
-rw-r--r--x11-toolkits/otk/distinfo3
-rw-r--r--x11-toolkits/otk/files/patch-otk__lib.c24
-rw-r--r--x11-toolkits/otk/files/patch-otk__lib.h10
-rw-r--r--x11-toolkits/otk/pkg-descr19
6 files changed, 90 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 808010af3c0a..1f5b9dac4fc8 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -104,6 +104,7 @@
SUBDIR += ocaml-lablgtk
SUBDIR += ocaml-lablgtk2
SUBDIR += open-motif
+ SUBDIR += otk
SUBDIR += p5-GdkImlib
SUBDIR += p5-GdkPixbuf
SUBDIR += p5-Glade2
diff --git a/x11-toolkits/otk/Makefile b/x11-toolkits/otk/Makefile
new file mode 100644
index 000000000000..5841545944ba
--- /dev/null
+++ b/x11-toolkits/otk/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: otk
+# Date created: 21 Jan 2006
+# Whom: Igor Pokrovsky <ip@doom.homeunix.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= otk
+PORTVERSION= 0.40
+CATEGORIES= x11-toolkits graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}_lib_v${PORTVERSION}
+
+MAINTAINER= ip@doom.homeunix.org
+COMMENT= An OpenGL based GUI widget library
+
+USE_GL= yes
+USE_X_PREFIX= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}_lib
+
+PLIST_FILES= lib/libotk.a include/gadget_lib.h include/otk_lib.h
+
+do-build:
+ cd ${WRKSRC} && \
+ ${CC} ${CFLAGS} -I${X11BASE}/include -c ./otk_lib.c && \
+ ar q ./libotk.a ./otk_lib.o && ranlib ./libotk.a
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/libotk.a ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/otk/distinfo b/x11-toolkits/otk/distinfo
new file mode 100644
index 000000000000..5d08bbd27572
--- /dev/null
+++ b/x11-toolkits/otk/distinfo
@@ -0,0 +1,3 @@
+MD5 (otk_lib_v0.40.tar.gz) = 30cff8d872aa6457e359f345555d3c22
+SHA256 (otk_lib_v0.40.tar.gz) = 867d6d17b1277598d5f5bdb4b9d353c994d0982c7b6b4e01942ebd0f4a1796af
+SIZE (otk_lib_v0.40.tar.gz) = 60273
diff --git a/x11-toolkits/otk/files/patch-otk__lib.c b/x11-toolkits/otk/files/patch-otk__lib.c
new file mode 100644
index 000000000000..856d7ba5724c
--- /dev/null
+++ b/x11-toolkits/otk/files/patch-otk__lib.c
@@ -0,0 +1,24 @@
+--- otk_lib.c.orig
++++ otk_lib.c
+@@ -70,6 +70,7 @@
+
+ #if (PLATFORM_KIND==Posix_Platform)
+ // #include <unistd.h>
++ #include <sys/time.h>
+ #define GlutEnabled 0 /* Choice: 0=Use X-windows, 1=Use Glut. */
+ #define WinGLEnabled 0
+ #ifndef SocEnabled
+@@ -111,6 +112,7 @@
+ #endif
+
+ #include "otk_lib.h"
++#include "gadget_lib.h"
+
+ int Otk_verbose=0;
+ int OtkWindowSizeX=-1, OtkWindowSizeY=-1;
+@@ -4517,3 +4519,5 @@
+ glutMainLoop();
+ #endif
+ }
++
++#include "gadget_lib.c"
diff --git a/x11-toolkits/otk/files/patch-otk__lib.h b/x11-toolkits/otk/files/patch-otk__lib.h
new file mode 100644
index 000000000000..c9dcfb7b25ef
--- /dev/null
+++ b/x11-toolkits/otk/files/patch-otk__lib.h
@@ -0,0 +1,10 @@
+--- otk_lib.h.orig
++++ otk_lib.h
+@@ -283,4 +283,7 @@
+
+ OtkFont *Otk_Read_SVG_Font( char *filename ); /* FONTS insertion */
+
++extern struct OtkObjectInstance *OtkRootObject, *OtkOuterWindow,
++ *Otk_keyboard_focus, *Otk_OpenMenu;
++
+ #endif
diff --git a/x11-toolkits/otk/pkg-descr b/x11-toolkits/otk/pkg-descr
new file mode 100644
index 000000000000..0741c8b949b0
--- /dev/null
+++ b/x11-toolkits/otk/pkg-descr
@@ -0,0 +1,19 @@
+Otk is a portable widget library for making graphical user interfaces for
+application programs. It emphasizes simplicity without eliminating capability.
+It is based on OpenGL, and C. Otk provides the following basic widgets:
+
+ * Panel - The "container" widget,
+ * Text Label - Text labels,
+ * Button - Buttons with labels and call-backs
+ to user functions,
+ * Text Form Box - Accept text with function call-back,
+ also scrollable editor window,
+ * Pull-down Menu - Display hierarchical menu-lists with user
+ function call-backs on mouse release,
+ * Slider Control - Slider control with call-back,
+ * Sub-windows - Detachable self-managed windows,
+ * Gadgets - High level widgets
+
+and many others.
+
+WWW: http://otk.sourceforge.net/