aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/compizconfig-python/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-09-18 17:33:59 +0000
committerSteve Wills <swills@FreeBSD.org>2018-09-18 17:33:59 +0000
commit9e4388fca47d89b6060e6d4cff4f3bd964e40697 (patch)
tree19373c2b52b0fb0646876ca1026122ffd1ee4f3f /x11-wm/compizconfig-python/Makefile
parentd0446982a0a859ebe91961bc9ddd1adac4f5d197 (diff)
downloadports-9e4388fca47d89b6060e6d4cff4f3bd964e40697.tar.gz
ports-9e4388fca47d89b6060e6d4cff4f3bd964e40697.zip
x11-wm/compizconfig-python: Add missing dependencies
While here, add LICENSE and pet portlint PR: 230912 Submitted by: Samy Mahmoudi <samy.mahmoudi@gmail.com> Approved by: maintainer timeout (freebsd-ports@dan.me.uk, >3 weeks)
Notes
Notes: svn path=/head/; revision=480042
Diffstat (limited to 'x11-wm/compizconfig-python/Makefile')
-rw-r--r--x11-wm/compizconfig-python/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/x11-wm/compizconfig-python/Makefile b/x11-wm/compizconfig-python/Makefile
index 9c68d88e0d37..1feecab1514b 100644
--- a/x11-wm/compizconfig-python/Makefile
+++ b/x11-wm/compizconfig-python/Makefile
@@ -3,23 +3,28 @@
PORTNAME= compizconfig-python
PORTVERSION= 0.8.4
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= x11-wm
MASTER_SITES= http://releases.compiz.org/${PORTVERSION}/
MAINTAINER= freebsd-ports@dan.me.uk
COMMENT= Python bindings for the compizconfig library
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= \
${LOCALBASE}/libdata/pkgconfig/compiz.pc:x11-wm/compiz \
${LOCALBASE}/libdata/pkgconfig/libcompizconfig.pc:x11-wm/libcompizconfig \
${PYTHON_PKGNAMEPREFIX}pyrex>0:devel/pyrex@${PY_FLAVOR}
+LIB_DEPENDS= libstartup-notification-1.so:x11/startup-notification
RUN_DEPENDS:= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
USES= gmake libtool pathfix pkgconfig python:2.7 tar:bzip2
-USE_GNOME= glib20
+USE_GNOME= glib20 libxml2 libxslt
USE_PYTHON= flavors
+USE_XORG= ice sm x11 xcomposite xdamage xext xfixes xinerama xrandr
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/compizconfig.so