aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/epiwm
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-08-22 03:08:54 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-08-22 03:08:54 +0000
commit511b2f4219c9d069377a3e79a51ad6b13338c0cf (patch)
treefdbec9cac4a4d9538ac27f381c6e024edf141fb8 /x11-wm/epiwm
parent1cf1099e3ff644108f9a767340b8975b7846a93e (diff)
downloadports-511b2f4219c9d069377a3e79a51ad6b13338c0cf.tar.gz
ports-511b2f4219c9d069377a3e79a51ad6b13338c0cf.zip
new port of epiwm window manager
Notes
Notes: svn path=/head/; revision=87473
Diffstat (limited to 'x11-wm/epiwm')
-rw-r--r--x11-wm/epiwm/Makefile76
-rw-r--r--x11-wm/epiwm/distinfo1
-rw-r--r--x11-wm/epiwm/pkg-descr9
3 files changed, 86 insertions, 0 deletions
diff --git a/x11-wm/epiwm/Makefile b/x11-wm/epiwm/Makefile
new file mode 100644
index 000000000000..28fc83b747fe
--- /dev/null
+++ b/x11-wm/epiwm/Makefile
@@ -0,0 +1,76 @@
+# New ports collection makefile for: epiwm
+# Date created: 2002-06-04
+# Whom: trevor
+#
+# $FreeBSD$
+#
+
+PORTNAME= epiwm
+PORTVERSION= 0.5.6
+CATEGORIES= x11-wm
+MASTER_SITES= http://www.nongnu.org/epiwm/download/
+
+MAINTAINER= trevor@FreeBSD.org
+COMMENT= Another fast, small, configurable window manager
+
+BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
+ automake14:${PORTSDIR}/devel/automake14
+LIB_DEPENDS= Imlib.5:${PORTSDIR}/graphics/imlib \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ ungif.5:${PORTSDIR}/graphics/libungif
+
+CONFIG= icons key menu start style window workspace
+DOCS= AUTHORS BUGS COPYING ChangeLog EPIwm-0.5.6.lsm INSTALL NEWS \
+ README TODO
+PLIST= ${WRKDIR}/pkg-plist
+USE_AUTOCONF= yes
+USE_X_PREFIX= yes
+
+post-extract:
+# Avoid having to read this file.
+ ${RM} ${WRKSRC}/configure
+
+do-patch:
+ ${CP} -p ${WRKSRC}/configure.in ${WRKSRC}/configure.in.orig
+ ${SED} -e 's|/etc/X11/epiwm|${PREFIX}/etc/epiwm|' \
+ < ${WRKSRC}/configure.in.orig > ${WRKSRC}/configure.in
+
+pre-configure:
+ cd ${WRKSRC} && automake14 -i && autoconf213
+
+pre-install:
+ ${RM} -f ${PLIST}
+.for ii in epiwm logoepiwm epiwm.inst
+ ${ECHO_CMD} bin/${ii} >> ${PLIST}
+.endfor
+.for ii in ${CONFIG}
+ ${ECHO_CMD} etc/epiwm/${ii} >> ${PLIST}
+.endfor
+.if !defined(NOPORTDOCS)
+.for ii in ${DOCS}
+ ${ECHO_CMD} share/doc/epiwm/${ii} >> ${PLIST}
+.endfor
+.for ii in etc share/doc
+ ${ECHO_CMD} @dirrm ${ii}/epiwm >> ${PLIST}
+.endfor
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/epiwm \
+ ${WRKSRC}/modules/logoepiwm/logoepiwm ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/epiwm.inst ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/etc/epiwm
+.for ii in ${CONFIG}
+ ${INSTALL_DATA} ${WRKSRC}/config/${ii} ${PREFIX}/etc/epiwm
+.endfor
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for ii in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${ii} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/epiwm/distinfo b/x11-wm/epiwm/distinfo
new file mode 100644
index 000000000000..cc58e75b6214
--- /dev/null
+++ b/x11-wm/epiwm/distinfo
@@ -0,0 +1 @@
+MD5 (epiwm-0.5.6.tar.gz) = 90f8d133fa3efeefce933ca6f02ae323
diff --git a/x11-wm/epiwm/pkg-descr b/x11-wm/epiwm/pkg-descr
new file mode 100644
index 000000000000..44da4e3cda51
--- /dev/null
+++ b/x11-wm/epiwm/pkg-descr
@@ -0,0 +1,9 @@
+from the home page:
+
+ EPIwm is a window manager which is intended to be small,
+ fast and configurable while maintaining a large feature
+ set. It is a computer school project from EPITA under GPL.
+
+Users must run the epiwm.inst script before starting epiwm.
+
+WWW: http://www.nongnu.org/epiwm