aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/fluxspace
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-06 05:47:28 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-06 05:47:28 +0000
commit494551bd5087e94ad21cc79f8813b3a16c617dba (patch)
tree5b9bfe49383375fc9f5971768a083df4498ee937 /x11-wm/fluxspace
parent4bb6ffde105d5c3b0ec09ddd564d5081c19d7074 (diff)
downloadports-494551bd5087e94ad21cc79f8813b3a16c617dba.tar.gz
ports-494551bd5087e94ad21cc79f8813b3a16c617dba.zip
New port: x11-wm/fluxspace
Fluxspace provides a framework and modules for adding event-driven behavior to Fluxbox as an external component. A variety of features and enhancements can be introduced more easily without modifying Fluxbox's C++ code. WWW: http://www.isomedia.com/homes/stevencooper/projects/fluxspace.html PR: ports/50405 Submitted by: Eirik Nygaard <eirikn@bluezone.no>
Notes
Notes: svn path=/head/; revision=90383
Diffstat (limited to 'x11-wm/fluxspace')
-rw-r--r--x11-wm/fluxspace/Makefile37
-rw-r--r--x11-wm/fluxspace/distinfo1
-rw-r--r--x11-wm/fluxspace/files/patch-configure263
-rw-r--r--x11-wm/fluxspace/files/patch-examples::fluxspace.xml11
-rw-r--r--x11-wm/fluxspace/pkg-descr10
-rw-r--r--x11-wm/fluxspace/pkg-message2
-rw-r--r--x11-wm/fluxspace/pkg-plist52
7 files changed, 376 insertions, 0 deletions
diff --git a/x11-wm/fluxspace/Makefile b/x11-wm/fluxspace/Makefile
new file mode 100644
index 000000000000..41ef3ec147d2
--- /dev/null
+++ b/x11-wm/fluxspace/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: fluxspace
+# Date created: 20 March 2003
+# Whom: Eirik Nygaard <eirikn@bluezone.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fluxspace
+PORTVERSION= 0.0.3
+CATEGORIES= x11-wm
+MASTER_SITES= http://www.isomedia.com/homes/stevencooper/files/
+
+MAINTAINER= eirikn@bluezone.no
+COMMENT= A window manager and workspace enhancer and integrator
+
+BUILD_DEPENDS= imlib2-config:${PORTSDIR}/graphics/imlib2 \
+ swig:${PORTSDIR}/devel/swig13
+
+.if defined(WITH_IDESK)
+RUN_DEPENDS+= idesk:${PORTSDIR}/x11/idesk
+.endif
+.if defined(WITH_ROX-FILER)
+RUN_DEPENDS+= rox:${PORTSDIR}/x11-fm/rox-filer
+.endif
+
+USE_PYTHON= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+pre-everything::
+ @${ECHO_CMD} "WITH_IDESK - To install idesk"
+ @${ECHO_CMD} "WITH_ROX-FILER - To install rox-filer"
+
+post-install::
+ @${CAT} pkg-message
+
+.include <bsd.port.mk>
diff --git a/x11-wm/fluxspace/distinfo b/x11-wm/fluxspace/distinfo
new file mode 100644
index 000000000000..4bd73c7e063a
--- /dev/null
+++ b/x11-wm/fluxspace/distinfo
@@ -0,0 +1 @@
+MD5 (fluxspace-0.0.3.tar.gz) = 0791efe124e98689be26c2ec290bbb59
diff --git a/x11-wm/fluxspace/files/patch-configure b/x11-wm/fluxspace/files/patch-configure
new file mode 100644
index 000000000000..c0f8ccfa0c3c
--- /dev/null
+++ b/x11-wm/fluxspace/files/patch-configure
@@ -0,0 +1,263 @@
+--- configure.old Mon Jan 20 04:01:19 2003
++++ configure Wed Mar 26 15:55:09 2003
+@@ -10505,260 +10505,6 @@
+ rm -f conftest.err conftest.$ac_ext
+ CPPFLAGS="$save_CPPFLAGS"
+
+-
+-
+- # Extract the first word of "python-config", so it can be a program name with args.
+-set dummy python-config; ac_word=$2
+-echo "$as_me:$LINENO: checking for $ac_word" >&5
+-echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
+-if test "${ac_cv_path_PYTHON_CONFIG_PROG+set}" = set; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+- case $PYTHON_CONFIG_PROG in
+- [\\/]* | ?:[\\/]*)
+- ac_cv_path_PYTHON_CONFIG_PROG="$PYTHON_CONFIG_PROG" # Let the user override the test with a path.
+- ;;
+- *)
+- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $PATH
+-do
+- IFS=$as_save_IFS
+- test -z "$as_dir" && as_dir=.
+- for ac_exec_ext in '' $ac_executable_extensions; do
+- if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+- ac_cv_path_PYTHON_CONFIG_PROG="$as_dir/$ac_word$ac_exec_ext"
+- echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
+- break 2
+- fi
+-done
+-done
+-
+- ;;
+-esac
+-fi
+-PYTHON_CONFIG_PROG=$ac_cv_path_PYTHON_CONFIG_PROG
+-
+-if test -n "$PYTHON_CONFIG_PROG"; then
+- echo "$as_me:$LINENO: result: $PYTHON_CONFIG_PROG" >&5
+-echo "${ECHO_T}$PYTHON_CONFIG_PROG" >&6
+-else
+- echo "$as_me:$LINENO: result: no" >&5
+-echo "${ECHO_T}no" >&6
+-fi
+-
+- PYTHON_FULL_NAME="python${PYTHON_VERSION}"
+- if test -z "$PYTHON_CONFIG_PROG" ; then
+- PYTHON_TRY_LDFLAGS="-l${PYTHON_FULL_NAME}"
+- else
+- PYTHON_TRY_LDFLAGS="`$PYTHON_CONFIG_PROG`"
+- fi
+-
+- if test -z "$PYTHON_LDFLAGS"; then
+- try_link_python_save_LDFLAGS="$LDFLAGS"
+- LDFLAGS="$LDFLAGS $PYTHON_TRY_LDFLAGS"
+- as_ac_Lib=`echo "ac_cv_lib_$PYTHON_FULL_NAME''_Py_Initialize" | $as_tr_sh`
+-echo "$as_me:$LINENO: checking for Py_Initialize in -l$PYTHON_FULL_NAME" >&5
+-echo $ECHO_N "checking for Py_Initialize in -l$PYTHON_FULL_NAME... $ECHO_C" >&6
+-if eval "test \"\${$as_ac_Lib+set}\" = set"; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+- ac_check_lib_save_LIBS=$LIBS
+-LIBS="-l$PYTHON_FULL_NAME $LIBS"
+-cat >conftest.$ac_ext <<_ACEOF
+-#line $LINENO "configure"
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-
+-/* Override any gcc2 internal prototype to avoid an error. */
+-#ifdef __cplusplus
+-extern "C"
+-#endif
+-/* We use char because int might match the return type of a gcc2
+- builtin and then its argument prototype would still apply. */
+-char Py_Initialize ();
+-int
+-main ()
+-{
+-Py_Initialize ();
+- ;
+- return 0;
+-}
+-_ACEOF
+-rm -f conftest.$ac_objext conftest$ac_exeext
+-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+- (eval $ac_link) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } &&
+- { ac_try='test -s conftest$ac_exeext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- eval "$as_ac_Lib=yes"
+-else
+- echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+-eval "$as_ac_Lib=no"
+-fi
+-rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
+-LIBS=$ac_check_lib_save_LIBS
+-fi
+-echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_Lib'}'`" >&5
+-echo "${ECHO_T}`eval echo '${'$as_ac_Lib'}'`" >&6
+-if test `eval echo '${'$as_ac_Lib'}'` = yes; then
+- PYTHON_LDFLAGS="$PYTHON_TRY_LDFLAGS"
+-fi
+-
+- LDFLAGS="$try_link_python_save_LDFLAGS"
+- fi
+-
+-
+- if test -z "$PYTHON_LDFLAGS"; then
+- try_link_python_save_LDFLAGS="$LDFLAGS"
+- LDFLAGS="$LDFLAGS $PYTHON_TRY_LDFLAGS -lutil"
+- as_ac_Lib=`echo "ac_cv_lib_$PYTHON_FULL_NAME''_Py_Finalize" | $as_tr_sh`
+-echo "$as_me:$LINENO: checking for Py_Finalize in -l$PYTHON_FULL_NAME" >&5
+-echo $ECHO_N "checking for Py_Finalize in -l$PYTHON_FULL_NAME... $ECHO_C" >&6
+-if eval "test \"\${$as_ac_Lib+set}\" = set"; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+- ac_check_lib_save_LIBS=$LIBS
+-LIBS="-l$PYTHON_FULL_NAME $LIBS"
+-cat >conftest.$ac_ext <<_ACEOF
+-#line $LINENO "configure"
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-
+-/* Override any gcc2 internal prototype to avoid an error. */
+-#ifdef __cplusplus
+-extern "C"
+-#endif
+-/* We use char because int might match the return type of a gcc2
+- builtin and then its argument prototype would still apply. */
+-char Py_Finalize ();
+-int
+-main ()
+-{
+-Py_Finalize ();
+- ;
+- return 0;
+-}
+-_ACEOF
+-rm -f conftest.$ac_objext conftest$ac_exeext
+-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+- (eval $ac_link) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } &&
+- { ac_try='test -s conftest$ac_exeext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- eval "$as_ac_Lib=yes"
+-else
+- echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+-eval "$as_ac_Lib=no"
+-fi
+-rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
+-LIBS=$ac_check_lib_save_LIBS
+-fi
+-echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_Lib'}'`" >&5
+-echo "${ECHO_T}`eval echo '${'$as_ac_Lib'}'`" >&6
+-if test `eval echo '${'$as_ac_Lib'}'` = yes; then
+- PYTHON_LDFLAGS="$PYTHON_TRY_LDFLAGS -lutil"
+-fi
+-
+- LDFLAGS="$try_link_python_save_LDFLAGS"
+- fi
+-
+-
+- if test -z "$PYTHON_LDFLAGS"; then
+- try_link_python_save_LDFLAGS="$LDFLAGS"
+- LDFLAGS="$LDFLAGS $PYTHON_TRY_LDFLAGS -lutil -lpthread"
+- as_ac_Lib=`echo "ac_cv_lib_$PYTHON_FULL_NAME''_Py_IsInitialized" | $as_tr_sh`
+-echo "$as_me:$LINENO: checking for Py_IsInitialized in -l$PYTHON_FULL_NAME" >&5
+-echo $ECHO_N "checking for Py_IsInitialized in -l$PYTHON_FULL_NAME... $ECHO_C" >&6
+-if eval "test \"\${$as_ac_Lib+set}\" = set"; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+- ac_check_lib_save_LIBS=$LIBS
+-LIBS="-l$PYTHON_FULL_NAME $LIBS"
+-cat >conftest.$ac_ext <<_ACEOF
+-#line $LINENO "configure"
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-
+-/* Override any gcc2 internal prototype to avoid an error. */
+-#ifdef __cplusplus
+-extern "C"
+-#endif
+-/* We use char because int might match the return type of a gcc2
+- builtin and then its argument prototype would still apply. */
+-char Py_IsInitialized ();
+-int
+-main ()
+-{
+-Py_IsInitialized ();
+- ;
+- return 0;
+-}
+-_ACEOF
+-rm -f conftest.$ac_objext conftest$ac_exeext
+-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+- (eval $ac_link) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } &&
+- { ac_try='test -s conftest$ac_exeext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- eval "$as_ac_Lib=yes"
+-else
+- echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+-eval "$as_ac_Lib=no"
+-fi
+-rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
+-LIBS=$ac_check_lib_save_LIBS
+-fi
+-echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_Lib'}'`" >&5
+-echo "${ECHO_T}`eval echo '${'$as_ac_Lib'}'`" >&6
+-if test `eval echo '${'$as_ac_Lib'}'` = yes; then
+- PYTHON_LDFLAGS="$PYTHON_TRY_LDFLAGS -lutil -lpthread"
+-fi
+-
+- LDFLAGS="$try_link_python_save_LDFLAGS"
+- fi
+-
+- if test -z "$PYTHON_LDFLAGS" ; then
+- { { echo "$as_me:$LINENO: error: Unable to determine proper Python link flags." >&5
+-echo "$as_me: error: Unable to determine proper Python link flags." >&2;}
+- { (exit 1); exit 1; }; }
+- else
+- LDFLAGS="$LDFLAGS $PYTHON_LDFLAGS"
+- fi
+-
+-
+ echo "$as_me:$LINENO: checking for ANSI C header files" >&5
+ echo $ECHO_N "checking for ANSI C header files... $ECHO_C" >&6
+ if test "${ac_cv_header_stdc+set}" = set; then
diff --git a/x11-wm/fluxspace/files/patch-examples::fluxspace.xml b/x11-wm/fluxspace/files/patch-examples::fluxspace.xml
new file mode 100644
index 000000000000..ead38caed7fc
--- /dev/null
+++ b/x11-wm/fluxspace/files/patch-examples::fluxspace.xml
@@ -0,0 +1,11 @@
+--- ../fluxspace-0.0.3.orig/examples/fluxspace.xml Thu Jan 9 06:03:16 2003
++++ examples/fluxspace.xml Wed Mar 26 17:30:59 2003
+@@ -30,7 +30,7 @@
+ </rox>
+
+ <!-- Idesk module - for desktop icons on each workspace -->
+- <idesk enable="no"\>
++ <idesk enable="no"/>
+
+ <!-- Runner module - command execution -->
+ <runner enable="no">
diff --git a/x11-wm/fluxspace/pkg-descr b/x11-wm/fluxspace/pkg-descr
new file mode 100644
index 000000000000..3e234353d4be
--- /dev/null
+++ b/x11-wm/fluxspace/pkg-descr
@@ -0,0 +1,10 @@
+Fluxspace provides a framework and modules for adding event-driven behavior
+to Fluxbox as an external component. A variety of features and enhancements
+can be introduced more easily without modifying Fluxbox's C++ code.
+
+Existing modules that integrate with Rox Filer or Idesk can add effective
+desktop management to a pure window manager, such as Fluxbox. It goes beyond
+the normal desktop capabilities to allow you to customize each workspace with
+its own panels, desktop icons and running applets.
+
+WWW: http://www.isomedia.com/homes/stevencooper/projects/fluxspace.html
diff --git a/x11-wm/fluxspace/pkg-message b/x11-wm/fluxspace/pkg-message
new file mode 100644
index 000000000000..dd64d1ee2f7d
--- /dev/null
+++ b/x11-wm/fluxspace/pkg-message
@@ -0,0 +1,2 @@
+You must have Fluxbox or other Blackbox derivative to use fluxspace. Note
+that only Fluxbox has been tested to any great extent.
diff --git a/x11-wm/fluxspace/pkg-plist b/x11-wm/fluxspace/pkg-plist
new file mode 100644
index 000000000000..101465efaee1
--- /dev/null
+++ b/x11-wm/fluxspace/pkg-plist
@@ -0,0 +1,52 @@
+lib/libfluxspace-0.0.3.so
+lib/libfluxspace.so
+lib/libfluxspace.la
+lib/libfluxspace.a
+%%PYTHON_SITELIBDIR%%/fluxspace/__init__.py
+%%PYTHON_SITELIBDIR%%/fluxspace/ideskutil.py
+%%PYTHON_SITELIBDIR%%/fluxspace/config.py
+%%PYTHON_SITELIBDIR%%/fluxspace/process.py
+%%PYTHON_SITELIBDIR%%/fluxspace/ideskutil.pyc
+%%PYTHON_SITELIBDIR%%/fluxspace/config.pyc
+%%PYTHON_SITELIBDIR%%/fluxspace/process.pyc
+%%PYTHON_SITELIBDIR%%/fluxspace/ideskutil.pyo
+%%PYTHON_SITELIBDIR%%/fluxspace/config.pyo
+%%PYTHON_SITELIBDIR%%/fluxspace/process.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/fluxspace
+%%PYTHON_SITELIBDIR%%/_fluxspace.so
+%%PYTHON_SITELIBDIR%%/fluxspace.py
+%%PYTHON_SITELIBDIR%%/fluxspace.pyc
+%%PYTHON_SITELIBDIR%%/fluxspace.pyo
+%%PYTHON_SITELIBDIR%%/fluxlet/__init__.py
+%%PYTHON_SITELIBDIR%%/fluxlet/painter.py
+%%PYTHON_SITELIBDIR%%/fluxlet/runner.py
+%%PYTHON_SITELIBDIR%%/fluxlet/rox.py
+%%PYTHON_SITELIBDIR%%/fluxlet/tracer.py
+%%PYTHON_SITELIBDIR%%/fluxlet/idesk.py
+%%PYTHON_SITELIBDIR%%/fluxlet/__init__.pyc
+%%PYTHON_SITELIBDIR%%/fluxlet/painter.pyc
+%%PYTHON_SITELIBDIR%%/fluxlet/runner.pyc
+%%PYTHON_SITELIBDIR%%/fluxlet/rox.pyc
+%%PYTHON_SITELIBDIR%%/fluxlet/tracer.pyc
+%%PYTHON_SITELIBDIR%%/fluxlet/idesk.pyc
+%%PYTHON_SITELIBDIR%%/fluxlet/__init__.pyo
+%%PYTHON_SITELIBDIR%%/fluxlet/painter.pyo
+%%PYTHON_SITELIBDIR%%/fluxlet/runner.pyo
+%%PYTHON_SITELIBDIR%%/fluxlet/rox.pyo
+%%PYTHON_SITELIBDIR%%/fluxlet/tracer.pyo
+%%PYTHON_SITELIBDIR%%/fluxlet/idesk.pyo
+bin/fluxspacebg
+bin/fluxspace
+bin/fluxspace-add-idesk-icon
+bin/fluxspace-sync-idesk-with-appdirs
+bin/rox-add-app
+share/fluxspace/examples/fluxspace.xml
+@dirrm share/fluxspace/examples
+share/fluxspace/AUTHORS
+share/fluxspace/BUGS
+share/fluxspace/ChangeLog
+share/fluxspace/COPYING
+share/fluxspace/NEWS
+share/fluxspace/README
+@dirrm share/fluxspace
+@dirrm %%PYTHON_SITELIBDIR%%/fluxlet