aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/fvwm2-devel
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2005-10-25 15:43:21 +0000
committerCy Schubert <cy@FreeBSD.org>2005-10-25 15:43:21 +0000
commite815c5d345222da5737aa36da97acc2e50a0c5a2 (patch)
tree4ade5b47ecc20bad254a13d8b606d08f6210d45e /x11-wm/fvwm2-devel
parent4e91fc74ed23975a7026f5a796c52b856f3913ed (diff)
downloadports-e815c5d345222da5737aa36da97acc2e50a0c5a2.tar.gz
ports-e815c5d345222da5737aa36da97acc2e50a0c5a2.zip
Merge in r1.76.
Notes
Notes: svn path=/head/; revision=146332
Diffstat (limited to 'x11-wm/fvwm2-devel')
-rw-r--r--x11-wm/fvwm2-devel/Makefile76
1 files changed, 48 insertions, 28 deletions
diff --git a/x11-wm/fvwm2-devel/Makefile b/x11-wm/fvwm2-devel/Makefile
index 53bfd0fa1d7b..14ddee0b3a81 100644
--- a/x11-wm/fvwm2-devel/Makefile
+++ b/x11-wm/fvwm2-devel/Makefile
@@ -7,39 +7,25 @@
PORTNAME= fvwm
PORTVERSION= 2.5.14
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-wm
MASTER_SITES= ftp://ftp.fvwm.org/pub/fvwm/version-2/ \
http://www.fvwm.org/generated/icon_download/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
-.if !defined(WITHOUT_ICONS)
-DISTFILES+= fvwm_icons.tgz
-.endif
-
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= cy@FreeBSD.org
COMMENT= Popular virtual window manager for X
-.if defined(WITHOUT_ICONV)
-CONFIGURE_ARGS+= --disable-iconv
-.else
-LIB_DEPENDS+= biconv.2:${PORTSDIR}/converters/iconv
-CONFIGURE_ARGS+= --with-iconv-library=${LOCALBASE}/lib \
- --with-iconv-includes=${LOCALBASE}/include
-.endif
-
LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/libXft
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
-.if defined(WITH_STROKE)
-LIB_DEPENDS+= stroke.0:${PORTSDIR}/devel/libstroke
-.endif
-
# Other ports this port cannot coexist with
CONFLICTS?= fvwm-1.* fvwm-2.4.*
NO_LATEST_LINK= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= X_CFLAGS=-I${LOCALBASE}/include
USE_REINPLACE= yes
USE_GMAKE= yes
USE_XPM= yes
@@ -47,16 +33,43 @@ USE_X_PREFIX= yes
USE_BZIP2= yes
WANT_GNOME= yes
+OPTIONS= ICONS "Install default icon set" on \
+ ICONV "Enable iconv character conversion support" on \
+ STROKE "Enable support for mouse gestures" off \
+ RPLAY "Enable RPlay support in FvwmEvent" off \
+ SESSION_MGMT "Enable Session Management support" on \
+ MULTIBYTE "Enable multibyte character support" on \
+ PNG "Build with PNG graphics support" on \
+ BIDI "Enable Asian bi-directional text support" off \
+ NLS "Enable National Language Support" on \
+ GNOME "Enable GNOME desktop support" off
+
.include <bsd.port.pre.mk>
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= X_CFLAGS=-I${LOCALBASE}/include
+.if !defined(WITHOUT_ICONS)
+DISTFILES+= fvwm_icons.tgz
+.endif
+
+.if defined(WITHOUT_ICONV)
+CONFIGURE_ARGS+= --disable-iconv
+.else
+LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
+CONFIGURE_ARGS+= --with-iconv-library=${LOCALBASE}/lib \
+ --with-iconv-includes=${LOCALBASE}/include
+.endif
.if defined(WITH_STROKE)
+LIB_DEPENDS+= stroke.0:${PORTSDIR}/devel/libstroke
CONFIGURE_ARGS+= --with-stroke --with-stroke-library=${LOCALBASE}/lib \
--with-stroke-includes=${LOCALBASE}/include
.endif
+.if defined(WITH_RPLAY)
+LIB_DEPENDS+= rplay.1:${PORTSDIR}/audio/rplay
+CONFIGURE_ARGS+= --with-rplay --with-rplay-library=${LOCALBASE}/lib \
+ --with-rplay-includes=${LOCALBASE}/include
+.endif
+
.if defined(WITHOUT_SESSION_MGMT)
CONFIGURE_ARGS+= --disable-sm
.endif
@@ -72,20 +85,18 @@ CONFIGURE_ARGS+= --with-png --with-png-includes=${LOCALBASE}/include \
.endif
.if defined(WITHOUT_BIDI)
-CONFIGURE_ARGS+= --disable-bidi
-.endif
-
-.if defined(WITHOUT_XINERAMA)
-CONFIGURE_ARGS+= --disable-xinerama
+CONFIGURE_ARGS+= --disable-bidi
+.else
+LIB_DEPENDS+= fribidi.0:${PORTSDIR}/converters/fribidi
.endif
PLIST_SUB+= FVWM_VERSION="${PORTVERSION}"
.if ${HAVE_GNOME:Mimlib}!=""
USE_GNOME= imlib
-PKGNAMESUFFIX= -imlib
CONFIGURE_ARGS+= --enable-gtktest --enable-imlibtest
PLIST_SUB+= GTK=""
+MAN1+= FvwmGtk.1
.else
CONFIGURE_ARGS+= --disable-gtktest --disable-imlibtest \
--with-gtk-prefix=/no/dir --with-imlib-prefix=/no/dir
@@ -93,13 +104,23 @@ PLIST_SUB+= GTK="@comment not installed: "
WITHOUT_GNOME= true
.endif
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ARGS+= --with-intl --with-intl-library=${LOCALBASE}/lib \
+ --with-intl-includes=${LOCALBASE}/include
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment not installed: "
+.endif
+
.if defined(WITHOUT_GNOME)
CONFIGURE_ARGS+= --without-gnome --disable-gnome-hints
.else
CONFIGURE_ARGS+= --with-gnome --enable-gnome-hints
.endif
-MAN1= FvwmAnimate.1 FvwmAuto.1 FvwmBacker.1 FvwmBanner.1 FvwmButtons.1 \
+MAN1+= FvwmAnimate.1 FvwmAuto.1 FvwmBacker.1 FvwmBanner.1 FvwmButtons.1 \
FvwmCommand.1 FvwmConsole.1 FvwmConsoleC.pl.1 FvwmCpp.1 FvwmDebug.1 \
FvwmDragWell.1 FvwmEvent.1 FvwmForm.1 FvwmIconBox.1 \
FvwmIconMan.1 FvwmIdent.1 FvwmM4.1 FvwmPager.1 FvwmRearrange.1 \
@@ -111,14 +132,13 @@ MAN1= FvwmAnimate.1 FvwmAuto.1 FvwmBacker.1 FvwmBanner.1 FvwmButtons.1 \
FvwmPerl.1 fvwm-perllib.1 FvwmProxy.1 FvwmWindowMenu.1 \
FvwmGtkDebug.1
-
.if !defined(WITHOUT_ICONS)
PLIST_SUB+= ICONS=""
post-extract:
@${MKDIR} ${WRKDIR}/icons
@${TAR} -xzf ${DISTDIR}/fvwm_icons.tgz -C ${WRKDIR}/icons
.else
-PLIST_SUB+= ICONS="@comment not installed"
+PLIST_SUB+= ICONS="@comment not installed: "
.endif
post-patch: