aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/metacity
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
commit798e9bed2a389dce8a970e15b68176fd49f442db (patch)
tree9dc5597aab073298ec381964f72cd853b3dd366c /x11-wm/metacity
parent48b92584b0722f7f6ca412e6cfe16f1381e043cc (diff)
downloadports-798e9bed2a389dce8a970e15b68176fd49f442db.tar.gz
ports-798e9bed2a389dce8a970e15b68176fd49f442db.zip
Presenting GNOME 2.14.1 for FreeBSD! Checkout
http://www.gnome.org/start/2.14/ for the official release notes, and a list of all the gooides in this new release. In particular, GNOME 2.14 focused on performance, and they did not miss the mark. There's some new eye candy, but most of the big things are waiting until GNOME 2.16. On the FreeBSD side, we tried to clean up all the crashers we could. In particular, we really improved GNOME's 64-bit support. The good news is that this release does not bring any big shared library version bumps, so you can almost do a simple portupgrade to get to 2.14. There are a few minor gotchas that will be documented in UPDATING shortly. The FreeBSD GNOME Team would like th thank the following users for their patches, feedback, and sometimes incessant complaing about crashes (you know who you are). Yasuda Keisuke <kysd@po.harenet.ne.jp> Pascal Hofstee <caelian@gmail.com> rmgls@wanadoo.fr tmclaugh Yuri Pankov <yuri.pankov@gmail.com> sajd on #freebsd-gnome ade ankon on #FreeBSD-Gnome mux Pascal Hofstee <caelian@gmail.com> QuiRK on #freebsd-gnome Vladimir Timofeev <vovkasm@gmail.com>
Notes
Notes: svn path=/head/; revision=160863
Diffstat (limited to 'x11-wm/metacity')
-rw-r--r--x11-wm/metacity/Makefile11
-rw-r--r--x11-wm/metacity/distinfo6
-rw-r--r--x11-wm/metacity/files/patch-src_window-props.c18
-rw-r--r--x11-wm/metacity/pkg-plist6
4 files changed, 33 insertions, 8 deletions
diff --git a/x11-wm/metacity/Makefile b/x11-wm/metacity/Makefile
index 7b8c5de5c59c..4416f3bb7533 100644
--- a/x11-wm/metacity/Makefile
+++ b/x11-wm/metacity/Makefile
@@ -3,15 +3,14 @@
# Whom: Garrett Rooney <rooneg@electricjellyfish.net>
#
# $FreeBSD$
-# $MCom: ports/x11-wm/metacity/Makefile,v 1.59 2005/10/03 21:18:00 mezz Exp $
+# $MCom: ports/x11-wm/metacity/Makefile,v 1.78 2006/04/15 01:51:15 mezz Exp $
#
PORTNAME= metacity
-PORTVERSION= 2.12.3
-PORTREVISION= 1
+PORTVERSION= 2.14.3
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -22,6 +21,7 @@ LIB_DEPENDS= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
CONFLICTS= expocity-[0-9]*
USE_BZIP2= yes
USE_X_PREFIX= yes
+USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomeprefix intlhack gnomehack gconf2
@@ -33,6 +33,7 @@ MAKE_ENV= G_CHARSET_ALIAS="${LOCALBASE}/libdata/charset.alias"
GCONF_SCHEMAS= metacity.schemas
-MAN1= metacity-theme-viewer.1 metacity-window-demo.1
+MAN1= metacity-theme-viewer.1 metacity-window-demo.1 \
+ metacity.1
.include <bsd.port.mk>
diff --git a/x11-wm/metacity/distinfo b/x11-wm/metacity/distinfo
index ba2369354d42..cc840ccb6a91 100644
--- a/x11-wm/metacity/distinfo
+++ b/x11-wm/metacity/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/metacity-2.12.3.tar.bz2) = 15df85021a8aa1d95fe60551105129db
-SHA256 (gnome2/metacity-2.12.3.tar.bz2) = 90871a0a4e242054f5290e42d7e104ca5d9d2fc47761d3e075fbcfbd6be0ac60
-SIZE (gnome2/metacity-2.12.3.tar.bz2) = 1672493
+MD5 (gnome2/metacity-2.14.3.tar.bz2) = 57c0bc3cf4103097e126df892ecc1d58
+SHA256 (gnome2/metacity-2.14.3.tar.bz2) = 067abbfffb9a4a08aab03249c691d8d2ca65641ffe00f0af245b7a5e2d222af8
+SIZE (gnome2/metacity-2.14.3.tar.bz2) = 1833709
diff --git a/x11-wm/metacity/files/patch-src_window-props.c b/x11-wm/metacity/files/patch-src_window-props.c
new file mode 100644
index 000000000000..e32aacf7ffa7
--- /dev/null
+++ b/x11-wm/metacity/files/patch-src_window-props.c
@@ -0,0 +1,18 @@
+--- src/window-props.c.orig Wed Dec 14 09:27:03 2005
++++ src/window-props.c Wed Dec 14 09:28:57 2005
+@@ -20,6 +20,7 @@
+ * 02111-1307, USA.
+ */
+
++#include <sys/param.h>
+ #include <config.h>
+ #include "window-props.h"
+ #include "xprops.h"
+@@ -194,6 +195,7 @@ reload_net_wm_user_time (MetaWindow *
+ }
+
+ #define MAX_TITLE_LENGTH 512
++#define HOST_NAME_MAX MAXHOSTNAMELEN
+
+ /**
+ * Called by set_window_title and set_icon_title to set the value of
diff --git a/x11-wm/metacity/pkg-plist b/x11-wm/metacity/pkg-plist
index a0362fafbe5e..26f5c0b0af97 100644
--- a/x11-wm/metacity/pkg-plist
+++ b/x11-wm/metacity/pkg-plist
@@ -110,12 +110,14 @@ share/locale/az/LC_MESSAGES/metacity.mo
share/locale/be/LC_MESSAGES/metacity.mo
share/locale/bg/LC_MESSAGES/metacity.mo
share/locale/bn/LC_MESSAGES/metacity.mo
+share/locale/br/LC_MESSAGES/metacity.mo
share/locale/bs/LC_MESSAGES/metacity.mo
share/locale/ca/LC_MESSAGES/metacity.mo
share/locale/cs/LC_MESSAGES/metacity.mo
share/locale/cy/LC_MESSAGES/metacity.mo
share/locale/da/LC_MESSAGES/metacity.mo
share/locale/de/LC_MESSAGES/metacity.mo
+share/locale/dz/LC_MESSAGES/metacity.mo
share/locale/el/LC_MESSAGES/metacity.mo
share/locale/en_CA/LC_MESSAGES/metacity.mo
share/locale/en_GB/LC_MESSAGES/metacity.mo
@@ -137,7 +139,9 @@ share/locale/id/LC_MESSAGES/metacity.mo
share/locale/is/LC_MESSAGES/metacity.mo
share/locale/it/LC_MESSAGES/metacity.mo
share/locale/ja/LC_MESSAGES/metacity.mo
+share/locale/ka/LC_MESSAGES/metacity.mo
share/locale/ko/LC_MESSAGES/metacity.mo
+share/locale/ku/LC_MESSAGES/metacity.mo
share/locale/lt/LC_MESSAGES/metacity.mo
share/locale/lv/LC_MESSAGES/metacity.mo
share/locale/mk/LC_MESSAGES/metacity.mo
@@ -173,6 +177,8 @@ share/locale/wa/LC_MESSAGES/metacity.mo
share/locale/xh/LC_MESSAGES/metacity.mo
share/locale/zh_CN/LC_MESSAGES/metacity.mo
share/locale/zh_TW/LC_MESSAGES/metacity.mo
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
@dirrm share/gnome/themes/Simple/metacity-1
@dirrm share/gnome/themes/Simple
@dirrm share/gnome/themes/Metabox/metacity-1