aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/musca
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2009-03-31 20:21:49 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2009-03-31 20:21:49 +0000
commit0c20529edc50651435cbd593d5b033fa859bc7a6 (patch)
tree5e57d2efd14345c44872f6bb65ff3a071795467d /x11-wm/musca
parent38c027f72e315b272a15062b1df23a134de4489b (diff)
downloadports-0c20529edc50651435cbd593d5b033fa859bc7a6.tar.gz
ports-0c20529edc50651435cbd593d5b033fa859bc7a6.zip
A simple dynamic window manager for X, with features nicked from
ratpoison and dwm. Musca's code is actually written from scratch, but a lot of useful stuff was gleaned from reading the source code of those two excellent projects. WWW: http://aerosuidae.net/musca.html Approved by: tabthorpe (co-mentor)
Notes
Notes: svn path=/head/; revision=231410
Diffstat (limited to 'x11-wm/musca')
-rw-r--r--x11-wm/musca/Makefile42
-rw-r--r--x11-wm/musca/distinfo3
-rw-r--r--x11-wm/musca/pkg-descr6
3 files changed, 51 insertions, 0 deletions
diff --git a/x11-wm/musca/Makefile b/x11-wm/musca/Makefile
new file mode 100644
index 000000000000..6cb2347488b8
--- /dev/null
+++ b/x11-wm/musca/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: musca
+# Date created: 2009-03-30
+# Whom: Dennis Herrmann <dhn@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= musca
+PORTVERSION= 0.9.13
+CATEGORIES= x11-wm
+MASTER_SITES= http://aerosuidae.net/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dhn@FreeBSD.org
+COMMENT= A simple window manager for X, with features from ratpoison and dwm
+
+RUN_DEPENDS= dmenu:${PORTSDIR}/x11/dmenu
+
+USE_XORG= x11
+
+PLIST_FILES= bin/musca
+PORTDOCS= readme.txt
+
+pre-everything::
+ @${ECHO_MSG} "You can build musca with your own config.h using the MUSCA_CONF knob:"
+ @${ECHO_MSG} "make MUSCA_CONF=/path/to/musca/config.h install clean"
+
+post-extract:
+.if defined(MUSCA_CONF)
+ @${ECHO_MSG} "creating config.h from ${MUSCA_CONF}"
+ @${CP} ${MUSCA_CONF} ${WRKSRC}/config.h
+.endif
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/musca/distinfo b/x11-wm/musca/distinfo
new file mode 100644
index 000000000000..23e8838540e4
--- /dev/null
+++ b/x11-wm/musca/distinfo
@@ -0,0 +1,3 @@
+MD5 (musca-0.9.13.tgz) = 0de3318238676483ad1a75550df6faa7
+SHA256 (musca-0.9.13.tgz) = 62c9f80473941da5da24efe1ffdde68a941f55dc7a53814eac6b35edac3366fa
+SIZE (musca-0.9.13.tgz) = 57881
diff --git a/x11-wm/musca/pkg-descr b/x11-wm/musca/pkg-descr
new file mode 100644
index 000000000000..94101c76fa20
--- /dev/null
+++ b/x11-wm/musca/pkg-descr
@@ -0,0 +1,6 @@
+A simple dynamic window manager for X, with features nicked from
+ratpoison and dwm. Musca's code is actually written from scratch,
+but a lot of useful stuff was gleaned from reading the source code
+of those two excellent projects.
+
+WWW: http://aerosuidae.net/musca.html