aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/plank
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2014-07-03 13:40:52 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2014-07-03 13:40:52 +0000
commita72ddb4641e311949955132e47256bd3ad90319a (patch)
tree0c67ef4daa3d9ded7b0e91f2214889c4d86761fe /x11-wm/plank
parent07748aff6da8658c0573673bf4baa97bc5d9edee (diff)
downloadports-a72ddb4641e311949955132e47256bd3ad90319a.tar.gz
ports-a72ddb4641e311949955132e47256bd3ad90319a.zip
Plank is an elegant, simple and clean dock.
Notes
Notes: svn path=/head/; revision=360368
Diffstat (limited to 'x11-wm/plank')
-rw-r--r--x11-wm/plank/Makefile52
-rw-r--r--x11-wm/plank/distinfo2
-rw-r--r--x11-wm/plank/files/patch-data__Makefile.in10
-rw-r--r--x11-wm/plank/files/patch-lib__Factories__AbstractMain.vala11
-rw-r--r--x11-wm/plank/files/patch-lib__Makefile.in10
-rw-r--r--x11-wm/plank/files/patch-vapi__compat.vapi13
-rw-r--r--x11-wm/plank/pkg-descr3
-rw-r--r--x11-wm/plank/pkg-plist76
8 files changed, 177 insertions, 0 deletions
diff --git a/x11-wm/plank/Makefile b/x11-wm/plank/Makefile
new file mode 100644
index 000000000000..e39c024fe945
--- /dev/null
+++ b/x11-wm/plank/Makefile
@@ -0,0 +1,52 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+
+PORTNAME= plank
+PORTVERSION= 0.5.0
+CATEGORIES= x11-wm
+MASTER_SITES= https://launchpadlibrarian.net/156777764/ \
+ https://launchpad.net/${PORTNAME}/1.0/${PORTVERSION}/+download/
+
+MAINTAINER= olivierd@FreeBSD.org
+COMMENT= Elegant, simple, and clean dock
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= vapigen:${PORTSDIR}/lang/vala-vapigen
+LIB_DEPENDS= libbamf3.so:${PORTSDIR}/sysutils/bamf \
+ libgee-0.8.so:${PORTSDIR}/devel/libgee
+
+USES= tar:xz pkgconfig gmake pathfix libtool
+GNU_CONFIGURE= yes
+USE_GNOME= glib20 gtk30 gdkpixbuf2 libxml2 libwnck3
+USE_XORG= x11
+INSTALLS_ICONS= yes
+
+OPTIONS_DEFINE= NLS DBUSMENU
+DBUSMENU_DESC= DBusMenu protocol
+
+CONFIGURE_ARGS= --enable-gee-0.8 \
+ --disable-benchmark \
+ --disable-headless-tests
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+CONFIGURE_ARGS+=--enable-nls
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MDBUSMENU}
+# Need GTK3 support
+LIB_DEPENDS+= libdbusmenu-gtk3.so:${PORTSDIR}/devel/libdbusmenu
+CONFIGURE_ARGS+=--enable-dbusmenu
+.else
+CONFIGURE_ARGS+=--disable-dbusmenu
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/plank/distinfo b/x11-wm/plank/distinfo
new file mode 100644
index 000000000000..a67ec5479288
--- /dev/null
+++ b/x11-wm/plank/distinfo
@@ -0,0 +1,2 @@
+SHA256 (plank-0.5.0.tar.xz) = bf0e14dbdc9d30d57e55cc88644ef6e6c296be924bbfc1b345cba1e0c9be1804
+SIZE (plank-0.5.0.tar.xz) = 899884
diff --git a/x11-wm/plank/files/patch-data__Makefile.in b/x11-wm/plank/files/patch-data__Makefile.in
new file mode 100644
index 000000000000..a9845a9812f7
--- /dev/null
+++ b/x11-wm/plank/files/patch-data__Makefile.in
@@ -0,0 +1,10 @@
+--- ./data/Makefile.in.orig 2013-11-17 13:45:58.000000000 +0000
++++ ./data/Makefile.in 2014-04-02 20:44:06.000000000 +0000
+@@ -371,7 +371,6 @@
+ top_srcdir = @top_srcdir@
+ NULL =
+ SUBDIRS = \
+- apport \
+ icons \
+ themes \
+ $(NULL)
diff --git a/x11-wm/plank/files/patch-lib__Factories__AbstractMain.vala b/x11-wm/plank/files/patch-lib__Factories__AbstractMain.vala
new file mode 100644
index 000000000000..147014bf081a
--- /dev/null
+++ b/x11-wm/plank/files/patch-lib__Factories__AbstractMain.vala
@@ -0,0 +1,11 @@
+--- ./lib/Factories/AbstractMain.vala.orig 2013-11-15 15:13:35.000000000 +0000
++++ ./lib/Factories/AbstractMain.vala 2014-05-23 18:39:31.000000000 +0000
+@@ -163,7 +163,7 @@
+ protected virtual void initialize_program ()
+ {
+ // set program name
+- prctl (15, exec_name);
++ setproctitle (exec_name);
+ Environment.set_prgname (exec_name);
+
+ Posix.signal(Posix.SIGINT, sig_handler);
diff --git a/x11-wm/plank/files/patch-lib__Makefile.in b/x11-wm/plank/files/patch-lib__Makefile.in
new file mode 100644
index 000000000000..43b5586d540b
--- /dev/null
+++ b/x11-wm/plank/files/patch-lib__Makefile.in
@@ -0,0 +1,10 @@
+--- ./lib/Makefile.in.orig 2013-11-17 13:45:58.000000000 +0000
++++ ./lib/Makefile.in 2014-07-03 14:52:41.000000000 +0000
+@@ -684,7 +684,6 @@
+ noinst_LTLIBRARIES = libplank-internal.la
+ libplank_internal_la_CFLAGS = \
+ $(AM_CFLAGS) \
+- -fvisibility=internal \
+ $(NULL)
+
+ libplank_internal_la_LDFLAGS = \
diff --git a/x11-wm/plank/files/patch-vapi__compat.vapi b/x11-wm/plank/files/patch-vapi__compat.vapi
new file mode 100644
index 000000000000..0ba6891515fe
--- /dev/null
+++ b/x11-wm/plank/files/patch-vapi__compat.vapi
@@ -0,0 +1,13 @@
+--- ./vapi/compat.vapi.orig 2013-11-15 15:13:29.000000000 +0000
++++ ./vapi/compat.vapi 2014-05-23 18:39:55.000000000 +0000
+@@ -25,8 +25,8 @@
+ [CCode (cheader_filename = "gtk/gtk.h", cname = "gtk_widget_shape_combine_region")]
+ public void gtk_widget_shape_combine_region (Gtk.Widget widget, Cairo.Region? region);
+ #endif
+- [CCode (cheader_filename = "sys/prctl.h", cname = "prctl", sentinel = "")]
+- public int prctl (int option, ...);
++ [CCode (cheader_filename = "unistd.h", cname = "setproctitle", sentinel = "")]
++ public void setproctitle (string fmt, ...);
+ }
+
+ [CCode (cheader_filename = "glib.h")]
diff --git a/x11-wm/plank/pkg-descr b/x11-wm/plank/pkg-descr
new file mode 100644
index 000000000000..1d952deaa8c3
--- /dev/null
+++ b/x11-wm/plank/pkg-descr
@@ -0,0 +1,3 @@
+Plank is an elegant, simple and clean dock.
+
+WWW: http://launchpad.net/plank/
diff --git a/x11-wm/plank/pkg-plist b/x11-wm/plank/pkg-plist
new file mode 100644
index 000000000000..f52d339dd29a
--- /dev/null
+++ b/x11-wm/plank/pkg-plist
@@ -0,0 +1,76 @@
+bin/plank
+include/plank/plank.h
+lib/libplank.so
+lib/libplank.so.0
+lib/libplank.so.0.0.0
+libdata/pkgconfig/plank.pc
+man/man1/plank.1.gz
+share/applications/plank.desktop
+share/icons/hicolor/128x128/apps/plank.svg
+share/icons/hicolor/16x16/apps/plank.svg
+share/icons/hicolor/22x22/apps/plank.svg
+share/icons/hicolor/24x24/apps/plank.svg
+share/icons/hicolor/32x32/apps/plank.svg
+share/icons/hicolor/48x48/apps/plank.svg
+share/icons/hicolor/64x64/apps/plank.svg
+%%NLS%%share/locale/ar/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/bs/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/de/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/el/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/en_AU/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/en_CA/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/es/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/et/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/he/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/id/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/it/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/ml/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/sma/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/sr@latin/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/ta/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/plank.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/plank.mo
+%%DATADIR%%/themes/Default/dock.theme
+%%DATADIR%%/themes/Matte/dock.theme
+%%DATADIR%%/themes/Transparent/dock.theme
+share/vala/vapi/plank.deps
+share/vala/vapi/plank.vapi
+@dirrm %%DATADIR%%/themes/Transparent
+@dirrm %%DATADIR%%/themes/Matte
+@dirrm %%DATADIR%%/themes/Default
+@dirrm %%DATADIR%%/themes
+@dirrm %%DATADIR%%
+%%NLS%%@dirrmtry share/locale/sr@latin/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/sr@latin
+%%NLS%%@dirrmtry share/locale/sma/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/sma
+@dirrm include/plank