aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/sapphire/Makefile
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>2000-02-21 16:57:04 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>2000-02-21 16:57:04 +0000
commitda961162c13fe6dd497e355f9dac34f480259390 (patch)
tree588d5d2368b02da2e255c1c2f431f9891c5f6aee /x11-wm/sapphire/Makefile
parent111db80c3dabf3eca6bcef29671663c74be701c4 (diff)
downloadports-da961162c13fe6dd497e355f9dac34f480259390.tar.gz
ports-da961162c13fe6dd497e355f9dac34f480259390.zip
Update to version 0.14.0.2
PR: 16878 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp> No response from: maintainer
Notes
Notes: svn path=/head/; revision=26098
Diffstat (limited to 'x11-wm/sapphire/Makefile')
-rw-r--r--x11-wm/sapphire/Makefile22
1 files changed, 20 insertions, 2 deletions
diff --git a/x11-wm/sapphire/Makefile b/x11-wm/sapphire/Makefile
index 16c2c2165580..501e13e9ba52 100644
--- a/x11-wm/sapphire/Makefile
+++ b/x11-wm/sapphire/Makefile
@@ -1,12 +1,13 @@
# New ports collection makefile for: sapphire
-# Version required: 0.13.6
+# Version required: 0.14.0.2
# Date created: 26 Jan 2000
# Whom: trevor@jpj.net
#
# $FreeBSD$
#
-DISTNAME= sapphire-0.13.6
+DISTNAME= sapphire-0.14.0-2
+PKGNAME= sapphire-0.14.0.2
CATEGORIES= x11-wm
MASTER_SITES= http://download.sourceforge.net/sapphire/
@@ -16,4 +17,21 @@ USE_GMAKE= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
+post-extract:
+ @${CP} ${WRKSRC}/data.inst ${WRKSRC}/sapphire.inst
+
+post-patch:
+ @${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/sapphire.inst
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/sapphire.inst ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/sapphire
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/sapphire
+ @${MKDIR} ${PREFIX}/share/sapphire/menu
+ ${INSTALL_DATA} ${WRKSRC}/data/menu/* ${PREFIX}/share/sapphire/menu
+ @${MKDIR} ${PREFIX}/share/sapphire/themes
+ ${INSTALL_DATA} ${WRKSRC}/data/themes/* ${PREFIX}/share/sapphire/themes
+ @${MKDIR} ${PREFIX}/share/sapphire/wmconfig
+ ${INSTALL_DATA} ${WRKSRC}/data/wmconfig/* ${PREFIX}/share/sapphire/wmconfig
+
.include <bsd.port.mk>