aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/sapphire
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>2000-02-21 16:57:04 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>2000-02-21 16:57:04 +0000
commitda961162c13fe6dd497e355f9dac34f480259390 (patch)
tree588d5d2368b02da2e255c1c2f431f9891c5f6aee /x11-wm/sapphire
parent111db80c3dabf3eca6bcef29671663c74be701c4 (diff)
downloadports-da961162c13fe6dd497e355f9dac34f480259390.tar.gz
ports-da961162c13fe6dd497e355f9dac34f480259390.zip
Update to version 0.14.0.2
PR: 16878 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp> No response from: maintainer
Notes
Notes: svn path=/head/; revision=26098
Diffstat (limited to 'x11-wm/sapphire')
-rw-r--r--x11-wm/sapphire/Makefile22
-rw-r--r--x11-wm/sapphire/distinfo2
-rw-r--r--x11-wm/sapphire/files/patch-aa54
-rw-r--r--x11-wm/sapphire/files/patch-ab11
-rw-r--r--x11-wm/sapphire/files/patch-ac12
-rw-r--r--x11-wm/sapphire/pkg-plist11
6 files changed, 109 insertions, 3 deletions
diff --git a/x11-wm/sapphire/Makefile b/x11-wm/sapphire/Makefile
index 16c2c2165580..501e13e9ba52 100644
--- a/x11-wm/sapphire/Makefile
+++ b/x11-wm/sapphire/Makefile
@@ -1,12 +1,13 @@
# New ports collection makefile for: sapphire
-# Version required: 0.13.6
+# Version required: 0.14.0.2
# Date created: 26 Jan 2000
# Whom: trevor@jpj.net
#
# $FreeBSD$
#
-DISTNAME= sapphire-0.13.6
+DISTNAME= sapphire-0.14.0-2
+PKGNAME= sapphire-0.14.0.2
CATEGORIES= x11-wm
MASTER_SITES= http://download.sourceforge.net/sapphire/
@@ -16,4 +17,21 @@ USE_GMAKE= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
+post-extract:
+ @${CP} ${WRKSRC}/data.inst ${WRKSRC}/sapphire.inst
+
+post-patch:
+ @${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/sapphire.inst
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/sapphire.inst ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/sapphire
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/sapphire
+ @${MKDIR} ${PREFIX}/share/sapphire/menu
+ ${INSTALL_DATA} ${WRKSRC}/data/menu/* ${PREFIX}/share/sapphire/menu
+ @${MKDIR} ${PREFIX}/share/sapphire/themes
+ ${INSTALL_DATA} ${WRKSRC}/data/themes/* ${PREFIX}/share/sapphire/themes
+ @${MKDIR} ${PREFIX}/share/sapphire/wmconfig
+ ${INSTALL_DATA} ${WRKSRC}/data/wmconfig/* ${PREFIX}/share/sapphire/wmconfig
+
.include <bsd.port.mk>
diff --git a/x11-wm/sapphire/distinfo b/x11-wm/sapphire/distinfo
index df6fd3cd47af..0401ce042836 100644
--- a/x11-wm/sapphire/distinfo
+++ b/x11-wm/sapphire/distinfo
@@ -1 +1 @@
-MD5 (sapphire-0.13.6.tar.gz) = b37848dd3aa9d4115af4e69b5d998799
+MD5 (sapphire-0.14.0-2.tar.gz) = 61f70e6d4f32380147f2015fa73b326d
diff --git a/x11-wm/sapphire/files/patch-aa b/x11-wm/sapphire/files/patch-aa
new file mode 100644
index 000000000000..7fb82408f93b
--- /dev/null
+++ b/x11-wm/sapphire/files/patch-aa
@@ -0,0 +1,54 @@
+--- sapphire.inst.orig Sun Feb 13 14:27:43 2000
++++ sapphire.inst Thu Feb 17 22:35:52 2000
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+ #
+ # Sapphire 0.14.0
+ #
+@@ -9,6 +9,7 @@
+ # 13 Feb 2000 at 12:27am
+ # frankhale@yahoo.com
+ #
++DATADIR = %%PREFIX%%/share/sapphire
+ if [ -d ~/.sapphire ]
+ then
+ echo "~/.sapphire directory exists, deleting it now.";
+@@ -33,15 +34,15 @@
+
+ echo "created directory ~/.sapphire/menu";
+
+- cp data/themes/* ~/.sapphire/themes
++ cp $DATADIR/themes/* ~/.sapphire/themes
+
+ echo "copied themes";
+
+- cp data/wmconfig/* ~/.sapphire/wmconfig
++ cp $DATADIR/wmconfig/* ~/.sapphire/wmconfig
+
+ echo "copied wmconfig";
+
+- cp data/menu/* ~/.sapphire/menu
++ cp $DATADIR/menu/* ~/.sapphire/menu
+
+ echo "copied menu";
+
+@@ -65,15 +66,15 @@
+
+ echo "created directory ~/.sapphire/menu";
+
+- cp data/themes/* ~/.sapphire/themes
++ cp $DATADIR/themes/* ~/.sapphire/themes
+
+ echo "copied themes";
+
+- cp data/wmconfig/* ~/.sapphire/wmconfig
++ cp $DATADIR/wmconfig/* ~/.sapphire/wmconfig
+
+ echo "copied wmconfig";
+
+- cp data/menu/* ~/.sapphire/menu
++ cp $DATADIR/menu/* ~/.sapphire/menu
+
+ echo "copied menu";
+
diff --git a/x11-wm/sapphire/files/patch-ab b/x11-wm/sapphire/files/patch-ab
new file mode 100644
index 000000000000..484242c1174b
--- /dev/null
+++ b/x11-wm/sapphire/files/patch-ab
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Mon Feb 7 07:57:13 2000
++++ src/Makefile.in Fri Feb 18 03:26:13 2000
+@@ -66,7 +66,7 @@
+ X_CFLAGS = @X_CFLAGS@
+ X_LIBS = @X_LIBS@
+
+-CXX = g++
++CXX = @CXX@
+ LDADD = $(X_LIBS)
+ CPPFLAGS = $(X_CFLAGS)
+ bin_PROGRAMS = sapphire
diff --git a/x11-wm/sapphire/files/patch-ac b/x11-wm/sapphire/files/patch-ac
new file mode 100644
index 000000000000..9018003dd4d0
--- /dev/null
+++ b/x11-wm/sapphire/files/patch-ac
@@ -0,0 +1,12 @@
+--- src/image.cc.orig Thu Feb 10 10:36:20 2000
++++ src/image.cc Fri Feb 18 03:26:13 2000
+@@ -29,7 +29,9 @@
+
+ #include "sapphire.hh"
+
++#ifndef __STDC__
+ #include <malloc.h>
++#endif
+
+ #ifdef GradientHack
+ # include <math.h>
diff --git a/x11-wm/sapphire/pkg-plist b/x11-wm/sapphire/pkg-plist
index 7c8d8e6d5f2b..f0680431f0f0 100644
--- a/x11-wm/sapphire/pkg-plist
+++ b/x11-wm/sapphire/pkg-plist
@@ -1 +1,12 @@
bin/sapphire
+bin/sapphire.inst
+share/sapphire/README
+share/sapphire/menu/default
+share/sapphire/themes/darkblue
+share/sapphire/themes/default
+share/sapphire/themes/slate
+share/sapphire/wmconfig/wmconf
+@dirrm share/sapphire/wmconfig
+@dirrm share/sapphire/themes
+@dirrm share/sapphire/menu
+@dirrm share/sapphire