aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/skippy
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-07-12 11:56:29 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-07-12 11:56:29 +0000
commit70c73c78e2e10b10be34a376918f9ffc10b9be8e (patch)
tree2e632342202d71d0dba9008ebca8200af51f9040 /x11-wm/skippy
parentbd2b948958acf04c4be4d33296e6620273036778 (diff)
downloadports-70c73c78e2e10b10be34a376918f9ffc10b9be8e.tar.gz
ports-70c73c78e2e10b10be34a376918f9ffc10b9be8e.zip
Fix .skippyrc-parsing (bump PORTREVISION)
PR: ports/68705 Submitted by: Leland Wang Approved by: maintainer
Notes
Notes: svn path=/head/; revision=113461
Diffstat (limited to 'x11-wm/skippy')
-rw-r--r--x11-wm/skippy/Makefile1
-rw-r--r--x11-wm/skippy/files/patch-config.c22
2 files changed, 23 insertions, 0 deletions
diff --git a/x11-wm/skippy/Makefile b/x11-wm/skippy/Makefile
index 20c41358f502..735a1d918a3b 100644
--- a/x11-wm/skippy/Makefile
+++ b/x11-wm/skippy/Makefile
@@ -7,6 +7,7 @@
PORTNAME= skippy
PORTVERSION= 0.5.0
+PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= http://thegraveyard.org/files/
diff --git a/x11-wm/skippy/files/patch-config.c b/x11-wm/skippy/files/patch-config.c
new file mode 100644
index 000000000000..4dfcce54a0fa
--- /dev/null
+++ b/x11-wm/skippy/files/patch-config.c
@@ -0,0 +1,22 @@
+--- config.c.orig Mon Jul 5 22:36:39 2004
++++ config.c Mon Jul 5 23:32:25 2004
+@@ -72,9 +72,9 @@
+ int ix = 0, l_ix = 0;
+ dlist *new_config = 0;
+
+- regcomp(&re_section, "^[[:space:]]*\\[[[:space:]]*([[:alnum:]]*?)[[:space:]]*\\][[:space:]]*$", REG_EXTENDED);
++ regcomp(&re_section, "^[[:space:]]*\\[[[:space:]]*([[:alnum:]]*)[[:space:]]*\\][[:space:]]*$", REG_EXTENDED);
+ regcomp(&re_empty, "^[[:space:]]*#|^[[:space:]]*$", REG_EXTENDED);
+- regcomp(&re_entry, "^[[:space:]]*([[:alnum:]]+)[[:space:]]*=[[:space:]]*(.*?)[[:space:]]*$", REG_EXTENDED);
++ regcomp(&re_entry, "^[[:space:]]*([[:alnum:]]+)[[:space:]]*=[[:space:]]*(.*)[[:space:]]*$", REG_EXTENDED);
+
+ while(1)
+ {
+@@ -148,6 +148,7 @@
+ fclose(fin);
+ return 0;
+ }
++ data[flen] = '\0';
+
+ fclose(fin);
+