aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/swm
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /x11-wm/swm
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'x11-wm/swm')
-rw-r--r--x11-wm/swm/Makefile15
-rw-r--r--x11-wm/swm/files/patch-Makefile-xpm2
2 files changed, 8 insertions, 9 deletions
diff --git a/x11-wm/swm/Makefile b/x11-wm/swm/Makefile
index 1a880d23b425..a43d3727eb10 100644
--- a/x11-wm/swm/Makefile
+++ b/x11-wm/swm/Makefile
@@ -7,13 +7,13 @@
PORTNAME= swm
PORTVERSION= 1.3.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-wm
MASTER_SITES= http://www2.informatik.hu-berlin.de/~sperling/prog/
EXTRACT_SUFX= c-src.tgz
MAINTAINER= ports@FreeBSD.org
-COMMENT=Window manager for low-memory systems, with title bars and shading
+COMMENT= Window manager for low-memory systems, with title bars and shading
BINS= swm swmbg swmswitch
DOCDIR= share/doc/${PORTNAME}
@@ -23,8 +23,7 @@ PLIST= ${WRKDIR}/pkg-plist
PLIST_DIRS= share/swm/pixmaps share/swm
SCRIPTS= startswm
USE_GMAKE= yes
-USE_XPM= yes
-USE_X_PREFIX= yes
+USE_XORG= x11 xext xpm
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
post-patch:
@@ -35,10 +34,10 @@ post-patch:
.endfor
post-build:
- cd ${WRKSRC}/../swmbg && ${CC} ${CFLAGS} -I${X11BASE}/include *.c \
- -o ${WRKSRC}/swmbg -lX11 -lXext -lXpm -L${X11BASE}/lib
- cd ${WRKSRC}/../swmswitch && ${CC} ${CFLAGS} -I${X11BASE}/include *.c \
- -o ${WRKSRC}/swmswitch -lX11 -L${X11BASE}/lib
+ cd ${WRKSRC}/../swmbg && ${CC} ${CFLAGS} -I${LOCALBASE}/include *.c \
+ -o ${WRKSRC}/swmbg -lX11 -lXext -lXpm -L${LOCALBASE}/lib
+ cd ${WRKSRC}/../swmswitch && ${CC} ${CFLAGS} -I${LOCALBASE}/include *.c \
+ -o ${WRKSRC}/swmswitch -lX11 -L${LOCALBASE}/lib
pre-install:
${RM} -f ${PLIST}
diff --git a/x11-wm/swm/files/patch-Makefile-xpm b/x11-wm/swm/files/patch-Makefile-xpm
index 68d8f4f46fe5..96ec2be6ea5b 100644
--- a/x11-wm/swm/files/patch-Makefile-xpm
+++ b/x11-wm/swm/files/patch-Makefile-xpm
@@ -17,7 +17,7 @@
+#CC = gcc
-XROOT = /usr/X11R6
-+XROOT = $(X11BASE)
++XROOT = $(LOCALBASE)
INCLPATH = -I$(XROOT)/include
LDPATH = -L$(XROOT)/lib