aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/windowmaker
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1998-10-19 10:57:04 +0000
committerThomas Gellekum <tg@FreeBSD.org>1998-10-19 10:57:04 +0000
commit7a58dbefbb49fa0d6f2db10d3968307f4fe422bc (patch)
tree0f15e5065c783bee91a84a9c5fc0287b45533457 /x11-wm/windowmaker
parent7e06d817b32a20d627ee802bfa0ce9c1cdfb5d5a (diff)
downloadports-7a58dbefbb49fa0d6f2db10d3968307f4fe422bc.tar.gz
ports-7a58dbefbb49fa0d6f2db10d3968307f4fe422bc.zip
Fix default paths in WPrefs.app.
Submitted by: Brian Handy <handy@physics.montana.edu>
Notes
Notes: svn path=/head/; revision=14063
Diffstat (limited to 'x11-wm/windowmaker')
-rw-r--r--x11-wm/windowmaker/Makefile5
-rw-r--r--x11-wm/windowmaker/files/patch-ag26
2 files changed, 30 insertions, 1 deletions
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index 4d064aac3910..e2250e6bb2d0 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -3,7 +3,7 @@
# Date created: August 13, 1997
# Whom: handy@physics.montana.edu
#
-# $Id: Makefile,v 1.33 1998/09/27 20:59:11 steve Exp $
+# $Id: Makefile,v 1.34 1998/09/30 13:24:39 tg Exp $
DISTNAME= WindowMaker-0.20.1
PKGNAME= windowmaker-0.20.1
@@ -38,6 +38,9 @@ DATAFILES= WindowMaker-data.tar.gz
post-extract:
cd ${WRKSRC}; ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} libPropList.tar.gz
+post-patch:
+ @perl -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/WPrefs.app/Paths.c
+
pre-configure:
@(cd ${WRKSRC}/libPropList && CC="${CC}" CXX="${CXX}" \
ac_cv_path_CC="${CC}" CFLAGS="${CFLAGS} -fPIC" \
diff --git a/x11-wm/windowmaker/files/patch-ag b/x11-wm/windowmaker/files/patch-ag
new file mode 100644
index 000000000000..d885e331e744
--- /dev/null
+++ b/x11-wm/windowmaker/files/patch-ag
@@ -0,0 +1,26 @@
+--- WPrefs.app/Paths.c.orig Fri Oct 9 07:35:39 1998
++++ WPrefs.app/Paths.c Fri Oct 9 07:37:46 1998
+@@ -82,10 +82,10 @@
+ wwarning(_("bad value in option IconPath. Using default path list"));
+ addPathToList(panel->icoL, -1, "~/pixmaps");
+ addPathToList(panel->icoL, -1, "~/GNUstep/Library/Icons");
+- addPathToList(panel->icoL, -1, "/usr/include/X11/pixmaps");
+- addPathToList(panel->icoL, -1, "/usr/local/share/WindowMaker/Icons");
+- addPathToList(panel->icoL, -1, "/usr/local/share/WindowMaker/Pixmaps");
+- addPathToList(panel->icoL, -1, "/usr/share/WindowMaker/Icons");
++ addPathToList(panel->icoL, -1, "%%PREFIX%%/include/X11/pixmaps");
++ addPathToList(panel->icoL, -1, "%%PREFIX%%/share/WindowMaker/Icons");
++ addPathToList(panel->icoL, -1, "%%PREFIX%%/share/WindowMaker/Pixmaps");
++ addPathToList(panel->icoL, -1, "%%PREFIX%%/share/WindowMaker/Icons");
+ } else {
+ for (i=0; i<PLGetNumberOfElements(array); i++) {
+ val = PLGetArrayElement(array, i);
+@@ -99,7 +99,7 @@
+ wwarning(_("bad value in option PixmapPath. Using default path list"));
+ addPathToList(panel->pixL, -1, "~/pixmaps");
+ addPathToList(panel->pixL, -1, "~/GNUstep/Library/WindowMaker/Pixmaps");
+- addPathToList(panel->pixL, -1, "/usr/local/share/WindowMaker/Pixmaps");
++ addPathToList(panel->pixL, -1, "%%PREFIX%%/share/WindowMaker/Pixmaps");
+ } else {
+ for (i=0; i<PLGetNumberOfElements(array); i++) {
+ val = PLGetArrayElement(array, i);