aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/wmii-devel
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2010-02-25 12:44:52 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2010-02-25 12:44:52 +0000
commit1f268d73dfd63c24e2de74b903032164d99c6de1 (patch)
tree4575b98efabc234d115cf9eeff463d8a0f029e29 /x11-wm/wmii-devel
parentbbd6fbd8b870aa7701b8309b181359b62c7e8ea6 (diff)
downloadports-1f268d73dfd63c24e2de74b903032164d99c6de1.tar.gz
ports-1f268d73dfd63c24e2de74b903032164d99c6de1.zip
- Update to the latest beta, 3.9.b1
- Drop `x11/dmenu' rdep, it is no longer required - Drop `devel/9base' dependency as well, since it is rather incomplete. Users who prefer Plan 9'ish way of configuring WMII are advised to go with `devel/plan9port' port instead - Respect DOCSDIR and NOPORTDOCS - Set LATEST_LINK now it's actually quite usable (esp. with p9p) Feature safe: yes
Notes
Notes: svn path=/head/; revision=250304
Diffstat (limited to 'x11-wm/wmii-devel')
-rw-r--r--x11-wm/wmii-devel/Makefile30
-rw-r--r--x11-wm/wmii-devel/distinfo6
-rw-r--r--x11-wm/wmii-devel/pkg-plist47
3 files changed, 57 insertions, 26 deletions
diff --git a/x11-wm/wmii-devel/Makefile b/x11-wm/wmii-devel/Makefile
index 3acb70efd7db..c8bfb42e0b25 100644
--- a/x11-wm/wmii-devel/Makefile
+++ b/x11-wm/wmii-devel/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: Window Manager Improved 2 (snapshot)
+# New ports collection makefile for: Window Manager Improved 2 (beta)
# Date created: 02 Jun 2005
# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
#
@@ -6,43 +6,39 @@
#
PORTNAME= wmii
-DISTVERSION= snap${SNAPDATE}
+DISTVERSION= 3.9b1
CATEGORIES= x11-wm
MASTER_SITES= http://dl.suckless.org/wmii/
DISTNAME= wmii+ixp-${DISTVERSION}
-EXTRACT_SUFX= .tgz
+EXTRACT_SUFX= .tbz
MAINTAINER= danfe@FreeBSD.org
COMMENT= A dynamic, minimalist window manager for X11
LIB_DEPENDS= ixp.1:${PORTSDIR}/devel/libixp
-RUN_DEPENDS= dmenu:${PORTSDIR}/x11/dmenu \
- ${LOCALBASE}/9/bin/rc:${PORTSDIR}/devel/9base
-SNAPDATE= 20090703
-CONFLICTS= wmii-3.*
-NO_LATEST_LINK= yes
+CONFLICTS= wmii-3.6*
+LATEST_LINK= ${PORTNAME}-devel
+USE_BZIP2= yes
USE_ICONV= yes
USE_XORG= x11 xext xrandr xrender xinerama xft
MAKE_ARGS= PREFIX="${PREFIX}" INCLUDE="${LOCALBASE}/include" \
CC="${CC} -c" LD="${CC}" LIBIXP="-lixp" STATIC="" \
- LIBICONV="-liconv" MAN="${MANPREFIX}/man" \
- VERS="3.6.${SNAPDATE}"
+ LIBICONV="-liconv" MAN="${MANPREFIX}/man" DOC="${DOCSDIR}"
+MAKE_ENV= noisycc=1 # unmute build commands, useful for logs
-MAN1= wmii.1 wmiir.1 wimenu.1
+MAN1= wimenu.1 wmii9menu.1 wmii.1 wmiir.1
post-patch: .SILENT
# Link against system libixp and strip debug build options
${REINPLACE_CMD} -e '/libixp/d' ${WRKSRC}/Makefile
${REINPLACE_CMD} -e 's,-g,-L${LOCALBASE}/lib, ; /^CFLAGS +=/d' \
${WRKSRC}/config.mk
-# Mute "hg: not found" messages
- ${REINPLACE_CMD} -e '/^VERS =/d' ${WRKSRC}/mk/wmii.mk
-# Make actual compile/link commands appear in the build log; do not try to
-# regenerate manpages
- ${REINPLACE_CMD} -E -e 's|^COMPILE=|& noisycc=yes | ; \
- s|^LINK=|& noisycc=yes | ; s|\.man1 ||' ${WRKSRC}/mk/hdr.mk
+.if defined(NOPORTDOCS)
+ ${REINPLACE_CMD} -e '/doc/d' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e '/DOCDIR/s,$$(INSTALL),:,' ${WRKSRC}/mk/common.mk
+.endif
.include <bsd.port.mk>
diff --git a/x11-wm/wmii-devel/distinfo b/x11-wm/wmii-devel/distinfo
index 476b6ef83b55..2c020177bd4e 100644
--- a/x11-wm/wmii-devel/distinfo
+++ b/x11-wm/wmii-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (wmii+ixp-snap20090703.tgz) = 2444c742d8f152d79e22750f48eccd38
-SHA256 (wmii+ixp-snap20090703.tgz) = 56617952f62ed0a5e572fdfcfbb820205e316f8d973cfdea8a6b2032161a30d0
-SIZE (wmii+ixp-snap20090703.tgz) = 429366
+MD5 (wmii+ixp-3.9b1.tbz) = 3ed907c820194b7186f549533bb6d60c
+SHA256 (wmii+ixp-3.9b1.tbz) = b46ecfd6edce640b19d753d79615c851349b6b1d2179368bada612ca8aab0444
+SIZE (wmii+ixp-3.9b1.tbz) = 423229
diff --git a/x11-wm/wmii-devel/pkg-plist b/x11-wm/wmii-devel/pkg-plist
index db8a9cece9b3..691badd72afc 100644
--- a/x11-wm/wmii-devel/pkg-plist
+++ b/x11-wm/wmii-devel/pkg-plist
@@ -4,11 +4,46 @@ bin/wmii
bin/wmii.rc
bin/wmii.sh
bin/wmii9menu
-bin/wmii9rc
bin/wmiir
-bin/wmiistartrc
-etc/wmii-hg/rc.wmii
-etc/wmii-hg/welcome
-etc/wmii-hg/wmiirc
-@dirrm etc/wmii-hg
+etc/wmii/plan9port/wmiirc
+etc/wmii/python/pygmi/__init__.py
+etc/wmii/python/pygmi/event.py
+etc/wmii/python/pygmi/fs.py
+etc/wmii/python/pygmi/menu.py
+etc/wmii/python/pygmi/monitor.py
+etc/wmii/python/pygmi/util.py
+etc/wmii/python/pyxp/__init__.py
+etc/wmii/python/pyxp/asyncclient.py
+etc/wmii/python/pyxp/client.py
+etc/wmii/python/pyxp/dial.py
+etc/wmii/python/pyxp/fcall.py
+etc/wmii/python/pyxp/fields.py
+etc/wmii/python/pyxp/messages.py
+etc/wmii/python/pyxp/mux.py
+etc/wmii/python/pyxp/types.py
+etc/wmii/python/wmiirc
+etc/wmii/python/wmiirc.py
+etc/wmii/ruby/config.rb
+etc/wmii/ruby/config.yaml
+etc/wmii/ruby/wmiirc
+etc/wmii/welcome
+etc/wmii/wmiirc
+@dirrm etc/wmii/ruby
+@dirrm etc/wmii/python/pyxp
+@dirrm etc/wmii/python/pygmi
+@dirrm etc/wmii/python
+@dirrm etc/wmii/plan9port
+@dirrm etc/wmii
lib/libwmii_hack.so
+%%PORTDOCS%%%%DOCSDIR%%/alternative_wmiircs/README
+%%PORTDOCS%%%%DOCSDIR%%/alternative_wmiircs/plan9port/README
+%%PORTDOCS%%%%DOCSDIR%%/alternative_wmiircs/python/README
+%%PORTDOCS%%%%DOCSDIR%%/alternative_wmiircs/ruby/HISTORY
+%%PORTDOCS%%%%DOCSDIR%%/alternative_wmiircs/ruby/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/alternative_wmiircs/ruby/README
+%%PORTDOCS%%%%DOCSDIR%%/wmii.pdf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/alternative_wmiircs/ruby
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/alternative_wmiircs/python
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/alternative_wmiircs/plan9port
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/alternative_wmiircs
+%%PORTDOCS%%@dirrm %%DOCSDIR%%