aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-03 08:14:43 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-03 08:14:43 +0000
commitdbba8af6447e625aae93ec45e619acbecb4ab189 (patch)
treed696a8c2d3e835a743132aa1f6a5cc0557d1c435 /x11-wm
parent683eaaa4ff765b627c52f147501abfaec4449cce (diff)
downloadports-dbba8af6447e625aae93ec45e619acbecb4ab189.tar.gz
ports-dbba8af6447e625aae93ec45e619acbecb4ab189.zip
Overhaul QT/KDE support:
- bsd.port.mk update to use bsd.kde.mk for USE_{QT,KDE}* - Cleanup corresponding ports for bsd.kde.mk update. - Fix bsd.kde.mk: use correct kdelibs dependency, put qt at the bottom, introduce QT_NONSTANDARD variable for nonstandard configure setup. - Update KDE2 to 2.1.1. Two patches included in x11/kdelibs2 to fix the proxy authentication that was broken for 2.1.1. Remove old patches. - Potentially fix kdelibs build for alpha. - Fix qt-designer 2.3.0 build. - Ruby stuff left alone since it looks like black magic to me. Should still work w/ compat shims for older USE_QT[,2] style. Some others were also left alone for the same reason. Reviewed by: portmgr, ports (bsd.kde.mk+bsd.port.mk) Submitted by: David Faure <faure@kde.org> (proxy auth patches) Alex Zepeda <garbanzo@kde.org> (old patches removal)
Notes
Notes: svn path=/head/; revision=40792
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/bbkeys/Makefile2
-rw-r--r--x11-wm/qlwm/Makefile5
-rw-r--r--x11-wm/toolbox/Makefile3
-rw-r--r--x11-wm/wmanager/Makefile2
-rw-r--r--x11-wm/xwmm/Makefile2
5 files changed, 6 insertions, 8 deletions
diff --git a/x11-wm/bbkeys/Makefile b/x11-wm/bbkeys/Makefile
index 5f5da4ef6344..daa472210046 100644
--- a/x11-wm/bbkeys/Makefile
+++ b/x11-wm/bbkeys/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= blackbox:${PORTSDIR}/x11-wm/blackbox
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-USE_QT2=yes
+USE_QT_VER= 2
do-build:
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
diff --git a/x11-wm/qlwm/Makefile b/x11-wm/qlwm/Makefile
index e89e3c1ebf14..2b4e924809e6 100644
--- a/x11-wm/qlwm/Makefile
+++ b/x11-wm/qlwm/Makefile
@@ -19,11 +19,10 @@ DOCS= CHANGES README
LIBDIR= lib/qlwm
PLIST= ${WRKDIR}/pkg-plist
MAN1= qlwm.1
-USE_QT2= yes
+USE_QT_VER= 2
USE_X_PREFIX= yes
-MAKE_ENV= CPPFLAGS="-I${X11BASE}/include/qt2 -I${X11BASE}/include" \
- LFLAGS="-L${X11BASE}/lib -L${X11BASE}/lib/qt2" \
+MAKE_ENV= LFLAGS="-L${X11BASE}/lib -L${X11BASE}/lib/qt2" \
QTDIR=${X11BASE} \
DEST=${PREFIX}/${LIBDIR}
diff --git a/x11-wm/toolbox/Makefile b/x11-wm/toolbox/Makefile
index a242c1f166c8..cf4d38a3a296 100644
--- a/x11-wm/toolbox/Makefile
+++ b/x11-wm/toolbox/Makefile
@@ -12,8 +12,7 @@ MASTER_SITES= http://www2.bc.edu/~kelleyry/toolbox/
MAINTAINER= patseal@hyperhost.net
-USE_QT2= yes
-USE_NEWGCC= yes
+USE_QT_VER= 2
USE_X_PREFIX= yes
MAKE_ENV= CXX="${CXX}" CC="${CC}"
diff --git a/x11-wm/wmanager/Makefile b/x11-wm/wmanager/Makefile
index d873fb6754a4..b580074c6bf6 100644
--- a/x11-wm/wmanager/Makefile
+++ b/x11-wm/wmanager/Makefile
@@ -19,7 +19,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_QT= yes
+USE_QT_VER= 1
USE_GMAKE= yes
MAKE_ENV= prefix=${PREFIX}
diff --git a/x11-wm/xwmm/Makefile b/x11-wm/xwmm/Makefile
index 2f71c9945f56..87dfac8b6560 100644
--- a/x11-wm/xwmm/Makefile
+++ b/x11-wm/xwmm/Makefile
@@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= asami
MAINTAINER= ports@FreeBSD.org
USE_X_PREFIX= yes
-USE_QT2= yes
+USE_QT_VER= 2
USE_GMAKE= yes
MAKE_ENV= QTDIR=$(X11BASE)
ALL_TARGET= # empty