aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-29 07:38:55 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-29 07:38:55 +0000
commit773216ba974b1fba4e0c725c4e5673de3add407c (patch)
tree9de7cad893e65e9f612ab1edf3020489a95bcc5f /x11-wm
parent835d028dc90b109961e7685857a4c230d3b76112 (diff)
downloadports-773216ba974b1fba4e0c725c4e5673de3add407c.tar.gz
ports-773216ba974b1fba4e0c725c4e5673de3add407c.zip
Properly _NET_WM_STATE_ABOVE and _NET_WM_STATE_BELOW.
PR: 57338 Submitted by: Jeremy Messenger <mezz7@cox.net> Reported by: netchild Obtained from: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=210518
Notes
Notes: svn path=/head/; revision=89752
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/sawfish2/Makefile2
-rw-r--r--x11-wm/sawfish2/files/patch-lisp::sawfish::wm::state::wm-spec.jl11
2 files changed, 12 insertions, 1 deletions
diff --git a/x11-wm/sawfish2/Makefile b/x11-wm/sawfish2/Makefile
index 67fd212edbe1..0063e180178d 100644
--- a/x11-wm/sawfish2/Makefile
+++ b/x11-wm/sawfish2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sawfish2
PORTVERSION= 1.3
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 2
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
diff --git a/x11-wm/sawfish2/files/patch-lisp::sawfish::wm::state::wm-spec.jl b/x11-wm/sawfish2/files/patch-lisp::sawfish::wm::state::wm-spec.jl
new file mode 100644
index 000000000000..c51fd1a5a8bd
--- /dev/null
+++ b/x11-wm/sawfish2/files/patch-lisp::sawfish::wm::state::wm-spec.jl
@@ -0,0 +1,11 @@
+--- lisp/sawfish/wm/state/wm-spec.jl.orig Sun Sep 28 22:51:20 2003
++++ lisp/sawfish/wm/state/wm-spec.jl Sun Sep 28 22:52:10 2003
+@@ -125,7 +125,7 @@
+ _NET_WM_WINDOW_TYPE_UTILITY
+ _NET_WM_WINDOW_TYPE_SPLASH])
+
+- (defvar wm-spec-below-depth +2)
++ (defvar wm-spec-below-depth -2)
+ (defvar wm-spec-above-depth +2)
+
+ (define supported-states '())