aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-06-04 22:43:38 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-06-04 22:43:38 +0000
commit93872f18cc0a948ab9c010bbe5694579bd59f8c4 (patch)
tree918c0e1660ed837a4087b57670a1b1c181c285e0 /x11-wm
parentd7568468f977aa272698f2ab9e7164f2a52b0ad5 (diff)
downloadports-93872f18cc0a948ab9c010bbe5694579bd59f8c4.tar.gz
ports-93872f18cc0a948ab9c010bbe5694579bd59f8c4.zip
Move inclusion of bsd.port.pre.mk later in the file for conditional BROKEN
tag. Early inclusion caused problems for some ports, so to be safe I'm updating all of them. Pointy hat to: kris
Notes
Notes: svn path=/head/; revision=82300
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/qlwm/Makefile12
-rw-r--r--x11-wm/toolbox/Makefile10
-rw-r--r--x11-wm/wmanager/Makefile12
-rw-r--r--x11-wm/xwmm/Makefile12
4 files changed, 23 insertions, 23 deletions
diff --git a/x11-wm/qlwm/Makefile b/x11-wm/qlwm/Makefile
index 13897f7269a8..35e6c2201007 100644
--- a/x11-wm/qlwm/Makefile
+++ b/x11-wm/qlwm/Makefile
@@ -15,12 +15,6 @@ MASTER_SITES= http://www.netcologne.de/~nc-lindenal/qlwm/
MAINTAINER= trevor@FreeBSD.org
COMMENT= Qt-based window manager
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Fails to link"
-.endif
-
DOCDIR= share/doc/${PORTNAME}
DOCS= CHANGES README
LIBDIR= lib/${PORTNAME}
@@ -34,6 +28,12 @@ REINPLACE_ARGS= -i'' -E
MAKE_ENV= DEST="${PREFIX}/${LIBDIR}" INCPATH="${QTCPPFLAGS}" \
LIBS="${QTCFGLIBS} -lqt-mt -pthread" LINK="${CXX}" MOC="${MOC}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Fails to link"
+.endif
+
post-patch:
find ${WRKSRC} -name "Makefile" | xargs ${REINPLACE_CMD} \
's|/usr/local/qlwm|${PREFIX}/${LIBDIR}|g ; \
diff --git a/x11-wm/toolbox/Makefile b/x11-wm/toolbox/Makefile
index b1a1d30a38a0..d1eb3dde457c 100644
--- a/x11-wm/toolbox/Makefile
+++ b/x11-wm/toolbox/Makefile
@@ -13,17 +13,17 @@ MASTER_SITES= http://www2.bc.edu/~kelleyry/toolbox/
MAINTAINER= ports@FreeBSD.org
COMMENT= A blackbox style configuration utility
+USE_QT_VER= 2
+USE_X_PREFIX= yes
+
+MAKE_ENV= CXX="${CXX}" CC="${CC}"
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Fails to link"
.endif
-USE_QT_VER= 2
-USE_X_PREFIX= yes
-
-MAKE_ENV= CXX="${CXX}" CC="${CC}"
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/toolbox ${PREFIX}/bin/toolbox
diff --git a/x11-wm/wmanager/Makefile b/x11-wm/wmanager/Makefile
index 0678e41479c3..ac19542e3df5 100644
--- a/x11-wm/wmanager/Makefile
+++ b/x11-wm/wmanager/Makefile
@@ -16,12 +16,6 @@ COMMENT= X11 window manager selector
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
@@ -29,6 +23,12 @@ MAKE_ENV= CXX="${CXX}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmanager ${PREFIX}/bin
.if !defined(NOPORTDOCS)
diff --git a/x11-wm/xwmm/Makefile b/x11-wm/xwmm/Makefile
index 89ed06bdf524..198246328572 100644
--- a/x11-wm/xwmm/Makefile
+++ b/x11-wm/xwmm/Makefile
@@ -14,18 +14,18 @@ MASTER_SITE_SUBDIR= asami
MAINTAINER= kde@freebsd.org
COMMENT= A simple utility managing multiple Window Managers with Qt
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_X_PREFIX= yes
USE_QT_VER= 2
USE_GMAKE= yes
MAKE_ENV= QTDIR=$(X11BASE)
ALL_TARGET= # empty
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
do-install:
$(INSTALL_PROGRAM) $(WRKSRC)/xwmm $(PREFIX)/bin
$(INSTALL_SCRIPT) $(WRKSRC)/startkde.fixed $(PREFIX)/bin/startkde.xwmm