aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-10-14 05:48:56 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-10-14 05:48:56 +0000
commita220c594d84b7d5f853c374c9a4df901ed869594 (patch)
treec5c8dcdafc378d12b2e703926d80b1ef9d21268f /x11-wm
parent7a9d557b006915053ddc48bce020f71b411fad8d (diff)
downloadports-a220c594d84b7d5f853c374c9a4df901ed869594.tar.gz
ports-a220c594d84b7d5f853c374c9a4df901ed869594.zip
Install pkg-config files needed by obconf.
Notes
Notes: svn path=/head/; revision=91134
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/openbox/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/x11-wm/openbox/Makefile b/x11-wm/openbox/Makefile
index 466e6e6c4661..5cdf303ba1b5 100644
--- a/x11-wm/openbox/Makefile
+++ b/x11-wm/openbox/Makefile
@@ -8,6 +8,7 @@
PORTNAME= openbox
PORTVERSION= 0.3.0.4
+PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= http://icculus.org/openbox/releases/
DISTNAME= openbox-3.0-rc4
@@ -49,6 +50,9 @@ pre-install:
.for ii in gnome-panel-control openbox kdetrayproxy themeupdate.py
${ECHO_CMD} bin/${ii} >> ${PLIST}
.endfor
+.for ii in parser render
+ ${ECHO_CMD} libdata/pkgconfig/ob${ii}-3.0.pc >> ${PLIST}
+.endfor
cd ${WRKSRC} && ${FIND} -s data themes -type f \
| ${SED} -e 's:^:share/openbox/:' >> ${PLIST} \
&& ${FIND} data themes -type d | sort -r \
@@ -82,6 +86,10 @@ do-install:
.for ii in parser/parse render/theme render/render
${INSTALL_DATA} ${WRKSRC}/${ii}.h ${PREFIX}/include/openbox/3.0
.endfor
+.for ii in parser render
+ ${INSTALL_DATA} ${WRKSRC}/${ii}/ob${ii}-3.0.pc \
+ ${PREFIX}/libdata/pkgconfig/
+.endfor
.for ii in menu rc
${INSTALL_DATA} ${WRKSRC}/data/${ii}.xml \
${PREFIX}/etc/openbox/xdg/openbox