aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-12-28 16:29:45 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-12-28 16:29:45 +0000
commit6f73c5cbdafdd4b950b048e6ccad272759260773 (patch)
tree7bc8be33e64567ab5c217f2c9c6da910ccfe6660 /x11-wm
parentf0798650de3f415075f26719a96be42400c867b7 (diff)
downloadports-6f73c5cbdafdd4b950b048e6ccad272759260773.tar.gz
ports-6f73c5cbdafdd4b950b048e6ccad272759260773.zip
JWM is a window manager for the X11 Window System. JWM is written in C and uses
only Xlib at a minimum. PR: ports/91015 Submitted by: Babak Farrokhi <babak@farrokhi.net>
Notes
Notes: svn path=/head/; revision=152288
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/jwm/Makefile38
-rw-r--r--x11-wm/jwm/distinfo3
-rw-r--r--x11-wm/jwm/files/patch-example-jwmrc12
-rw-r--r--x11-wm/jwm/pkg-descr7
5 files changed, 61 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 0c46f7d22076..70ad2b969b15 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -56,6 +56,7 @@
SUBDIR += ion-2
SUBDIR += ion-3ds
SUBDIR += jewel
+ SUBDIR += jwm
SUBDIR += kahakai
SUBDIR += kappdock
SUBDIR += kompmgr
diff --git a/x11-wm/jwm/Makefile b/x11-wm/jwm/Makefile
new file mode 100644
index 000000000000..55c7a74697a0
--- /dev/null
+++ b/x11-wm/jwm/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: jwm
+# Date created: 26 DEC 2005
+# Whom: babak@farrokhi.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= jwm
+PORTVERSION= 1.1
+CATEGORIES= x11-wm
+MASTER_SITES= http://joewing.net/programs/jwm/ \
+ http://joesbox.xmgfree.com/jwm/
+
+MAINTAINER= babak@farrokhi.net
+COMMENT= Joe's Window Manager
+
+MAN1= jwm.1
+USE_X_PREFIX= yes
+USE_XPM= yes
+HAS_CONFIGURE= yes
+USE_BZIP2= yes
+USE_REINPLACE= yes
+PLIST_FILES= bin/jwm etc/system.jwmrc
+CONFIGURE_ARGS= --prefix=${PREFIX} --enable-icons \
+ --enable-png --enable-xpm --enable-shape \
+ --enable-xinerama --enable-xft --enable-xrender
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,^CC =,CC ?=,' \
+ -e 's,^CFLAGS =,CFLAGS +=,' \
+ ${WRKSRC}/src/Makefile.in
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/jwm ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/example.jwmrc ${PREFIX}/etc/system.jwmrc
+ ${INSTALL_MAN} ${WRKSRC}/jwm.1 ${MANPREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/x11-wm/jwm/distinfo b/x11-wm/jwm/distinfo
new file mode 100644
index 000000000000..ef91c1fcf79f
--- /dev/null
+++ b/x11-wm/jwm/distinfo
@@ -0,0 +1,3 @@
+MD5 (jwm-1.1.tar.bz2) = b5afb82b017894665c73ed3febbafaa9
+SHA256 (jwm-1.1.tar.bz2) = eead5a45c0743c515241c7c93fba32a236627bddafe3f0f2d4e0bef72e1d1657
+SIZE (jwm-1.1.tar.bz2) = 111464
diff --git a/x11-wm/jwm/files/patch-example-jwmrc b/x11-wm/jwm/files/patch-example-jwmrc
new file mode 100644
index 000000000000..a172b79ef45d
--- /dev/null
+++ b/x11-wm/jwm/files/patch-example-jwmrc
@@ -0,0 +1,12 @@
+--- example.jwmrc.orig Wed Dec 28 16:16:26 2005
++++ example.jwmrc Wed Dec 28 16:19:07 2005
+@@ -113,6 +113,9 @@
+
+ <Icons>
+ <IconPath>$HOME/.icons</IconPath>
++ <IconPath>%%PREFIX%%/share/icons</IconPath>
++ <IconPath>%%PREFIX%%/share/pixmaps</IconPath>
++ <IconPath>%%PREFIX%%/lib/X11/icons</IconPath>
+ </Icons>
+
+ <StartupCommand>
diff --git a/x11-wm/jwm/pkg-descr b/x11-wm/jwm/pkg-descr
new file mode 100644
index 000000000000..2e2b7b73cf69
--- /dev/null
+++ b/x11-wm/jwm/pkg-descr
@@ -0,0 +1,7 @@
+WM is a window manager for the X11 Window System.
+JWM is written in C and uses only Xlib at a minimum.
+
+WWW: http://joewing.net/programs/jwm/index.shtml
+
+-- Babak Farrokhi
+ babak@farrokhi.net