aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-11 17:16:10 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-11 17:16:10 +0000
commit19a718ac4c38750e766de7abf027f0491981495d (patch)
tree8fad9fa05facfd939ca92589f047e5224dffd236 /x11-wm
parent47c68887b223642a73baccd0fa69c8caf7845044 (diff)
downloadports-19a718ac4c38750e766de7abf027f0491981495d.tar.gz
ports-19a718ac4c38750e766de7abf027f0491981495d.zip
Convert all core GNOME1 components and some of the most popular GNOME1
apps to bsd.gnomeng.mk. The goal is to make GNOME1 framework more modular, which will allow to use GNOME1 apps with GNOME2 desktop as well as considerably reduce langht of dependency chains for GNOME1 ports (for example after this commit AbiWord's dependency chain was reduced by 7 ports from 57 to only 50, while Gnumeric's - from 60 to 53 and so on). The most of the GNOME1 apps are still not converted, so that lot of work is still ahead. Please report any unusual problems to gnome@FreeBSD.org. Discussed with: marcus Reviewed by: marcus
Notes
Notes: svn path=/head/; revision=62821
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/sawfish/Makefile17
-rw-r--r--x11-wm/sawfish/pkg-plist8
2 files changed, 8 insertions, 17 deletions
diff --git a/x11-wm/sawfish/Makefile b/x11-wm/sawfish/Makefile
index 8fe128b0adea..fa8edb140f40 100644
--- a/x11-wm/sawfish/Makefile
+++ b/x11-wm/sawfish/Makefile
@@ -28,11 +28,11 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_IMLIB= yes
USE_REINPLACE= yes
+USE_GNOMENG= yes
WANT_GNOME= yes
+USE_GNOME= gnomehack gnomehier gtk12 imlib esound
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-readline \
- --localstatedir=${PREFIX}/share \
- --datadir=${PREFIX}/share
+CONFIGURE_ARGS= --with-readline
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= ${ARCH}-pc-freebsd${OSREL:C/\..*//}
@@ -45,8 +45,9 @@ WITH_GNOME= yes
.include <bsd.port.pre.mk>
-.if defined(HAVE_GNOME)
-USE_GNOME= yes
+.if ${HAVE_GNOME:Mlibcapplet}!="" && ${HAVE_GNOME:Mgdkpixbuf}!=""
+USE_GNOME+= libcapplet gdkpixbuf
+PKGNAMESUFFIX= -gnome
CONFIGURE_ARGS+=--enable-capplet
.else
CONFIGURE_ARGS+=--disable-capplet \
@@ -54,15 +55,11 @@ CONFIGURE_ARGS+=--disable-capplet \
--without-gdk-pixbuf
.endif
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -e 's^-l(pthread|c_r)^${PTHREAD_LIBS}^g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|[(]top_builddir[)]/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${REINPLACE_CMD} -e \
- 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
- s|[(]datadir[)]/aclocal|(prefix)/share/aclocal|g ; \
- s|[(]datadir[)]/locale|(prefix)/share/locale|g'
post-install:
install-info --section="X11 window manager" \
diff --git a/x11-wm/sawfish/pkg-plist b/x11-wm/sawfish/pkg-plist
index a53d527dce5b..5ee9cf91ce91 100644
--- a/x11-wm/sawfish/pkg-plist
+++ b/x11-wm/sawfish/pkg-plist
@@ -69,7 +69,7 @@ share/gnome/pixmaps/sawfish-logo.png
%%GNOME:%%share/gnome/pixmaps/sawfish-shortcuts.png
%%GNOME:%%share/gnome/pixmaps/sawfish-tooltips.png
%%GNOME:%%share/gnome/pixmaps/sawfish-workspaces.png
-%%GNOME:%%share/gnome/wm-properties/Sawfish.desktop
+share/gnome/wm-properties/Sawfish.desktop
share/locale/az/LC_MESSAGES/sawfish.mo
share/locale/bg/LC_MESSAGES/sawfish.mo
share/locale/ca/LC_MESSAGES/sawfish.mo
@@ -657,8 +657,6 @@ share/sawfish/%%VERSION%%/themes/smaker/close_inv.png
share/sawfish/%%VERSION%%/themes/smaker/min.png
share/sawfish/%%VERSION%%/themes/smaker/min_inv.png
share/sawfish/%%VERSION%%/themes/smaker/theme.jl
-@dirrm share/sawfish/themes
-@dirrm share/sawfish/sounds
@dirrm share/sawfish/%%VERSION%%/themes/smaker
@dirrm share/sawfish/%%VERSION%%/themes/simple
@dirrm share/sawfish/%%VERSION%%/themes/mono
@@ -688,15 +686,11 @@ share/sawfish/%%VERSION%%/themes/smaker/theme.jl
@dirrm share/sawfish/%%VERSION%%/lisp/sawfish
@dirrm share/sawfish/%%VERSION%%/lisp
@dirrm share/sawfish/%%VERSION%%
-@dirrm share/sawfish
-%%NOGNOME:%%@dirrm share/gnome/pixmaps
%%GNOME:%%@dirrm share/gnome/control-center/Sawfish
%%GNOME:%%@dirrm share/gnome/apps/Settings/Sawfish
-%%NOGNOME:%%@dirrm share/gnome
@dirrm libexec/sawfish/%%VERSION%%/%%GNUHOST%%/sawfish/wm/util
@dirrm libexec/sawfish/%%VERSION%%/%%GNUHOST%%/sawfish/wm
@dirrm libexec/sawfish/%%VERSION%%/%%GNUHOST%%/sawfish
@dirrm libexec/sawfish/%%VERSION%%/%%GNUHOST%%
@dirrm libexec/sawfish/%%VERSION%%
-@dirrm libexec/sawfish
@dirrm libexec/rep/%%GNUHOST%%/sawfish