aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-03-15 11:51:30 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-03-15 11:51:30 +0000
commita4aa7ad65a8331db10c7d22857449d1681aaa9f0 (patch)
treeeb140f313a45b4b309b7958eeb85ceb52573b246 /x11-wm
parent1088df1e34c32e60ac5060c16536d83725e5825e (diff)
downloadports-a4aa7ad65a8331db10c7d22857449d1681aaa9f0.tar.gz
ports-a4aa7ad65a8331db10c7d22857449d1681aaa9f0.zip
Contrary to the assertion in the configure script, it is not "better to
link C++ code with the C compiler". This fixes the build on amd64.
Notes
Notes: svn path=/head/; revision=104076
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/icewm/files/patch-configure11
-rw-r--r--x11-wm/icewm/files/patch-configure.in38
2 files changed, 49 insertions, 0 deletions
diff --git a/x11-wm/icewm/files/patch-configure b/x11-wm/icewm/files/patch-configure
new file mode 100644
index 000000000000..f32d878f7811
--- /dev/null
+++ b/x11-wm/icewm/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Mon Mar 15 03:48:52 2004
++++ configure Mon Mar 15 03:49:27 2004
+@@ -3332,7 +3332,7 @@
+ ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
+
+ if test x"$ac_cv_c_compiler_gnu" != x; then
+- CXX_LINK=${CC}
++ CXX_LINK=${CXX}
+ fi
+
+
diff --git a/x11-wm/icewm/files/patch-configure.in b/x11-wm/icewm/files/patch-configure.in
new file mode 100644
index 000000000000..56a54e511fc4
--- /dev/null
+++ b/x11-wm/icewm/files/patch-configure.in
@@ -0,0 +1,38 @@
+--- configure.in.orig Mon Mar 15 03:46:35 2004
++++ configure.in Mon Mar 15 03:46:25 2004
+@@ -25,35 +25,6 @@
+ AC_LANG_CPLUSPLUS
+ AC_PROG_CXX
+
+-dnl ----------- If both CC and CXX are GNU compilers, it is better to use CC ---
+-dnl ---- for linking. Also check how to turn off RTTI and exception handling ---
+-if test x"$ac_cv_prog_gxx" != x; then
+- AC_PROG_CC
+- if test x"$ac_cv_prog_gcc" != x; then
+- CXX_LINK=${CC}
+- fi
+-
+- ICE_CXX_FLAG_ACCEPT(no_rtti, -fno-rtti)
+- dnl --- Intel C++ supports -fno-rtti, but doens't support -fno-*-exceptions
+- if test $(basename $CXX) != "icc"; then
+- ICE_CXX_FLAG_ACCEPT(no_exceptions, -fno-exceptions)
+- if test x"$no_exceptions_ok" = xno; then
+- ICE_CXX_FLAG_ACCEPT(no_exceptions, -fno-handle-exceptions)
+- fi
+- fi
+-fi
+-
+-if test x"$ac_cv_prog_gxx" != x; then
+- dnl --- Intel C++ doesn't supports lots of GCC -W* and -fpermissive
+- if test $(basename $CXX) = "icc"; then
+- dnl --- Using -w0 to avoid noisy "remark" messages
+- ICE_CXX_FLAG_ACCEPT(warn_xxx, -w0)
+- else
+- ICE_CXX_FLAG_ACCEPT(warn_xxx, -Wall -Wpointer-arith -Wconversion -Wwrite-strings -Winline -Woverloaded-virtual -W)
+- ICE_CXX_FLAG_ACCEPT(permissive, -fpermissive)
+- fi
+-fi
+-
+ if test x"$CXX_LINK" = x; then
+ CXX_LINK=$CXX
+ fi