aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-07 21:50:41 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-07 21:50:41 +0000
commitcb7fc08926ba29beed598538df2eabc57a73758a (patch)
tree37eef45fa76c0b4eadc28cc6929bcc3f0e4e87ac /x11-wm
parent7594a830571e1cb3fbf56e85847166458960a544 (diff)
downloadports-cb7fc08926ba29beed598538df2eabc57a73758a.tar.gz
ports-cb7fc08926ba29beed598538df2eabc57a73758a.zip
Make it work with recent version of enlightenment.
PR: ports/99856 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=167164
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/e17-module-weather/Makefile1
-rw-r--r--x11-wm/e17-module-weather/files/patch-e_mod_main.c12
2 files changed, 13 insertions, 0 deletions
diff --git a/x11-wm/e17-module-weather/Makefile b/x11-wm/e17-module-weather/Makefile
index 5f9b4237ef1f..f53f241b95a5 100644
--- a/x11-wm/e17-module-weather/Makefile
+++ b/x11-wm/e17-module-weather/Makefile
@@ -7,6 +7,7 @@
PORTNAME= weather
PORTVERSION= 23062006
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://mbsd.msk.ru/dist/
PKGNAMEPREFIX= e17-module-
diff --git a/x11-wm/e17-module-weather/files/patch-e_mod_main.c b/x11-wm/e17-module-weather/files/patch-e_mod_main.c
new file mode 100644
index 000000000000..64cfef8a20e0
--- /dev/null
+++ b/x11-wm/e17-module-weather/files/patch-e_mod_main.c
@@ -0,0 +1,12 @@
+--- e_mod_main.c.orig Thu Jul 6 23:05:04 2006
++++ e_mod_main.c Thu Jul 6 23:05:19 2006
+@@ -354,7 +354,8 @@
+ EAPI int
+ e_modapi_about(E_Module *m)
+ {
+- e_module_dialog_show(D_("Enlightenment Weather Module"), D_("A weather forecast module for Enlightenment"));
++ e_module_dialog_show(m, D_("Enlightenment Weather Module"),
++ D_("A weather forecast module for Enlightenment"));
+ return 1;
+ }
+