aboutsummaryrefslogtreecommitdiff
path: root/x11/XFree86
diff options
context:
space:
mode:
authorJean-Marc Zucconi <jmz@FreeBSD.org>2002-04-02 13:04:27 +0000
committerJean-Marc Zucconi <jmz@FreeBSD.org>2002-04-02 13:04:27 +0000
commit443e4b043b9738eee43b9b1b54d09d1af522d219 (patch)
tree60f1a401537b8295640e03f94d2391b9121e3140 /x11/XFree86
parent30cda655e2d04e41d8223e257ea358f1180da643 (diff)
downloadports-443e4b043b9738eee43b9b1b54d09d1af522d219.tar.gz
ports-443e4b043b9738eee43b9b1b54d09d1af522d219.zip
Fix the build on -current.
Do not compile with 'make -k'.
Notes
Notes: svn path=/head/; revision=57197
Diffstat (limited to 'x11/XFree86')
-rw-r--r--x11/XFree86/Makefile3
-rw-r--r--x11/XFree86/files/patch-y18
-rw-r--r--x11/XFree86/files/patch-z16
3 files changed, 36 insertions, 1 deletions
diff --git a/x11/XFree86/Makefile b/x11/XFree86/Makefile
index 02922120e0a2..e343d33041c2 100644
--- a/x11/XFree86/Makefile
+++ b/x11/XFree86/Makefile
@@ -7,7 +7,7 @@
PORTNAME= XFree86
PORTVERSION= 3.3.6
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_XFREE}
MASTER_SITE_SUBDIR= ${PORTVERSION}
@@ -32,6 +32,7 @@ INSTALL_TARGET+= install.linkkit
DIST_SUBDIR= xc
SCRIPTS_ENV= OSVERSION=${OSVERSION} MACHINE=${MACHINE} \
MACHINE_ARCH=${MACHINE_ARCH}
+MAKE_ARGS= WORLDOPTS=
# can't use USE_X_PREFIX here -- it will cause a circular dependency
PREFIX= ${X11BASE}
MTREE_FILE= /etc/mtree/BSD.x11.dist
diff --git a/x11/XFree86/files/patch-y b/x11/XFree86/files/patch-y
new file mode 100644
index 000000000000..90b55cf20c84
--- /dev/null
+++ b/x11/XFree86/files/patch-y
@@ -0,0 +1,18 @@
+--- lib/font/Type1/spaces.c.orig Tue Apr 2 03:37:02 2002
++++ lib/font/Type1/spaces.c Tue Apr 2 03:57:38 2002
+@@ -38,6 +38,7 @@
+ :h3.Include Files
+ */
+ /* $XFree86: xc/lib/font/Type1/spaces.c,v 3.0.6.2 1998/10/04 15:22:56 hohndel Exp $ */
++#include "X11/Xos.h"
+ #include "objects.h"
+ #include "spaces.h"
+ #include "paths.h"
+@@ -45,7 +46,6 @@
+ #include "fonts.h"
+ #include "arith.h"
+ #include "trig.h"
+-#include "X11/Xos.h"
+
+ static void FindFfcn();
+ static void FindIfcn();
diff --git a/x11/XFree86/files/patch-z b/x11/XFree86/files/patch-z
new file mode 100644
index 000000000000..5ecb4d3b82e8
--- /dev/null
+++ b/x11/XFree86/files/patch-z
@@ -0,0 +1,16 @@
+--- programs/Xserver/include/misc.h.orig Tue Apr 2 04:43:50 2002
++++ programs/Xserver/include/misc.h Tue Apr 2 04:44:43 2002
+@@ -158,11 +158,11 @@
+
+ #define min(a, b) (((a) < (b)) ? (a) : (b))
+ #define max(a, b) (((a) > (b)) ? (a) : (b))
+-#if !defined(AMOEBA) && !defined(__EMX__)
++#if !defined(AMOEBA) && !defined(__EMX__) && !defined(__FreeBSD__)
+ #ifndef abs
+ #define abs(a) ((a) > 0 ? (a) : -(a))
+ #endif
+-#else /* AMOEBA || __EMX__ */
++#else /* AMOEBA || __EMX__ || __FreeBSD__ */
+ /* abs() is a function, not a macro; include the file declaring
+ * it in case we haven't done that yet.
+ */