aboutsummaryrefslogtreecommitdiff
path: root/x11/avant-window-navigator/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-05-28 14:41:03 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-05-28 14:41:03 +0000
commit6457fc97b9486a0d18fb7ffb5e733fb75e78fff0 (patch)
tree48ea5dc44368852e10abacbd46f5f4d1f4b4dd70 /x11/avant-window-navigator/Makefile
parent5ba5b972563b99e82d2e0121244af78985b9310a (diff)
downloadports-6457fc97b9486a0d18fb7ffb5e733fb75e78fff0.tar.gz
ports-6457fc97b9486a0d18fb7ffb5e733fb75e78fff0.zip
Avant Window Navigator (Awn) is a dock-like bar which sits at the
bottom of the screen. It has support for launchers, task lists, and third party applets. WWW: http://launchpad.net/awn
Notes
Notes: svn path=/head/; revision=234699
Diffstat (limited to 'x11/avant-window-navigator/Makefile')
-rw-r--r--x11/avant-window-navigator/Makefile72
1 files changed, 72 insertions, 0 deletions
diff --git a/x11/avant-window-navigator/Makefile b/x11/avant-window-navigator/Makefile
new file mode 100644
index 000000000000..7d6201e6f33a
--- /dev/null
+++ b/x11/avant-window-navigator/Makefile
@@ -0,0 +1,72 @@
+# New ports collection makefile for: avant-window-navigator
+# Date created: 18 May 2009
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= avant-window-navigator
+PORTVERSION= 0.3.2.1
+CATEGORIES= x11
+MASTER_SITES= http://launchpad.net/awn/0.2/${PORTVERSION}/+download/ \
+ http://mirror.amdmi3.ru/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Dock-like navigation bar
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg
+LIB_DEPENDS= wnck-1.22:${PORTSDIR}/x11-toolkits/libwnck \
+ dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack glib20 gtk20 pygtk2
+USE_PYTHON= yes
+USE_GETTEXT= yes
+USE_LDCONFIG= yes
+INSTALLS_ICONS= yes
+USE_XORG= x11 xproto xcomposite xrender
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
+ CPPFLAGS="-I${LOCALBASE}/include"
+MAKE_JOBS_SAFE= yes
+
+AWN_DESKTOP?= agnostic
+
+.if ${AWN_DESKTOP} == "gnome"
+USE_GNOME+= gnomedesktop libgnomeui
+CONFIGURE_ARGS+= --with-desktop=gnome
+PNGNAMESUFFIX= -gnome
+CONFLICTS= ${PORTNAME}-xfce4-[0-9]* ${PORTNAME}-[0-9]*
+WITH_GCONF= yes
+.elif ${AWN_DESKTOP} == "xfce4"
+OPTIONS= GCONF "Use GConf to store configuration information" off
+USE_XFCE+= thunar
+CONFIGURE_ARGS+= --with-desktop=xfce4
+PNGNAMESUFFIX= -xfce4
+CONFLICTS= ${PORTNAME}-gnome-[0-9]* ${PORTNAME}-[0-9]*
+.else
+# agnostic desktop
+OPTIONS= GCONF "Use GConf to store configuration information" off
+CONFIGURE_ARGS+= --with-desktop=agnostic
+CONFLICTS= ${PORTNAME}-gnome-[0-9]* ${PORTNAME}-xfce4-[0-9]*
+.endif
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_GCONF)
+USE_GNOME+= gconf2
+GCONF_SCHEMAS= awn.schemas awn-applets-shared.schemas
+CONFIGURE_ARGS+= --with-gconf
+.else
+CONFIGURE_ARGS+= --without-gconf
+.endif
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|#!/usr/bin/python|#!/usr/bin/env python|' \
+ ${WRKSRC}/awn-manager/awnManager.py.in \
+ ${WRKSRC}/awn-manager/awnManager.py
+
+.include <bsd.port.post.mk>