aboutsummaryrefslogtreecommitdiff
path: root/x11/blast
diff options
context:
space:
mode:
authorChuck Robey <chuckr@FreeBSD.org>1996-07-31 22:07:52 +0000
committerChuck Robey <chuckr@FreeBSD.org>1996-07-31 22:07:52 +0000
commit4f78682929250d9ad03f23582cbaec00a1c964a8 (patch)
tree7bd409ef31aa423661b7eba66ae5f4934191cee6 /x11/blast
parentab393d817d162c1a844767b1dc2f12e40e2ea93a (diff)
downloadports-4f78682929250d9ad03f23582cbaec00a1c964a8.tar.gz
ports-4f78682929250d9ad03f23582cbaec00a1c964a8.zip
New X11 game, leaves holes in your windows!
Submitted by: Michael Searle
Notes
Notes: svn path=/head/; revision=3474
Diffstat (limited to 'x11/blast')
-rw-r--r--x11/blast/Makefile37
-rw-r--r--x11/blast/distinfo1
-rw-r--r--x11/blast/pkg-comment1
-rw-r--r--x11/blast/pkg-descr5
-rw-r--r--x11/blast/pkg-plist2
5 files changed, 46 insertions, 0 deletions
diff --git a/x11/blast/Makefile b/x11/blast/Makefile
new file mode 100644
index 000000000000..ed60c4435fef
--- /dev/null
+++ b/x11/blast/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: blast-1.0
+# Version required: 1.0
+# Date created: 9 Jul 1996
+# Whom: searle
+#
+# $Id: porting.sgml,v 1.11 1995/12/07 13:22:15 jkh Exp $
+#
+
+DISTNAME= blast-1.0-ss-9.03
+PKGNAME= blast-1.0
+CATEGORIES+= x11
+MASTER_SITES= ftp://hpux.csc.liv.ac.uk/hpux/X11/Demos/blast-1.0/ \
+ ftp://ftp.ask.uni-karlsruhe.de/pub/hpux/X11/Demos/blast-1.0/ \
+ ftp://ftp.univie.ac.at/systems/hpux/hpux/X11/Demos/blast-1.0/ \
+ ftp://hpftp.cict.fr/hpux/X11/Demos/blast-1.0/ \
+ ftp://parnas.mimuw.edu.pl/hpux/X11/Demos/blast-1.0/
+
+MAINTAINER= searle@longacre.demon.co.uk
+
+USE_X11= yes
+
+MANDIR= $(PREFIX)/man/man1
+
+pre-configure:
+ mv $(WRKDIR)/blast-1.0 $(WRKSRC)
+
+do-build:
+ cc $(WRKSRC)/blast.c -I/usr/X11R6/include -O2 -L$(PREFIX)/lib -lX11 -lXext -o $(WRKSRC)/blast
+
+do-install:
+ $(INSTALL) -c $(WRKSRC)/blast $(PREFIX)/bin/blast
+ $(INSTALL) -c $(WRKSRC)/blast.man $(DESTDIR)$(MANDIR)/blast.1
+.if !defined(NOMANCOMPRESS)
+ gzip -9 $(MANDIR)/blast.1
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11/blast/distinfo b/x11/blast/distinfo
new file mode 100644
index 000000000000..2af858f20ffd
--- /dev/null
+++ b/x11/blast/distinfo
@@ -0,0 +1 @@
+MD5 (blast-1.0-ss-9.03.tar.gz) = e530a49424ed753ca51b403f5620edd2
diff --git a/x11/blast/pkg-comment b/x11/blast/pkg-comment
new file mode 100644
index 000000000000..5a084b931b67
--- /dev/null
+++ b/x11/blast/pkg-comment
@@ -0,0 +1 @@
+Blast blows holes through windows.
diff --git a/x11/blast/pkg-descr b/x11/blast/pkg-descr
new file mode 100644
index 000000000000..565f84a9212e
--- /dev/null
+++ b/x11/blast/pkg-descr
@@ -0,0 +1,5 @@
+Blast blows holes in windows - you can see what's behind it through them. It
+uses the X Shape Extension.
+
+Michael Searle
+searle@longacre.demon.co.uk
diff --git a/x11/blast/pkg-plist b/x11/blast/pkg-plist
new file mode 100644
index 000000000000..ece066fb0f3f
--- /dev/null
+++ b/x11/blast/pkg-plist
@@ -0,0 +1,2 @@
+bin/blast
+man/man1/blast.1.gz