aboutsummaryrefslogtreecommitdiff
path: root/x11/bmpanel2
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-10-18 11:55:40 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-10-18 11:55:40 +0000
commit457517b034aedff3ad4ebbd415a2ae61ac4c9922 (patch)
treecc31a9b40606dc2feb87596cbaaaf9ed732bdb89 /x11/bmpanel2
parent5b99b6ed79a87751e9bcfca3da4735d4bb5f191e (diff)
downloadports-457517b034aedff3ad4ebbd415a2ae61ac4c9922.tar.gz
ports-457517b034aedff3ad4ebbd415a2ae61ac4c9922.zip
- Unbreak the build on -CURRENT by explicitly linking against libm as a
remedy to the following error: [100%] Linking C executable bmpanel2 /usr/bin/ld: undefined reference to symbol `truncf@@FBSD_1.0' (try adding -lm) //lib/libm.so.5: could not read symbols: Bad value - While here fix long standing issue of -L${LOCALBASE}/lib being required in LDFLAGS while USES=pkgconfig due to missing LINK_DIRECTORIES() call in the top-level `CMakeLists.txt'
Notes
Notes: svn path=/head/; revision=399614
Diffstat (limited to 'x11/bmpanel2')
-rw-r--r--x11/bmpanel2/Makefile2
-rw-r--r--x11/bmpanel2/files/patch-CMakeLists.txt15
2 files changed, 15 insertions, 2 deletions
diff --git a/x11/bmpanel2/Makefile b/x11/bmpanel2/Makefile
index 3267ce7ca3a4..7a99cc1fc3ff 100644
--- a/x11/bmpanel2/Makefile
+++ b/x11/bmpanel2/Makefile
@@ -18,8 +18,6 @@ USES= cmake pkgconfig
USE_GNOME= pango
USE_XORG= x11 xext
-LDFLAGS+= -L${LOCALBASE}/lib # XXX should not be needed
-
OPTIONS_DEFINE= OPACITY TEMPERATURE
OPACITY_DESC= Opacity setting with compositing window managers
TEMPERATURE_DESC= Build with temperature widget (for CPU, etc.)
diff --git a/x11/bmpanel2/files/patch-CMakeLists.txt b/x11/bmpanel2/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..a70d1c65214e
--- /dev/null
+++ b/x11/bmpanel2/files/patch-CMakeLists.txt
@@ -0,0 +1,15 @@
+--- CMakeLists.txt.orig 2009-11-01 05:50:26 UTC
++++ CMakeLists.txt
+@@ -50,9 +50,11 @@ PKG_CHECK_MODULES(GTHREAD REQUIRED gthre
+
+ INCLUDE_DIRECTORIES(${X11_INCLUDE_DIRS} ${CAIRO_INCLUDE_DIRS}
+ ${GLIB_INCLUDE_DIRS} ${GTHREAD_INCLUDE_DIRS} ${PANGO_INCLUDE_DIRS})
++LINK_DIRECTORIES(${X11_LIBRARY_DIRS} ${CAIRO_LIBRARY_DIRS}
++ ${GLIB_LIBRARY_DIRS} ${GTHREAD_LIBRARY_DIRS} ${PANGO_LIBRARY_DIRS})
+
+ ADD_EXECUTABLE(${BMPANEL_EXECUTABLE_NAME} ${SOURCES})
+-TARGET_LINK_LIBRARIES(${BMPANEL_EXECUTABLE_NAME} ${X11_LIBRARIES}
++TARGET_LINK_LIBRARIES(${BMPANEL_EXECUTABLE_NAME} -lm ${X11_LIBRARIES}
+ ${CAIRO_LIBRARIES} ${GLIB_LIBRARIES} ${GTHREAD_LIBRARIES} ${PANGO_LIBRARIES})
+
+ # OPTIONS