aboutsummaryrefslogtreecommitdiff
path: root/x11/compositeext
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2003-12-27 01:32:08 +0000
committerEric Anholt <anholt@FreeBSD.org>2003-12-27 01:32:08 +0000
commit81521106a38c1c1e5f75a75ea8a61f379e25bec8 (patch)
tree4854d4a0d29f84506863e487c9aac057b466441d /x11/compositeext
parent7ee04b912d2979b037aa095a618437d78babfe3d (diff)
downloadports-81521106a38c1c1e5f75a75ea8a61f379e25bec8.tar.gz
ports-81521106a38c1c1e5f75a75ea8a61f379e25bec8.zip
New port: Prerelease version of compositeext from freedesktop.org:
X Composite extension headers and specification Testing is encouraged, but please do not use these ports as dependencies until they are updated to release tarballs and the XFree86 ports have been updated to depend on them.
Notes
Notes: svn path=/head/; revision=96663
Diffstat (limited to 'x11/compositeext')
-rw-r--r--x11/compositeext/Makefile29
-rw-r--r--x11/compositeext/distinfo1
-rw-r--r--x11/compositeext/files/patch-Makefile.in11
-rw-r--r--x11/compositeext/pkg-descr6
-rw-r--r--x11/compositeext/pkg-plist5
5 files changed, 52 insertions, 0 deletions
diff --git a/x11/compositeext/Makefile b/x11/compositeext/Makefile
new file mode 100644
index 000000000000..677e27f60ba0
--- /dev/null
+++ b/x11/compositeext/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: compositeext
+# Date Created: 13 Nov, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= compositeext
+PORTVERSION= 2.0.p1
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X Composite extension headers and specification
+
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/fixesext.pc:${PORTSDIR}/x11/fixesext
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${LIB_PC_DEPENDS}
+RUN_DEPENDS= ${LIB_PC_DEPENDS}
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GMAKE= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-2.0
+
+.include <bsd.port.mk>
diff --git a/x11/compositeext/distinfo b/x11/compositeext/distinfo
new file mode 100644
index 000000000000..16a2d1e995d4
--- /dev/null
+++ b/x11/compositeext/distinfo
@@ -0,0 +1 @@
+MD5 (compositeext-2.0.p1.tar.bz2) = 2cb608e6d69c190bdf1d74f8f6eae060
diff --git a/x11/compositeext/files/patch-Makefile.in b/x11/compositeext/files/patch-Makefile.in
new file mode 100644
index 000000000000..7794322a5cdc
--- /dev/null
+++ b/x11/compositeext/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Thu Nov 13 13:47:39 2003
++++ Makefile.in Thu Nov 13 13:54:09 2003
+@@ -126,7 +126,7 @@
+ compositeextdocdir = $(datadir)/doc/compositeext
+ compositeextdoc_DATA = protocol
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = compositeext.pc
+
+ EXTRA_DIST = autogen.sh compositeext.pc.in $(compositeextdoc_DATA)
diff --git a/x11/compositeext/pkg-descr b/x11/compositeext/pkg-descr
new file mode 100644
index 000000000000..0aaa986a39ad
--- /dev/null
+++ b/x11/compositeext/pkg-descr
@@ -0,0 +1,6 @@
+This package contains the X Composite extension headers and specification
+
+WWW: http://www.freedesktop.org/Software/xlibs
+
+- Eric Anholt
+anholt@FreeBSD.org
diff --git a/x11/compositeext/pkg-plist b/x11/compositeext/pkg-plist
new file mode 100644
index 000000000000..fc03b10ee214
--- /dev/null
+++ b/x11/compositeext/pkg-plist
@@ -0,0 +1,5 @@
+include/X11/extensions/composite.h
+include/X11/extensions/compositeproto.h
+libdata/pkgconfig/compositeext.pc
+%%DOCSDIR%%/protocol
+@dirrm %%DOCSDIR%%