aboutsummaryrefslogtreecommitdiff
path: root/x11/electricsheep
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2002-03-24 19:28:48 +0000
committerAnders Nordby <anders@FreeBSD.org>2002-03-24 19:28:48 +0000
commit5fd4ae2e00e1840d568aabc7e0c11b3e1503eb6f (patch)
treeebf0f6bc10cf42a416a9bb29b0dbb5d9384f3782 /x11/electricsheep
parent64491432c4332e117122ed549c6469a285239519 (diff)
downloadports-5fd4ae2e00e1840d568aabc7e0c11b3e1503eb6f.tar.gz
ports-5fd4ae2e00e1840d568aabc7e0c11b3e1503eb6f.zip
Say hello to the Electric Sheep distributed screensaver.
PR: 35553 Submitted by: David Yeske <dyeske@yahoo.com>
Notes
Notes: svn path=/head/; revision=56554
Diffstat (limited to 'x11/electricsheep')
-rw-r--r--x11/electricsheep/Makefile40
-rw-r--r--x11/electricsheep/distinfo1
-rw-r--r--x11/electricsheep/files/patch-electricsheep.c12
-rw-r--r--x11/electricsheep/pkg-comment1
-rw-r--r--x11/electricsheep/pkg-descr11
-rw-r--r--x11/electricsheep/pkg-plist9
6 files changed, 74 insertions, 0 deletions
diff --git a/x11/electricsheep/Makefile b/x11/electricsheep/Makefile
new file mode 100644
index 000000000000..b6f749042652
--- /dev/null
+++ b/x11/electricsheep/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: electricsheep
+# Date created: 11 Feb 2002
+# Whom: David Yeske <dyeske@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= electricsheep
+PORTVERSION= 2.1
+CATEGORIES= x11
+MASTER_SITES= http://www-2.cs.cmu.edu/~spot/cache/
+
+MAINTAINER= dyeske@yahoo.com
+
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
+RUN_DEPENDS= xloadimage:${PORTSDIR}/x11/xloadimage \
+ xsetbg:${PORTSDIR}/graphics/xli \
+ curl:${PORTSDIR}/ftp/curl
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+
+pre-patch:
+ @${PERL} -pi -e 's|/usr/include/X11|${X11BASE}/include|g; \
+ s|/usr/lib/libjpeg.so.62|${LOCALBASE}/lib/libjpeg.so|g;' \
+ ${WRKSRC}/video_out/Makefile
+
+post-patch:
+ @${PERL} -pi -e 's|/usr/local/share|${PREFIX}/share/electricsheep|g;' \
+ ${WRKSRC}/electricsheep.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/electricsheep ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/flame/anim-flame ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/flame/pick-flame ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/video_out/mpeg_play ${PREFIX}/bin/mpeg-loop
+ ${INSTALL} -d -m 0755 ${PREFIX}/share/electricsheep
+ ${INSTALL_DATA} ${WRKSRC}/*.tif ${PREFIX}/share/electricsheep
+
+.include <bsd.port.mk>
diff --git a/x11/electricsheep/distinfo b/x11/electricsheep/distinfo
new file mode 100644
index 000000000000..8c3d77835ac2
--- /dev/null
+++ b/x11/electricsheep/distinfo
@@ -0,0 +1 @@
+MD5 (electricsheep-2.1.tar.gz) = c63c7584df6a885638d05e326daab7df
diff --git a/x11/electricsheep/files/patch-electricsheep.c b/x11/electricsheep/files/patch-electricsheep.c
new file mode 100644
index 000000000000..e4f21a9b0085
--- /dev/null
+++ b/x11/electricsheep/files/patch-electricsheep.c
@@ -0,0 +1,12 @@
+$FreeBSD$
+--- electricsheep.c.orig Tue Jul 3 14:55:00 2001
++++ electricsheep.c Tue Feb 12 12:58:42 2002
+@@ -1223,7 +1223,7 @@
+
+ /* create our own group so all workers/children may be killed together
+ without hassle */
+- if (-1 == setpgrp())
++ if (-1 == setpgrp(getpid(), getpid()))
+ perror("setpgrp");
+ signal(SIGTERM, handle_sig_term);
+ signal(SIGINT, handle_sig_term);
diff --git a/x11/electricsheep/pkg-comment b/x11/electricsheep/pkg-comment
new file mode 100644
index 000000000000..e50d8687efde
--- /dev/null
+++ b/x11/electricsheep/pkg-comment
@@ -0,0 +1 @@
+A nice distributed screensaver
diff --git a/x11/electricsheep/pkg-descr b/x11/electricsheep/pkg-descr
new file mode 100644
index 000000000000..89e8e7e71efd
--- /dev/null
+++ b/x11/electricsheep/pkg-descr
@@ -0,0 +1,11 @@
+Electricsheep is a distributed screensaver. It realizes the
+collective dream of sleeping computers from all over the internet.
+When the screen-saver is activated, the screen goes black and an
+animated 'sheep' appears. Behind the scenes, the screen-saver
+contacts an internet server and joins the parallel computation of
+new sheep.
+
+WWW: http://www.electricsheep.org/
+
+- David
+dyeske@yahoo.com
diff --git a/x11/electricsheep/pkg-plist b/x11/electricsheep/pkg-plist
new file mode 100644
index 000000000000..f9e986a17056
--- /dev/null
+++ b/x11/electricsheep/pkg-plist
@@ -0,0 +1,9 @@
+bin/electricsheep
+bin/anim-flame
+bin/pick-flame
+bin/mpeg-loop
+share/electricsheep/electricsheep-frown.tif
+share/electricsheep/electricsheep-smile.tif
+share/electricsheep/electricsheep-splash-0.tif
+share/electricsheep/electricsheep-splash-1.tif
+@dirrm share/electricsheep