aboutsummaryrefslogtreecommitdiff
path: root/x11/fireflies
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /x11/fireflies
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'x11/fireflies')
-rw-r--r--x11/fireflies/Makefile4
-rw-r--r--x11/fireflies/files/patch-Make.include.in4
2 files changed, 4 insertions, 4 deletions
diff --git a/x11/fireflies/Makefile b/x11/fireflies/Makefile
index 0245b8b79ace..9603aefa77eb 100644
--- a/x11/fireflies/Makefile
+++ b/x11/fireflies/Makefile
@@ -18,8 +18,8 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GL= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include/GL" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/GL" \
+ LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-bindir=${LOCALBASE}/bin/xscreensaver-hacks \
--with-confdir=${LOCALBASE}/share/xscreensaver/config
PLIST_SUB= VERSION=${PORTVERSION}
diff --git a/x11/fireflies/files/patch-Make.include.in b/x11/fireflies/files/patch-Make.include.in
index 9369f93aefad..059278411157 100644
--- a/x11/fireflies/files/patch-Make.include.in
+++ b/x11/fireflies/files/patch-Make.include.in
@@ -6,8 +6,8 @@
-CFLAGS = -Wall -I../libgfx/include/ $(SDL_CFLAGS) @CFLAGS@
-LIBS = ../libgfx/src/libgfx.a $(GL_LIBS) $(SDL_LIBS) $(OPT_LIBS) @LIBS@
-+CFLAGS = -Wall -I$(X11BASE)/include -I../libgfx/include/ $(SDL_CFLAGS) @CFLAGS@
-+LIBS = ../libgfx/src/libgfx.a $(SDL_LIBS) $(OPT_LIBS) -L$(X11BASE)/lib $(GL_LIBS) @LIBS@
++CFLAGS = -Wall -I$(LOCALBASE)/include -I../libgfx/include/ $(SDL_CFLAGS) @CFLAGS@
++LIBS = ../libgfx/src/libgfx.a $(SDL_LIBS) $(OPT_LIBS) -L$(LOCALBASE)/lib $(GL_LIBS) @LIBS@
OBJECTS = arrow.o bait.o firefly.o scene.o tail.o utils.o modes.o @OPT_OBJS@
PROGRAM = @PROGRAM@