aboutsummaryrefslogtreecommitdiff
path: root/x11/fixesext/Makefile
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2003-12-22 00:30:35 +0000
committerEric Anholt <anholt@FreeBSD.org>2003-12-22 00:30:35 +0000
commit2005bec2e389eae4f370be9be6c7c92b0caa3f1c (patch)
treeecafedc7d90afd94c423abcfc02443e8f71ec31c /x11/fixesext/Makefile
parent72887b1ed1e6d1ef0642acff5415998eb51092b3 (diff)
downloadports-2005bec2e389eae4f370be9be6c7c92b0caa3f1c.tar.gz
ports-2005bec2e389eae4f370be9be6c7c92b0caa3f1c.zip
New port: Prerelease version of fixesext from freedesktop.org:
X Fixes extension headers and specification Testing is encouraged, but please do not use these ports as dependencies until they are updated to release tarballs and the XFree86 ports have been updated to depend on them.
Notes
Notes: svn path=/head/; revision=96384
Diffstat (limited to 'x11/fixesext/Makefile')
-rw-r--r--x11/fixesext/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11/fixesext/Makefile b/x11/fixesext/Makefile
new file mode 100644
index 000000000000..354b5437840d
--- /dev/null
+++ b/x11/fixesext/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: fixesext
+# Date Created: 29 Oct, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fixesext
+PORTVERSION= 2.0.p2
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X Fixes extension headers and specification
+
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/xextensions.pc:${PORTSDIR}/x11/xextensions
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${LIB_PC_DEPENDS}
+RUN_DEPENDS= ${LIB_PC_DEPENDS}
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GMAKE= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-2.0
+
+.include <bsd.port.mk>