aboutsummaryrefslogtreecommitdiff
path: root/x11/gdm/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-01-19 22:50:09 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-01-19 22:50:09 +0000
commit3b85e78755e0223254e72db7af815416900c7d2a (patch)
treea76d4c843c9b9c1591b38a72828024a30b689476 /x11/gdm/Makefile
parentaaae4362859dec839afd38ea463a3868bfbec679 (diff)
downloadports-3b85e78755e0223254e72db7af815416900c7d2a.tar.gz
ports-3b85e78755e0223254e72db7af815416900c7d2a.zip
Correct last commit. PKG_PREFIX is only set by pkg_add, thus when building the
port, the variable does not exist. Spotted by: Mark Hannon <markhannon@optusnet.com.au>
Notes
Notes: svn path=/head/; revision=73568
Diffstat (limited to 'x11/gdm/Makefile')
-rw-r--r--x11/gdm/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/x11/gdm/Makefile b/x11/gdm/Makefile
index c5e9a26f38c7..9f18d67aa8fc 100644
--- a/x11/gdm/Makefile
+++ b/x11/gdm/Makefile
@@ -52,6 +52,12 @@ post-install:
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.endif
+.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
+ @${CHOWN} -R gdm:gdm ${PREFIX}/share/gnome/gdm ${PREFIX}/etc/gdm
+.else
+ @${CHOWN} -R 92:92 ${PREFIX}/share/gnome/gdm ${PREFIX}/etc/gdm
+.endif
+ @${CHMOD} 0750 ${PREFIX}/share/gnome/gdm
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>