aboutsummaryrefslogtreecommitdiff
path: root/x11/gpctool
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /x11/gpctool
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'x11/gpctool')
-rw-r--r--x11/gpctool/Makefile2
-rw-r--r--x11/gpctool/files/BSDmakefile4
2 files changed, 3 insertions, 3 deletions
diff --git a/x11/gpctool/Makefile b/x11/gpctool/Makefile
index b1c01a737229..408d644605f9 100644
--- a/x11/gpctool/Makefile
+++ b/x11/gpctool/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= gpc:${PORTSDIR}/devel/libgpc \
USE_ZIP= yes
USE_GL= yes
PLIST_FILES= bin/gpctool
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
NO_CDROM= Can't be used for profit without permission
MAKEFILE= ${FILESDIR}/BSDmakefile
diff --git a/x11/gpctool/files/BSDmakefile b/x11/gpctool/files/BSDmakefile
index 42365dfae84f..957862277916 100644
--- a/x11/gpctool/files/BSDmakefile
+++ b/x11/gpctool/files/BSDmakefile
@@ -6,9 +6,9 @@ SRCS= gpctool.c main.c callbacks.c graphics.c psdump.c
BINDIR= ${PREFIX}/bin
WARNS?= 2
-CFLAGS+= -I${X11BASE}/include/X11 -I${X11BASE}/include
+CFLAGS+= -I${LOCALBASE}/include/X11 -I${LOCALBASE}/include
CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${X11BASE}/lib -lformsGL -lGLU
+LDFLAGS+= -L${LOCALBASE}/lib -lformsGL -lGLU
LDFLAGS+= -L${LOCALBASE}/lib -lgpc -lm
.include <bsd.prog.mk>