aboutsummaryrefslogtreecommitdiff
path: root/x11/gswitchit_applet/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-07-28 15:42:31 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-07-28 15:42:31 +0000
commit11e0dec2b5128a6dc6e4da3597b488f13e1ab49b (patch)
treeb920926d6a3392a29e09cb2f33ee92fe3b54c2bf /x11/gswitchit_applet/Makefile
parent4634742f54118dd1f27b1ed1ec8cd540c90e0d88 (diff)
downloadports-11e0dec2b5128a6dc6e4da3597b488f13e1ab49b.tar.gz
ports-11e0dec2b5128a6dc6e4da3597b488f13e1ab49b.zip
Add gswitchit_applet - a keyboard layout state indicator and switcher for
Gnome Desktop. Obtained from: http://www.gnome.org/
Notes
Notes: svn path=/head/; revision=31085
Diffstat (limited to 'x11/gswitchit_applet/Makefile')
-rw-r--r--x11/gswitchit_applet/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11/gswitchit_applet/Makefile b/x11/gswitchit_applet/Makefile
new file mode 100644
index 000000000000..112b0620b41a
--- /dev/null
+++ b/x11/gswitchit_applet/Makefile
@@ -0,0 +1,37 @@
+# Ports collection Makefile for: gswitchit_applet
+# Date created: 5 June 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gswitchit_applet
+PORTVERSION= 0.61
+CATEGORIES= x11 gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gswitchit
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= panel_applet.4:${PORTSDIR}/x11/gnomecore \
+ gnome.4:${PORTSDIR}/x11/gnomelibs \
+ gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+RUN_DEPENDS= gnomecc:${PORTSDIR}/sysutils/gnomecontrolcenter
+
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= gswitchit_applet.1
+
+post-extract:
+ @${PERL} -pi -e 's|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>