aboutsummaryrefslogtreecommitdiff
path: root/x11/i3lock
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-15 07:45:34 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-15 07:45:34 +0000
commitb7857287b0c8718b586487821992138acd991910 (patch)
treef0b1f8a600f938eae08ab8995e70c099b69b2929 /x11/i3lock
parent4763a75e8d6d1994557cbb7b117a81e85e1fe60f (diff)
downloadports-b7857287b0c8718b586487821992138acd991910.tar.gz
ports-b7857287b0c8718b586487821992138acd991910.zip
x11/i3lock: Fix staging orphan, assign port to submitter
Details: * Change license from BSD to BSD3CLAUSE * Use @mode instead of CHMOD * Add DOCS to options * strip executable * Move patch actions to Makefile * Fix WWW * Fix orphaned etc/pam.3/i3lock * Fix LIB_DEPENDS format * Pass maintainership to Horia PR: 190992 Submitted by: Horia Racoviceanu Approved by: maintainer timeout (2 months)
Notes
Notes: svn path=/head/; revision=364946
Diffstat (limited to 'x11/i3lock')
-rw-r--r--x11/i3lock/Makefile27
-rw-r--r--x11/i3lock/files/patch-Makefile15
-rw-r--r--x11/i3lock/pkg-descr2
3 files changed, 21 insertions, 23 deletions
diff --git a/x11/i3lock/Makefile b/x11/i3lock/Makefile
index a051cb2866cf..c76f4df2fc95 100644
--- a/x11/i3lock/Makefile
+++ b/x11/i3lock/Makefile
@@ -3,19 +3,19 @@
PORTNAME= i3lock
PORTVERSION= 2.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= http://i3wm.org/${PORTNAME}/
-MAINTAINER= dhn@FreeBSD.org
+MAINTAINER= horia@racoviceanu.com
COMMENT= Slightly improved screen locker based on slock
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
-LIB_DEPENDS= libcairo.so.2:${PORTSDIR}/graphics/cairo \
+LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
libxcb-keysyms.so:${PORTSDIR}/x11/xcb-util-keysyms \
libxcb-image.so:${PORTSDIR}/x11/xcb-util-image \
- libev.so.4:${PORTSDIR}/devel/libev \
+ libev.so:${PORTSDIR}/devel/libev \
libxkbfile.so:${PORTSDIR}/x11/libxkbfile \
libxkbcommon.so:${PORTSDIR}/x11/libxkbcommon
@@ -23,14 +23,27 @@ MAKE_ARGS= PREFIX="${PREFIX}" X11LIB="${LOCALBASE}/lib" \
X11INC="${LOCALBASE}/include" CC="${CC}" \
MANDIR="${MANPREFIX}/man"
-PLIST_FILES= bin/i3lock \
+PLIST_FILES= "@mode 4755" bin/i3lock @mode \
man/man1/i3lock.1.gz
LDFLAGS+= ${ICONV_LIB}
USE_XORG= x11 xcb xt xproto xext
USES= gmake iconv pkgconfig tar:bzip2
+PORTDOCS= CHANGELOG README
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|.*pam.d/i3lock.*| $$(INSTALL)\
+ -m 644 i3lock.1 $$(DESTDIR)$$(PREFIX)/man/man1|; \
+ /pam.d/d' \
+ ${WRKSRC}/Makefile
+
post-install:
- ${CHMOD} u+s ${STAGEDIR}${PREFIX}/bin/i3lock
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/i3lock
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/x11/i3lock/files/patch-Makefile b/x11/i3lock/files/patch-Makefile
deleted file mode 100644
index 3115173e2034..000000000000
--- a/x11/i3lock/files/patch-Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
---- ./Makefile.orig 2012-04-01 13:14:28.000000000 +0200
-+++ ./Makefile 2012-04-08 13:39:09.000000000 +0200
-@@ -42,9 +42,10 @@
-
- install: all
- $(INSTALL) -d $(DESTDIR)$(PREFIX)/bin
-- $(INSTALL) -d $(DESTDIR)$(SYSCONFDIR)/pam.d
-+ $(INSTALL) -d $(DESTDIR)$(PREFIX)$(SYSCONFDIR)/pam.d
- $(INSTALL) -m 755 i3lock $(DESTDIR)$(PREFIX)/bin/i3lock
-- $(INSTALL) -m 644 i3lock.pam $(DESTDIR)$(SYSCONFDIR)/pam.d/i3lock
-+ $(INSTALL) -m 644 i3lock.pam $(DESTDIR)$(PREFIX)$(SYSCONFDIR)/pam.d/i3lock
-+ $(INSTALL) -m 644 i3lock.1 $(DESTDIR)$(PREFIX)/man/man1
-
- uninstall:
- rm -f $(DESTDIR)$(PREFIX)/bin/i3lock
diff --git a/x11/i3lock/pkg-descr b/x11/i3lock/pkg-descr
index 3edf0583aa69..a6071b436d45 100644
--- a/x11/i3lock/pkg-descr
+++ b/x11/i3lock/pkg-descr
@@ -8,4 +8,4 @@ you have entered a password when resuming from suspend, at least sometimes.
i3lock was forked from slock-0.9
-WWW: http://i3.zekjur.net/i3lock/
+WWW: http://i3wm.org/i3lock/