aboutsummaryrefslogtreecommitdiff
path: root/x11/kde4-runtime/files
diff options
context:
space:
mode:
authorAlan Eldridge <alane@FreeBSD.org>2002-10-11 00:00:00 +0000
committerAlan Eldridge <alane@FreeBSD.org>2002-10-11 00:00:00 +0000
commit53fa9783e9a36e1385b109375a5f5d255cd0c090 (patch)
tree866f45a209c6a99782830f7c0f2666f48d150f19 /x11/kde4-runtime/files
parent69a4c09708c54e4569a468304d051a3c19368317 (diff)
downloadports-53fa9783e9a36e1385b109375a5f5d255cd0c090.tar.gz
ports-53fa9783e9a36e1385b109375a5f5d255cd0c090.zip
1. Remove QT warning from kde3. It's been there long enough.
2. This is 3.0.4, folks. 3. Added extra patch files for backport of keramik.
Notes
Notes: svn path=/head/; revision=67789
Diffstat (limited to 'x11/kde4-runtime/files')
-rw-r--r--x11/kde4-runtime/files/keramik-patch-kwin-Makefile.am20
-rw-r--r--x11/kde4-runtime/files/keramik-patch-kwin-client.h27
-rw-r--r--x11/kde4-runtime/files/keramik-patch-kwin-clients-Makefile.am6
3 files changed, 53 insertions, 0 deletions
diff --git a/x11/kde4-runtime/files/keramik-patch-kwin-Makefile.am b/x11/kde4-runtime/files/keramik-patch-kwin-Makefile.am
new file mode 100644
index 000000000000..7a14cf7edc7c
--- /dev/null
+++ b/x11/kde4-runtime/files/keramik-patch-kwin-Makefile.am
@@ -0,0 +1,20 @@
+--- kwin/Makefile.am.orig Fri Mar 8 15:49:39 2002
++++ kwin/Makefile.am Sun Oct 6 16:33:31 2002
+@@ -8,14 +8,15 @@
+ # workspace.cpp has to be first in order not to break --enable-final
+ kwin_la_SOURCES = workspace.cpp atoms.cpp client.cpp main.cpp \
+ tabbox.cpp options.cpp plugins.cpp events.cpp KWinInterface.skel \
+- killwindow.cpp kwinbutton.cpp
++ killwindow.cpp kwinbutton.cpp placement.cpp popupinfo.cpp
+ kwin_la_LIBADD = $(LIB_KDEUI) $(LIBXINERAMA)
+ kwin_la_LDFLAGS = $(all_libraries) -module -avoid-version
+
+ include_HEADERS = KWinInterface.h
+
+ kwinincludedir = $(includedir)/kwin
+-kwininclude_HEADERS = options.h client.h workspace.h kwinbutton.h
++kwininclude_HEADERS = options.h client.h workspace.h kwinbutton.h \
++ placement.h popupinfo.h
+
+ kwin_SOURCES = kwin_main.cpp
+ kwin_LDADD = kwin.la
diff --git a/x11/kde4-runtime/files/keramik-patch-kwin-client.h b/x11/kde4-runtime/files/keramik-patch-kwin-client.h
new file mode 100644
index 000000000000..bf09b2f0355a
--- /dev/null
+++ b/x11/kde4-runtime/files/keramik-patch-kwin-client.h
@@ -0,0 +1,27 @@
+--- kwin/client.h.orig Sun Oct 6 16:00:30 2002
++++ kwin/client.h Sun Oct 6 14:49:21 2002
+@@ -161,6 +161,7 @@
+ bool isTool() const; // KDE4 remove me
+ bool isToolbar() const;
+ bool isTopMenu() const;
++ bool isMenu() const; // compat. for KDE 3.0.x <alane@freebsd.org>
+ bool isNormalWindow() const; // normal as in 'NET::Normal or NET::Unknown non-transient'
+ bool isDialog() const;
+
+@@ -505,6 +506,16 @@
+ {
+ return cmap;
+ }
++
++/*
++ compat. for 3.0.x <alane@freebsd.org>
++*/
++
++inline bool Client::isMenu() const
++{
++ return isTopMenu();
++}
++
+
+ class NoBorderClient : public Client
+ {
diff --git a/x11/kde4-runtime/files/keramik-patch-kwin-clients-Makefile.am b/x11/kde4-runtime/files/keramik-patch-kwin-clients-Makefile.am
new file mode 100644
index 000000000000..d63afd653f14
--- /dev/null
+++ b/x11/kde4-runtime/files/keramik-patch-kwin-clients-Makefile.am
@@ -0,0 +1,6 @@
+--- kwin/clients/Makefile.am.orig Sat Jan 26 11:06:53 2002
++++ kwin/clients/Makefile.am Mon Oct 7 03:51:41 2002
+@@ -1,2 +1,2 @@
+ SUBDIRS = default kde1 riscos redmond quartz icewm web b2 \
+- modernsystem laptop system kwmtheme kstep
++ modernsystem laptop system kwmtheme kstep keramik