aboutsummaryrefslogtreecommitdiff
path: root/x11/kde4-workspace/files/patch-CMakeLists.txt
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-09-02 21:06:27 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-09-02 21:06:27 +0000
commit08351f8e016396e46d654e72eceb6a2ed81aadbb (patch)
treed97f07c03bb7f9977c1021629266214a9d2310e6 /x11/kde4-workspace/files/patch-CMakeLists.txt
parent0b3b58a79f748bf25f2a89f19316de184c390fa6 (diff)
downloadports-08351f8e016396e46d654e72eceb6a2ed81aadbb.tar.gz
ports-08351f8e016396e46d654e72eceb6a2ed81aadbb.zip
KDE FreeBSD team presents KDE SC 4.5.1.
New ports added: misc/kde4-l10n-ia - Interlingua localization for KDE
Notes
Notes: svn path=/head/; revision=260443
Diffstat (limited to 'x11/kde4-workspace/files/patch-CMakeLists.txt')
-rw-r--r--x11/kde4-workspace/files/patch-CMakeLists.txt15
1 files changed, 12 insertions, 3 deletions
diff --git a/x11/kde4-workspace/files/patch-CMakeLists.txt b/x11/kde4-workspace/files/patch-CMakeLists.txt
index b0a9a4744f7e..69647cafd4f2 100644
--- a/x11/kde4-workspace/files/patch-CMakeLists.txt
+++ b/x11/kde4-workspace/files/patch-CMakeLists.txt
@@ -1,6 +1,15 @@
---- ./CMakeLists.txt.orig 2009-01-01 19:26:09.000000000 +0300
-+++ ./CMakeLists.txt 2009-03-07 10:02:36.000000000 +0300
-@@ -220,7 +220,7 @@
+--- ./CMakeLists.txt.orig 2010-07-29 01:04:56.000000000 +0400
++++ ./CMakeLists.txt 2010-08-03 14:45:37.785806201 +0400
+@@ -79,7 +79,7 @@
+ configure_file(config-unix.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-unix.h )
+ configure_file(config-X11.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-X11.h )
+ if(NOT CMAKE_INSTALL_PREFIX STREQUAL "/usr")
+- set(EXPORT_XCURSOR_PATH "XCURSOR_PATH=${CMAKE_INSTALL_PREFIX}/share/icons:$XCURSOR_PATH\":~/.icons:/usr/share/icons:/usr/share/pixmaps:/usr/X11R6/lib/X11/icons\"; export XCURSOR_PATH")
++ set(EXPORT_XCURSOR_PATH "XCURSOR_PATH=${CMAKE_INSTALL_PREFIX}/share/icons:$XCURSOR_PATH\":~/.icons:/usr/local/share/icons:/usr/local/share/pixmaps:/usr/local/lib/X11/icons\"; export XCURSOR_PATH")
+ endif(NOT CMAKE_INSTALL_PREFIX STREQUAL "/usr")
+ configure_file(startkde.cmake ${CMAKE_CURRENT_BINARY_DIR}/startkde @ONLY)
+ endif(NOT WIN32)
+@@ -231,7 +231,7 @@
macro_write_basic_cmake_version_file(${CMAKE_CURRENT_BINARY_DIR}/KDE4WorkspaceConfigVersion.cmake
${KDE4WORKSPACE_VERSION_MAJOR} ${KDE4WORKSPACE_VERSION_MINOR} ${KDE4WORKSPACE_VERSION_PATCH})