aboutsummaryrefslogtreecommitdiff
path: root/x11/kde4-workspace
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2010-06-25 07:33:50 +0000
committerAlberto Villa <avilla@FreeBSD.org>2010-06-25 07:33:50 +0000
commit771b26eadb12af350175949c3cf7dc40954aac23 (patch)
treeb647506bf1b54f622ea36f27c1a9ed5341931053 /x11/kde4-workspace
parent8939b67c98771c83d72c6b403a6a40a851075bad (diff)
downloadports-771b26eadb12af350175949c3cf7dc40954aac23.tar.gz
ports-771b26eadb12af350175949c3cf7dc40954aac23.zip
- Fix instantiation of ConsoleKit session in KDM. [1]
- Enable Solid HAL plugin. [2] - Remove stale patch. - Bump PORTREVISION. [1] procfs(5) is required. [2] Even if buttons like "Sleep" and "Hibernate" will show up in PowerDevil, FreeBSD support on those doesn't change: sleeping is still unsupported on i386, and hibernation is not implemented anywhere. Approved by: tabthorpe (mentor), erwin (portmgr) Obtained from: http://websvn.kde.org/?view=revision&revision=1133877 [2] Feature safe: yes
Notes
Notes: svn path=/head/; revision=256942
Diffstat (limited to 'x11/kde4-workspace')
-rw-r--r--x11/kde4-workspace/Makefile2
-rw-r--r--x11/kde4-workspace/files/patch-kdm-config.def13
-rw-r--r--x11/kde4-workspace/files/patch-kdm__backend__client.c26
-rw-r--r--x11/kde4-workspace/files/patch-solid__CMakeLists.txt12
-rw-r--r--x11/kde4-workspace/pkg-plist2
5 files changed, 42 insertions, 13 deletions
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index d9a56d2728e1..ee025cbee3fe 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdebase-workspace
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
@@ -88,6 +89,7 @@ post-patch:
${PATCH_WRKSRC}/kcontrol/kfontinst/lib/KfiConstants.h \
${PATCH_WRKSRC}/kcontrol/kfontinst/kio/KioFonts.cpp \
${PATCH_WRKSRC}/kcontrol/kxkb/x11helper.cpp \
+ ${PATCH_WRKSRC}/kdm/backend/client.c \
${PATCH_WRKSRC}/kdm/kfrontend/genkdmconf.c
${CP} ${FILESDIR}/uptime.* ${WRKSRC}/ksysguard/ksysguardd/FreeBSD/
diff --git a/x11/kde4-workspace/files/patch-kdm-config.def b/x11/kde4-workspace/files/patch-kdm-config.def
deleted file mode 100644
index 5eabd14494f3..000000000000
--- a/x11/kde4-workspace/files/patch-kdm-config.def
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -ur kdm~/config.def kdm/config.def
---- ./kdm/config.def.orig 2009-11-17 12:53:01.000000000 +0200
-+++ ./kdm/config.def 2009-11-17 12:55:35.000000000 +0200
-@@ -32,6 +32,9 @@
- #define KDMCONF KDE_CONFDIR "/kdm"
- #define KDMDATA KDE_DATADIR "/kdm"
-
-+#include <sys/param.h> /* This is required for BSD define (how else will we
-+ known it exists?). */
-+
- #ifdef _AIX
- # define HALT_CMD "/usr/sbin/shutdown -h now"
- # define REBOOT_CMD "/usr/sbin/shutdown -r now"
diff --git a/x11/kde4-workspace/files/patch-kdm__backend__client.c b/x11/kde4-workspace/files/patch-kdm__backend__client.c
new file mode 100644
index 000000000000..fe71ad1286a9
--- /dev/null
+++ b/x11/kde4-workspace/files/patch-kdm__backend__client.c
@@ -0,0 +1,26 @@
+--- kdm/backend/client.c.orig 2010-03-26 18:26:49.000000000 +0100
++++ kdm/backend/client.c 2010-06-16 00:28:31.056683006 +0200
+@@ -1271,6 +1271,9 @@
+ char ckDeviceBuf[20] = "";
+ const char *ckDevice = ckDeviceBuf;
+ dbus_bool_t isLocal;
++# ifdef BSD
++ FILE *proc;
++# endif
+ #endif
+ char *failsafeArgv[2];
+ char *buf, *buf2;
+@@ -1302,6 +1305,13 @@
+ # ifdef HAVE_VTS
+ if (td->serverVT > 0)
+ sprintf( ckDeviceBuf, "/dev/tty%d", td->serverVT );
++# elif defined(BSD)
++ if ((proc = popen( "/usr/local/libexec/ck-get-x11-display-device", "r" ))) {
++ fscanf( proc, "%s", ckDeviceBuf );
++ pclose( proc );
++ if (strcmp( ckDeviceBuf, "usage" ) == 0 || strcmp( ckDeviceBuf, "ERROR:" ) == 0)
++ ckDeviceBuf[0] = '\0';
++ }
+ # endif
+ isLocal = ((td->displayType & d_location) == dLocal);
+ # ifdef XDMCP
diff --git a/x11/kde4-workspace/files/patch-solid__CMakeLists.txt b/x11/kde4-workspace/files/patch-solid__CMakeLists.txt
new file mode 100644
index 000000000000..a4f39228f738
--- /dev/null
+++ b/x11/kde4-workspace/files/patch-solid__CMakeLists.txt
@@ -0,0 +1,12 @@
+--- solid/CMakeLists.txt.orig 2010-06-16 09:49:31.723645684 +0200
++++ solid/CMakeLists.txt 2010-06-16 09:49:41.468153690 +0200
+@@ -7,8 +7,8 @@
+ add_subdirectory(kcm)
+ add_subdirectory(solid-actions-kcm)
+
++add_subdirectory(hal)
+ IF("${CMAKE_SYSTEM}" MATCHES "Linux")
+- add_subdirectory(hal)
+ add_subdirectory(networking)
+ add_subdirectory(solidshell)
+ ENDIF("${CMAKE_SYSTEM}" MATCHES "Linux")
diff --git a/x11/kde4-workspace/pkg-plist b/x11/kde4-workspace/pkg-plist
index 4de869873e21..512b482606a4 100644
--- a/x11/kde4-workspace/pkg-plist
+++ b/x11/kde4-workspace/pkg-plist
@@ -340,6 +340,7 @@ lib/kde4/plugins/designer/ksysguardlsofwidgets.so
lib/kde4/plugins/designer/ksysguardwidgets.so
lib/kde4/plugins/gui_platform/libkde.so
lib/kde4/solid_fakenet.so
+lib/kde4/solid_hal_power.so
lib/kde4/solid_lirc.so
lib/kde4/solid_wicd.so
lib/libkdecorations.so
@@ -1996,6 +1997,7 @@ share/kde4/services/settings-system.desktop
share/kde4/services/settings-window-behaviour.desktop
share/kde4/services/solid-actions.desktop
share/kde4/services/solidbackends/solid_fakenet.desktop
+share/kde4/services/solidbackends/solid_hal_power.desktop
share/kde4/services/solidbackends/solid_lirc.desktop
share/kde4/services/solidbackends/solid_wicd.desktop
share/kde4/services/standard_actions.desktop