aboutsummaryrefslogtreecommitdiff
path: root/x11/kdebase4/Makefile
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-05-02 13:10:50 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-05-02 13:10:50 +0000
commit77c311d02274b6818e29306c83a3b533b6df01c5 (patch)
treeb349b24e2599f939d35f56986ec9093944aa5fc6 /x11/kdebase4/Makefile
parent7c6072f8a91e7353f58bcd7d564595c6f0578a25 (diff)
downloadports-77c311d02274b6818e29306c83a3b533b6df01c5.tar.gz
ports-77c311d02274b6818e29306c83a3b533b6df01c5.zip
Process the pkg-message template earlier than post-install so
package users will actually get to see it the right way. PR: ports/66123 Reported by: obrien
Notes
Notes: svn path=/head/; revision=108158
Diffstat (limited to 'x11/kdebase4/Makefile')
-rw-r--r--x11/kdebase4/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/x11/kdebase4/Makefile b/x11/kdebase4/Makefile
index 4d2f8252ffa1..5e7be64d5308 100644
--- a/x11/kdebase4/Makefile
+++ b/x11/kdebase4/Makefile
@@ -28,6 +28,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_XPM= yes
USE_REINPLACE= yes
+PKGMESSAGE= ${WRKDIR}/MESSAGE
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
@@ -65,14 +66,17 @@ post-configure:
${REINPLACE_CMD} -e 's/444/644/g' \
${WRKSRC}/kdesktop/init/Templates/Makefile
+post-build:
+ @${CAT} ${FILESDIR}/pkg-message | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
+ | ${SED} -e 's,%%X11BASE%%,${X11BASE},g' > ${PKGMESSAGE}
+
post-install:
${LOCALBASE}/bin/genkdmconf --no-old --in ${PREFIX}/share/config/kdm/default
${LOCALBASE}/bin/genkdmconf --no-backup --no-old-scripts --in ${PREFIX}/share/config/kdm
${RM} -f ${PREFIX}/share/apps/konsole/linux.desktop
${CHMOD} u+s ${PREFIX}/bin/kcheckpass
${CHGRP} kmem ${PREFIX}/bin/ksysguardd && \
- ${CHMOD} g+s ${PREFIX}/bin/ksysguardd
- @${CAT} ${PKGMESSAGE} | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
- | ${SED} -e 's,%%X11BASE%%,${X11BASE},g'
+ ${CHMOD} g+s ${PREFIX}/bin/ksysguard$d
+ ${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>