aboutsummaryrefslogtreecommitdiff
path: root/x11/kdebase4
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-12-14 06:13:10 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-12-14 06:13:10 +0000
commitf836caf7c119f58f2c213a24ce7e6243f363bfde (patch)
tree38f0d5b10d3418792c04e662c1508521e1f5a5fe /x11/kdebase4
parent049896f9de597028528d0c2cee18f47acdd9d8cc (diff)
downloadports-f836caf7c119f58f2c213a24ce7e6243f363bfde.tar.gz
ports-f836caf7c119f58f2c213a24ce7e6243f363bfde.zip
- better kdmrc config file handling:
* install kdmrc.dist and copy to kdmrc if it doesn't already exist. don't clobber user's custom kdmrc settings. * always install the scripts, even if the config directory exists * always generate the scripts (add --no-old) - remove rcsid from patch so it applies cleanly - bump PORTREVISION PR: 32537, 32660 Submitted by: Alan Eldridge <alane@geeksrus.net>
Notes
Notes: svn path=/head/; revision=51517
Diffstat (limited to 'x11/kdebase4')
-rw-r--r--x11/kdebase4/Makefile7
-rw-r--r--x11/kdebase4/files/patch-kdm::kfrontend::Makefile.am15
-rw-r--r--x11/kdebase4/files/patch-kdm::kfrontend::genkdmconf.c13
-rw-r--r--x11/kdebase4/files/patch-ksysguardd.c22
-rw-r--r--x11/kdebase4/pkg-plist4
5 files changed, 45 insertions, 16 deletions
diff --git a/x11/kdebase4/Makefile b/x11/kdebase4/Makefile
index 3e2388979c98..9c4478fed378 100644
--- a/x11/kdebase4/Makefile
+++ b/x11/kdebase4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= kdebase
PORTVERSION= 2.2.2
+PORTREVISION= 1
CATEGORIES?= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -82,5 +83,11 @@ post-configure:
post-install:
${CHMOD} u+s ${PREFIX}/bin/kcheckpass
+.for file in kdmrc
+.if !exists(${PREFIX}/share/config/kdm/${file})
+ @${CP} ${PREFIX}/share/config/kdm/${file}.dist \
+ ${PREFIX}/share/config/kdm/${file}
+.endif
+.endfor
.include <bsd.port.post.mk>
diff --git a/x11/kdebase4/files/patch-kdm::kfrontend::Makefile.am b/x11/kdebase4/files/patch-kdm::kfrontend::Makefile.am
new file mode 100644
index 000000000000..c5274c1096ac
--- /dev/null
+++ b/x11/kdebase4/files/patch-kdm::kfrontend::Makefile.am
@@ -0,0 +1,15 @@
+--- kdm/kfrontend/Makefile.am.~1.21.~ Sun Jul 29 00:56:28 2001
++++ kdm/kfrontend/Makefile.am Mon Dec 10 01:08:15 2001
+@@ -25,10 +25,8 @@
+ genkdmconf_LDADD = $(LIB_X11)
+
+ install-data-local:
+- @if test ! -d $(DESTDIR)$(kde_confdir)/kdm; then \
+- $(mkinstalldirs) $(DESTDIR)$(kde_confdir)/kdm; \
+- ./genkdmconf --in $(DESTDIR)$(kde_confdir)/kdm; \
+- fi
++ -$(mkinstalldirs) $(DESTDIR)$(kde_confdir)/kdm
++ ./genkdmconf --no-old --in $(DESTDIR)$(kde_confdir)/kdm
+
+ messages:
+ $(XGETTEXT) $(kdm_greet_SOURCES) -o $(podir)/kdmgreet.pot
diff --git a/x11/kdebase4/files/patch-kdm::kfrontend::genkdmconf.c b/x11/kdebase4/files/patch-kdm::kfrontend::genkdmconf.c
index 84fdeaf99ba2..6aeac3d4433e 100644
--- a/x11/kdebase4/files/patch-kdm::kfrontend::genkdmconf.c
+++ b/x11/kdebase4/files/patch-kdm::kfrontend::genkdmconf.c
@@ -1,5 +1,5 @@
---- kdm/kfrontend/genkdmconf.c.orig Wed Sep 5 08:15:47 2001
-+++ kdm/kfrontend/genkdmconf.c Tue Oct 23 04:04:22 2001
+--- kdm/kfrontend/genkdmconf.c.orig Mon Nov 5 21:40:03 2001
++++ kdm/kfrontend/genkdmconf.c Sun Dec 9 22:42:26 2001
@@ -212,7 +212,7 @@
*/
@@ -27,3 +27,12 @@
"-x " KDMCONF "/Xservers "
#endif
"$USER\n"
+@@ -1781,7 +1781,7 @@
+ }
+ addKdePath ("UserPath", DEF_USER_PATH);
+ addKdePath ("SystemPath", DEF_SYSTEM_PATH);
+- ASPrintf (&newkdmrc, "%s/kdmrc", newdir);
++ ASPrintf (&newkdmrc, "%s/kdmrc.dist", newdir);
+ f = Create (newkdmrc, kdmrcmode);
+ wrconf (f);
+ fclose (f);
diff --git a/x11/kdebase4/files/patch-ksysguardd.c b/x11/kdebase4/files/patch-ksysguardd.c
index 940aa4d327a5..e7a37616b367 100644
--- a/x11/kdebase4/files/patch-ksysguardd.c
+++ b/x11/kdebase4/files/patch-ksysguardd.c
@@ -1,15 +1,11 @@
---- ksysguard/ksysguardd/FreeBSD/ksysguardd.c 2001/11/17 02:01:46 1.5
-+++ ksysguard/ksysguardd/FreeBSD/ksysguardd.c 2001/11/17 06:16:15 1.6
-@@ -17,9 +17,11 @@
- along with this program; if not, write to the Free Software
- Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+--- ksysguard/ksysguardd/FreeBSD/ksysguardd.c.orig Sat Nov 10 00:17:04 2001
++++ ksysguard/ksysguardd/FreeBSD/ksysguardd.c Sun Dec 9 22:26:48 2001
+@@ -37,6 +37,8 @@
+ #include <sys/wait.h>
+ #include <unistd.h>
-- $Id: ksysguardd.c,v 1.2.6.1 2001/11/08 10:48:51 tokoe Exp $
-+ $Id: ksysguardd.c,v 1.6 2001/11/17 06:16:15 waba Exp $
- */
-
-+#include <config.h>
++#include "config.h"
+
- #include <ctype.h>
- #include <fcntl.h>
- #include <netdb.h>
+ #include "CPU.h"
+ #include "Command.h"
+ #include "Memory.h"
diff --git a/x11/kdebase4/pkg-plist b/x11/kdebase4/pkg-plist
index 3b9d7855dd8d..9e32ca59349f 100644
--- a/x11/kdebase4/pkg-plist
+++ b/x11/kdebase4/pkg-plist
@@ -1286,7 +1286,9 @@ share/config/kdm/Xsession
share/config/kdm/Xsetup
share/config/kdm/Xstartup
share/config/kdm/Xwilling
-share/config/kdm/kdmrc
+@unexec if test ! -f %D/share/config/kdm/kdmrc || cmp -s %D/share/config/kdm/kdmrc.dist %D/share/config/kdm/kdmrc; then rm -f %D/share/config/kdm/kdmrc; fi
+share/config/kdm/kdmrc.dist
+@exec if test ! -f %D/share/config/kdm/kdmrc; then rm -f %D/share/config/kdm/kdmrc; cp -p %D/share/config/kdm/kdmrc.dist %D/share/config/kdm/kdmrc; fi
share/config/klipperrc
share/config/konqsidebartng.rc
share/config/konsolerc