aboutsummaryrefslogtreecommitdiff
path: root/x11/kdelibs3
diff options
context:
space:
mode:
authorEd Schouten <ed@FreeBSD.org>2008-06-27 13:03:12 +0000
committerEd Schouten <ed@FreeBSD.org>2008-06-27 13:03:12 +0000
commit82dabcefbe8a70a1a7e471105f9f55b9b6446bc1 (patch)
tree6e00d5661c2c84effce90a7d709b423032ea4d4c /x11/kdelibs3
parent50b63bb4cb2273747d17e5a7a802365853fabc9e (diff)
downloadports-82dabcefbe8a70a1a7e471105f9f55b9b6446bc1.tar.gz
ports-82dabcefbe8a70a1a7e471105f9f55b9b6446bc1.zip
Prevent the usage of the CTRL() macro.
After my change to the CTRL() macro, the kpty code sets improper values to various control keys. Change the kpty code to use the constants from <sys/ttydefaults.h>. Approved by: philip (mentor)
Notes
Notes: svn path=/head/; revision=215834
Diffstat (limited to 'x11/kdelibs3')
-rw-r--r--x11/kdelibs3/Makefile2
-rw-r--r--x11/kdelibs3/files/patch-kdecore-kpty.cpp34
2 files changed, 35 insertions, 1 deletions
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index 5b36357ce24c..7772d47a51a7 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kdelibs3/files/patch-kdecore-kpty.cpp b/x11/kdelibs3/files/patch-kdecore-kpty.cpp
new file mode 100644
index 000000000000..1ac88614386d
--- /dev/null
+++ b/x11/kdelibs3/files/patch-kdecore-kpty.cpp
@@ -0,0 +1,34 @@
+--- kdecore/kpty.cpp
++++ kdecore/kpty.cpp
+@@ -127,9 +127,15 @@
+ #include <kdebug.h>
+ #include <kstandarddirs.h> // locate
+
+-// not defined on HP-UX for example
+-#undef CTRL
+-#define CTRL(x) ((x) & 037)
++#ifndef CINTR
++#define CINTR 0x03
++#endif
++#ifndef CQUIT
++#define CQUIT 0x1c
++#endif
++#ifndef CERASE
++#define CERASE 0x7f
++#endif
+
+ #define TTY_GROUP "tty"
+
+@@ -333,9 +339,9 @@
+ ttmode.c_iflag |= IUTF8;
+ #endif
+
+- ttmode.c_cc[VINTR] = CTRL('C' - '@');
+- ttmode.c_cc[VQUIT] = CTRL('\\' - '@');
+- ttmode.c_cc[VERASE] = 0177;
++ ttmode.c_cc[VINTR] = CINTR;
++ ttmode.c_cc[VQUIT] = CQUIT;
++ ttmode.c_cc[VERASE] = CERASE;
+
+ _tcsetattr(d->slaveFd, &ttmode);
+