aboutsummaryrefslogtreecommitdiff
path: root/x11/kdelibs4
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-07-02 19:04:18 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-07-02 19:04:18 +0000
commit18ff93d1a7890eb2f3b1c6249141e45a3e45e037 (patch)
tree2923053fc55dccac74b95b5ed97ba05ff2db25bb /x11/kdelibs4
parentf026ee1fe8da98244462007ccf598885ff54758f (diff)
downloadports-18ff93d1a7890eb2f3b1c6249141e45a3e45e037.tar.gz
ports-18ff93d1a7890eb2f3b1c6249141e45a3e45e037.zip
Update to KDE SC 4.10.4, proudly presented by the KDE on FreeBSD team.
With commits from avilla@, makc@, rakuco@ and Schaich Alonso. The upstream announcement can be found in [1]. [1] http://www.kde.org/announcements/announce-4.10.4.php clang support should be more stable now, with clang being recognized by kdelibs4 and being passed the correct flags to build other ports. Additionally, all ports being committed have been verified to build with -CURRENT's clang 3.3 on an amd64 tinderbox (special thanks go to swills@ for providing it). Work on the newly-released 4.10.5 will begin shortly.
Notes
Notes: svn path=/head/; revision=322191
Diffstat (limited to 'x11/kdelibs4')
-rw-r--r--x11/kdelibs4/Makefile1
-rw-r--r--x11/kdelibs4/distinfo4
-rw-r--r--x11/kdelibs4/files/patch-KDE4Defaults.cmake4
-rw-r--r--x11/kdelibs4/files/patch-cmake_modules_FindKDE4Internal.cmake64
-rw-r--r--x11/kdelibs4/files/patch-kioslave__http__http.cpp32
-rw-r--r--x11/kdelibs4/pkg-message2
6 files changed, 59 insertions, 48 deletions
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index a011ed3b1192..d9d32c4dbc8f 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -53,6 +53,7 @@ USE_QT4= corelib dbus declarative designer_build gui \
USE_XORG= sm x11 xcursor xext xfixes xrender xtst
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
+MAKE_ENV= XDG_CONFIG_HOME=/dev/null
CMAKE_ARGS+= -DWITH_ACL:BOOL=Off \
-DWITH_FAM:BOOL=On \
diff --git a/x11/kdelibs4/distinfo b/x11/kdelibs4/distinfo
index 0d4e85e8a6ec..f3de9ad15023 100644
--- a/x11/kdelibs4/distinfo
+++ b/x11/kdelibs4/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/4.10.3/kdelibs-4.10.3.tar.xz) = 5fbde0b372e6c2054ee3c620f3e465b452d2bf90a0c6ab3cc98d153e3a572cef
-SIZE (KDE/4.10.3/kdelibs-4.10.3.tar.xz) = 11981656
+SHA256 (KDE/4.10.4/kdelibs-4.10.4.tar.xz) = a1e570c76e8f31687510bb27de0b5af85c4a7b8b4145189f0e93217c2e4c4420
+SIZE (KDE/4.10.4/kdelibs-4.10.4.tar.xz) = 11786940
diff --git a/x11/kdelibs4/files/patch-KDE4Defaults.cmake b/x11/kdelibs4/files/patch-KDE4Defaults.cmake
index e0c7ded7e855..2a02bce93f52 100644
--- a/x11/kdelibs4/files/patch-KDE4Defaults.cmake
+++ b/x11/kdelibs4/files/patch-KDE4Defaults.cmake
@@ -4,13 +4,13 @@
# define the generic version of the libraries here
# this makes it easy to advance it when the next KDE release comes
# Use this version number for libraries which are at version n in KDE version n
--set(GENERIC_LIB_VERSION "4.10.3")
+-set(GENERIC_LIB_VERSION "4.10.4")
-set(GENERIC_LIB_SOVERSION "4")
+set(GENERIC_LIB_VERSION "5.0.1")
+set(GENERIC_LIB_SOVERSION "5")
# Use this version number for libraries which are already at version n+1 in KDE version n
--set(KDE_NON_GENERIC_LIB_VERSION "5.10.3")
+-set(KDE_NON_GENERIC_LIB_VERSION "5.10.4")
-set(KDE_NON_GENERIC_LIB_SOVERSION "5")
+set(KDE_NON_GENERIC_LIB_VERSION "7.0.1")
+set(KDE_NON_GENERIC_LIB_SOVERSION "7")
diff --git a/x11/kdelibs4/files/patch-cmake_modules_FindKDE4Internal.cmake b/x11/kdelibs4/files/patch-cmake_modules_FindKDE4Internal.cmake
index 3180d70d340c..6f73a6014299 100644
--- a/x11/kdelibs4/files/patch-cmake_modules_FindKDE4Internal.cmake
+++ b/x11/kdelibs4/files/patch-cmake_modules_FindKDE4Internal.cmake
@@ -1,22 +1,64 @@
---- ./cmake/modules/FindKDE4Internal.cmake.orig 2012-11-30 07:17:39.000000000 +0000
-+++ ./cmake/modules/FindKDE4Internal.cmake 2013-02-15 15:45:41.732493091 +0000
+--- cmake/modules/FindKDE4Internal.cmake.orig 2013-05-28 21:33:13.000000000 +0300
++++ cmake/modules/FindKDE4Internal.cmake 2013-06-23 15:03:18.000000000 +0300
@@ -893,8 +893,8 @@
_set_fancy(XDG_MIME_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/mime/packages" "The install dir for the xdg mimetypes")
_set_fancy(SYSCONF_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/etc" "The sysconfig install dir (default ${CMAKE_INSTALL_PREFIX}/etc)")
- _set_fancy(MAN_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/man" "The man install dir (default ${SHARE_INSTALL_PREFIX}/man/)")
- _set_fancy(INFO_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/info" "The info install dir (default ${SHARE_INSTALL_PREFIX}/info)")
-+ _set_fancy(MAN_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/man" "The man install dir (default ${SHARE_INSTALL_PREFIX}/man/)")
-+ _set_fancy(INFO_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/info" "The info install dir (default ${SHARE_INSTALL_PREFIX}/info)")
++ _set_fancy(MAN_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/man" "The man install dir (default ${CMAKE_INSTALL_PREFIX}/man/)")
++ _set_fancy(INFO_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/info" "The info install dir (default ${CMAKE_INSTALL_PREFIX}/info)")
_set_fancy(DBUS_INTERFACES_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/dbus-1/interfaces" "The dbus interfaces install dir (default ${SHARE_INSTALL_PREFIX}/dbus-1/interfaces)")
_set_fancy(DBUS_SERVICES_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/dbus-1/services" "The dbus services install dir (default ${SHARE_INSTALL_PREFIX}/dbus-1/services)")
_set_fancy(DBUS_SYSTEM_SERVICES_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/dbus-1/system-services" "The dbus system services install dir (default ${SHARE_INSTALL_PREFIX}/dbus-1/system-services)")
-@@ -1204,7 +1204,7 @@
- set(CMAKE_C_FLAGS_DEBUGFULL "-g3 -fno-inline")
- set(CMAKE_C_FLAGS_PROFILE "-g3 -fno-inline -ftest-coverage -fprofile-arcs")
+@@ -1304,6 +1304,50 @@
+ endif (CMAKE_COMPILER_IS_GNUCXX)
-- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-long-long -std=iso9899:1990 -Wundef -Wcast-align -Werror-implicit-function-declaration -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-common")
-+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-long-long -Wundef -Wcast-align -Werror-implicit-function-declaration -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-common")
- # As of Qt 4.6.x we need to override the new exception macros if we want compile with -fno-exceptions
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wnon-virtual-dtor -Wno-long-long -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-exceptions -DQT_NO_EXCEPTIONS -fno-check-new -fno-common")
++if (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
++ set (KDE4_ENABLE_EXCEPTIONS "-fexceptions -UQT_NO_EXCEPTIONS")
++ # Select flags.
++ set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "-O2 -g -DNDEBUG -DQT_NO_DEBUG")
++ set(CMAKE_CXX_FLAGS_RELEASE "-O2 -DNDEBUG -DQT_NO_DEBUG")
++ set(CMAKE_CXX_FLAGS_DEBUG "-g -O2 -fno-inline")
++ set(CMAKE_CXX_FLAGS_DEBUGFULL "-g3 -fno-inline")
++ set(CMAKE_CXX_FLAGS_PROFILE "-g3 -fno-inline -ftest-coverage -fprofile-arcs")
++ set(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2 -g -DNDEBUG -DQT_NO_DEBUG")
++ set(CMAKE_C_FLAGS_RELEASE "-O2 -DNDEBUG -DQT_NO_DEBUG")
++ set(CMAKE_C_FLAGS_DEBUG "-g -O2 -fno-inline")
++ set(CMAKE_C_FLAGS_DEBUGFULL "-g3 -fno-inline")
++ set(CMAKE_C_FLAGS_PROFILE "-g3 -fno-inline -ftest-coverage -fprofile-arcs")
++
++ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-long-long -std=iso9899:1990 -Wundef -Wcast-align -Werror-implicit-function-declaration -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-common")
++ # As of Qt 4.6.x we need to override the new exception macros if we want compile with -fno-exceptions
++ # set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wnon-virtual-dtor -Wno-long-long -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -Woverloaded-virtual -fno-exceptions -DQT_NO_EXCEPTIONS -fno-common -fvisibility=hidden -Werror=return-type -fvisibility-inlines-hidden")
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wnon-virtual-dtor -Wno-long-long -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -Woverloaded-virtual -fno-common -fvisibility=hidden -Werror=return-type -fvisibility-inlines-hidden -Wno-return-type-c-linkage")
++ set(KDE4_C_FLAGS "-fvisibility=hidden")
++
++ set(KDE4_CXX_FPIE_FLAGS "-fPIE")
++ set(KDE4_PIE_LDFLAGS "-pie")
++
++ if (CMAKE_SYSTEM_NAME STREQUAL GNU)
++ set (CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -pthread")
++ set (CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -pthread")
++ endif (CMAKE_SYSTEM_NAME STREQUAL GNU)
++
++ set(__KDE_HAVE_GCC_VISIBILITY TRUE)
++
++ # check that Qt defines Q_DECL_EXPORT as __attribute__ ((visibility("default")))
++ # if it doesn't and KDE compiles with hidden default visibiltiy plugins will break
++ set(_source "#include <QtCore/QtGlobal>\n int main()\n {\n #ifndef QT_VISIBILITY_AVAILABLE \n #error QT_VISIBILITY_AVAILABLE is not available\n #endif \n }\n")
++ set(_source_file ${CMAKE_BINARY_DIR}/CMakeTmp/check_qt_visibility.cpp)
++ file(WRITE "${_source_file}" "${_source}")
++ set(_include_dirs "-DINCLUDE_DIRECTORIES:STRING=${QT_INCLUDES}")
++ try_compile(_compile_result ${CMAKE_BINARY_DIR} ${_source_file} CMAKE_FLAGS "${_include_dirs}" OUTPUT_VARIABLE _compile_output_var)
++ if(NOT _compile_result)
++ message("${_compile_output_var}")
++ message(FATAL_ERROR "Qt compiled without support for -fvisibility=hidden. This will break plugins and linking of some applications. Please fix your Qt installation (try passing --reduce-exports to configure).")
++ endif(NOT _compile_result)
++endif (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
++
++
+ if (CMAKE_C_COMPILER MATCHES "icc")
+
+ set (KDE4_ENABLE_EXCEPTIONS -fexceptions)
diff --git a/x11/kdelibs4/files/patch-kioslave__http__http.cpp b/x11/kdelibs4/files/patch-kioslave__http__http.cpp
deleted file mode 100644
index 60842593ffbc..000000000000
--- a/x11/kdelibs4/files/patch-kioslave__http__http.cpp
+++ /dev/null
@@ -1,32 +0,0 @@
-commit 65d736dab592bced4410ccfa4699de89f78c96ca
-Author: Grégory Oestreicher <greg@kamago.net>
-Date: Wed May 8 23:16:00 2013 +0200
-
- Don't show passwords contained in HTTP URLs in error messages
- BUG: 319428
-
-diff --git a/kioslave/http/http.cpp b/kioslave/http/http.cpp
-index 2d139a9..129fc7b 100644
---- ./kioslave/http/http.cpp
-+++ ./kioslave/http/http.cpp
-@@ -3056,7 +3056,7 @@ try_again:
- ; // Ignore error
- } else {
- if (!sendErrorPageNotification()) {
-- error(ERR_INTERNAL_SERVER, m_request.url.url());
-+ error(ERR_INTERNAL_SERVER, m_request.url.prettyUrl());
- return false;
- }
- }
-@@ -3072,9 +3072,9 @@ try_again:
- // Tell that we will only get an error page here.
- if (!sendErrorPageNotification()) {
- if (m_request.responseCode == 403)
-- error(ERR_ACCESS_DENIED, m_request.url.url());
-+ error(ERR_ACCESS_DENIED, m_request.url.prettyUrl());
- else
-- error(ERR_DOES_NOT_EXIST, m_request.url.url());
-+ error(ERR_DOES_NOT_EXIST, m_request.url.prettyUrl());
- return false;
- }
- } else if (m_request.responseCode >= 301 && m_request.responseCode<= 303) {
diff --git a/x11/kdelibs4/pkg-message b/x11/kdelibs4/pkg-message
index c884bc59d618..81747701bee7 100644
--- a/x11/kdelibs4/pkg-message
+++ b/x11/kdelibs4/pkg-message
@@ -2,7 +2,7 @@
Due to severe instability, the Solid UPnP backend was disabled. Thus,
you will not get notifications about networked shares in the device
-notifier. The UPnP functionality can be reenabled by setting the
+notifier. The UPnP functionality can be re-enabled by setting the
SOLID_UPNP environment variable:
$ cat > ~/.kde4/env/upnp.sh << EOF