aboutsummaryrefslogtreecommitdiff
path: root/x11/libgnome
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-05-20 22:42:49 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-05-20 22:42:49 +0000
commite635725aa92f5c28dfbbe5a7084e83898f0a1376 (patch)
treec7fee9554462d94cab373b43b4056121cc42460f /x11/libgnome
parentb8cccc78d24296fe06ad80cb1bb9acf086086f1e (diff)
downloadports-e635725aa92f5c28dfbbe5a7084e83898f0a1376.tar.gz
ports-e635725aa92f5c28dfbbe5a7084e83898f0a1376.zip
Fix some help related paths. Bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=59562
Diffstat (limited to 'x11/libgnome')
-rw-r--r--x11/libgnome/Makefile1
-rw-r--r--x11/libgnome/files/patch-libgnome_gnome-program.c28
2 files changed, 27 insertions, 2 deletions
diff --git a/x11/libgnome/Makefile b/x11/libgnome/Makefile
index c87cb41d9d65..cfd2b96b65a6 100644
--- a/x11/libgnome/Makefile
+++ b/x11/libgnome/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libgnome
PORTVERSION= 1.117.0
+PORTREVISION= 1
CATEGORIES?= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta5
diff --git a/x11/libgnome/files/patch-libgnome_gnome-program.c b/x11/libgnome/files/patch-libgnome_gnome-program.c
index 4c3c6b33cea4..eddd1f28db8c 100644
--- a/x11/libgnome/files/patch-libgnome_gnome-program.c
+++ b/x11/libgnome/files/patch-libgnome_gnome-program.c
@@ -1,5 +1,5 @@
---- libgnome/gnome-program.c.orig Fri May 17 20:18:53 2002
-+++ libgnome/gnome-program.c Fri May 17 20:19:50 2002
+--- libgnome/gnome-program.c.orig Fri Mar 22 11:02:45 2002
++++ libgnome/gnome-program.c Mon May 20 18:28:24 2002
@@ -882,12 +882,12 @@
attr_rel = "";
break;
@@ -15,6 +15,15 @@
attr_name = GNOME_PARAM_GNOME_DATADIR;
attr_rel = "/pixmaps";
break;
+@@ -899,7 +899,7 @@
+ case GNOME_FILE_DOMAIN_HELP:
+ prefix_rel = "/share/gnome/help";
+ attr_name = GNOME_PARAM_GNOME_DATADIR;
+- attr_rel = "/gnome/help";
++ attr_rel = "/help";
+ break;
+ case GNOME_FILE_DOMAIN_APP_LIBDIR:
+ prefix_rel = "/lib";
@@ -914,13 +914,13 @@
search_path = FALSE;
break;
@@ -31,3 +40,18 @@
attr_name = GNOME_PARAM_APP_DATADIR;
attr_rel = "/pixmaps";
search_path = FALSE;
+@@ -941,12 +941,12 @@
+
+ attr_name = GNOME_PARAM_APP_DATADIR;
+
+- len = strlen ("/gnome/help/") +
++ len = strlen ("/help/") +
+ strlen (program->_priv->app_id) + 1;
+ attr_rel = g_alloca (len);
+ if (attr_rel == NULL /* bad things */)
+ return NULL;
+- g_snprintf (attr_rel, len, "/gnome/help/%s", program->_priv->app_id);
++ g_snprintf (attr_rel, len, "/help/%s", program->_priv->app_id);
+
+ search_path = FALSE;
+ break;