aboutsummaryrefslogtreecommitdiff
path: root/x11/libgnome
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-22 20:13:24 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-22 20:13:24 +0000
commit8a1cf1d31b7cd3e8a6c1d8f0a3ebbc7ad79425b3 (patch)
tree6c00a2bd5bee984817b0b55c09b578ad1991fb59 /x11/libgnome
parent3f8a2e2eec18531ce6c75caab85172ae8cef1f47 (diff)
downloadports-8a1cf1d31b7cd3e8a6c1d8f0a3ebbc7ad79425b3.tar.gz
ports-8a1cf1d31b7cd3e8a6c1d8f0a3ebbc7ad79425b3.zip
Hopefully fix the Help problem once and for all. This adjusts the DATADIR
parameters to be share/gnome/... instead of share/... Tested by: adamw Jeremy Messenger <mezz7@cox.net> Franz Klammer <klammer@webonaut.com>
Notes
Notes: svn path=/head/; revision=96464
Diffstat (limited to 'x11/libgnome')
-rw-r--r--x11/libgnome/Makefile2
-rw-r--r--x11/libgnome/files/patch-libgnome_gnome-program.c34
2 files changed, 32 insertions, 4 deletions
diff --git a/x11/libgnome/Makefile b/x11/libgnome/Makefile
index 5d83cf8d0163..370a7878c7ff 100644
--- a/x11/libgnome/Makefile
+++ b/x11/libgnome/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libgnome
PORTVERSION= 2.4.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES?= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.4
diff --git a/x11/libgnome/files/patch-libgnome_gnome-program.c b/x11/libgnome/files/patch-libgnome_gnome-program.c
index c480676d5901..90fcdd22c777 100644
--- a/x11/libgnome/files/patch-libgnome_gnome-program.c
+++ b/x11/libgnome/files/patch-libgnome_gnome-program.c
@@ -1,6 +1,12 @@
--- libgnome/gnome-program.c.orig Wed Jul 23 05:35:30 2003
-+++ libgnome/gnome-program.c Tue Dec 9 17:25:38 2003
-@@ -899,12 +899,12 @@
++++ libgnome/gnome-program.c Mon Dec 22 01:19:23 2003
+@@ -894,17 +894,17 @@
+ attr_rel = "";
+ break;
+ case GNOME_FILE_DOMAIN_DATADIR:
+- prefix_rel = "/share";
++ prefix_rel = "/share/gnome";
+ attr_name = GNOME_PARAM_GNOME_DATADIR;
attr_rel = "";
break;
case GNOME_FILE_DOMAIN_SOUND:
@@ -24,7 +30,14 @@
break;
case GNOME_FILE_DOMAIN_APP_LIBDIR:
prefix_rel = "/lib";
-@@ -931,13 +931,13 @@
+@@ -925,19 +925,19 @@
+ search_path = FALSE;
+ break;
+ case GNOME_FILE_DOMAIN_APP_DATADIR:
+- prefix_rel = "/share";
++ prefix_rel = "/share/gnome";
+ attr_name = GNOME_PARAM_APP_DATADIR;
+ attr_rel = "";
search_path = FALSE;
break;
case GNOME_FILE_DOMAIN_APP_SOUND:
@@ -40,3 +53,18 @@
attr_name = GNOME_PARAM_APP_DATADIR;
attr_rel = "/pixmaps";
search_path = FALSE;
+@@ -958,12 +958,12 @@
+
+ attr_name = GNOME_PARAM_APP_DATADIR;
+
+- len = strlen ("/gnome/help/") +
++ len = strlen ("/help/") +
+ strlen (program->_priv->app_id) + 1;
+ attr_rel = g_alloca (len);
+ if (attr_rel == NULL /* bad things */)
+ return NULL;
+- g_snprintf (attr_rel, len, "/gnome/help/%s", program->_priv->app_id);
++ g_snprintf (attr_rel, len, "/help/%s", program->_priv->app_id);
+
+ search_path = FALSE;
+ break;