aboutsummaryrefslogtreecommitdiff
path: root/x11/mlterm/Makefile
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2006-05-21 10:33:59 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2006-05-21 10:33:59 +0000
commitba5442310268cb9a6bf47352a293357449102e9a (patch)
tree6b1e5a685fe3f646e5ef136b0bb645dbbb7c2fd6 /x11/mlterm/Makefile
parentdd2b0c80ff1aa1d4f2210f03cdcfc973c718ecaf (diff)
downloadports-ba5442310268cb9a6bf47352a293357449102e9a.tar.gz
ports-ba5442310268cb9a6bf47352a293357449102e9a.zip
- Update to 2.9.3. [1]
- Add --disable-* options to CONFIGURE_ARGS to disable options actually. PR: ports/97543 [1] Submitted by: KIMURA Yasuhiro <yasu@utahime.org> [1]
Notes
Notes: svn path=/head/; revision=162925
Diffstat (limited to 'x11/mlterm/Makefile')
-rw-r--r--x11/mlterm/Makefile33
1 files changed, 24 insertions, 9 deletions
diff --git a/x11/mlterm/Makefile b/x11/mlterm/Makefile
index 6603c32156f9..000bff9ab358 100644
--- a/x11/mlterm/Makefile
+++ b/x11/mlterm/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mlterm
-PORTVERSION= 2.9.2
-PORTREVISION= 2
+PORTVERSION= 2.9.3
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -25,15 +24,18 @@ CONFIGURE_ARGS= --with-imagelib=gdk-pixbuf --enable-utmp \
CONFIGURE_ENV= LIBS=-L${LOCALBASE}/lib CFLAGS=-I${LOCALBASE}/include
OPTIONS= FRIBIDI "Use Fribidi for BiDi rendering" off \
- UIM "uim support" off \
- M17NLIB "m17n library support" off \
- IIIMF "IIIMF support (broken)" off
+ UIM "uim support (experimental)" off \
+ M17NLIB "m17n library support (experimental)" off \
+ IIIMF "IIIMF support (experimental)" off \
+ SCIM "SCIM support (experimental)" off
.include <bsd.port.pre.mk>
.if defined(WITH_FRIBIDI)
CONFIGURE_ARGS+= --enable-fribidi
LIB_DEPENDS+= fribidi.0:${PORTSDIR}/converters/fribidi
+.else
+CONFIGURE_ARGS+= --disable-fribidi
.endif
.if defined(WITH_UIM)
@@ -42,6 +44,7 @@ MAKE_ENV= LIBS_LOCAL=-L${LOCALBASE}/lib
LIB_DEPENDS+= uim.1:${PORTSDIR}/textproc/uim
PLIST_SUB+= UIM=""
.else
+CONFIGURE_ARGS+= --disable-uim
PLIST_SUB+= UIM="@comment "
.endif
@@ -51,6 +54,7 @@ MAKE_ENV= LIBS_LOCAL=-L${LOCALBASE}/lib
LIB_DEPENDS+= m17n.1:${PORTSDIR}/devel/m17n-lib
PLIST_SUB+= M17NLIB=""
.else
+CONFIGURE_ARGS+= --disable-m17nlib
PLIST_SUB+= M17NLIB="@comment "
.endif
@@ -60,22 +64,33 @@ EXTRA_PATCHES= ${PATCHDIR}/extra-patch-inputmethod:iiimf:im_iiimf.c
.endif
CONFIGURE_ARGS+= --enable-iiimf
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" CFLAGS=-I${LOCALBASE}/include
-MAKE_ENV= LIBS_LOCAL="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" CFLAGS_LOCAL="-I${LOCALBASE}/include/iiimf -I${LOCALBASE}/include/iiimf/iiimp"
-LIB_DEPENDS+= iiimcf.2:${PORTSDIR}/textproc/iiimf-client-lib
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" CFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/iiim"
+LIB_DEPENDS+= iiimcf.3:${PORTSDIR}/textproc/iiimf-client-lib
PLIST_SUB+= IIIMF=""
.else
+CONFIGURE_ARGS+= --disable-iiimf
PLIST_SUB+= IIIMF="@comment "
.endif
+.if defined(WITH_SCIM)
+CONFIGURE_ARGS+= --enable-scim
+MAKE_ENV= LIBS_LOCAL=-L${LOCALBASE}/lib
+LIB_DEPENDS+= scim-1.0.9:${PORTSDIR}/textproc/scim
+PLIST_SUB+= SCIM=""
+.else
+CONFIGURE_ARGS+= --disable-scim
+PLIST_SUB+= SCIM="@comment "
+.endif
+
INSTALLS_SHLIB= yes
MAN1= mlterm.1 mlclient.1
.if ${X_WINDOW_SYSTEM:L} == xfree86-3
PKGNAMESUFFIX= -noaa
+CONFIGURE_ARGS+= --with-type-engines=xcore
.else
-CONFIGURE_ARGS+= --enable-anti-alias
+CONFIGURE_ARGS+= --with-type-engines="xcore,xft"
LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
.endif